Contribute
Register

Thunderbolt only works about 30% of the time on 2018 Razer Blade 15

Joined
Jan 6, 2017
Messages
32
Motherboard
Dell Optiplex 3011 AIO
CPU
i7-3770K
Graphics
HD 4000, 1600x900
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac Pro
Classic Mac
  1. Apple
  2. Classic
  3. eMac
  4. iBook
  5. iMac
  6. Performa
  7. Power Mac
  8. PowerBook
  9. Xserve
Mobile Phone
  1. iOS
Hi everyone, I'm running Catalina on my 2018 Razer Blade 15 Advanced and recently purchased a third monitor (two external + the laptop display) to add to my setup. I needed a way to connect it to the intel UHD630 on this machine as the Nvidia card obviously isn't supported, so I decided to replace my USB-C hub with HDMI for an Elgato Thunderbolt 3 Mini dock, which features two simultaneous display outputs that could connect to the iGPU through the thunderbolt port. The HDMI so far hasn't had any issues at all, and I was able to test the displayport as well (had to borrow my brother's monitor, waiting for a DP to DVI adapter to come in) and that all works fine. However, the dock also includes Ethernet and a USB3.0 controller. These two rarely are detected by macOS, sometimes at random after a reboot the ethernet and USB3 will detect in system profiler, sometimes only the USB3, but most of the time neither are detected at all and I cannot figure out what is causing it to work or not work. So far i've tried messing with thunderbolt settings in my BIOS, changing opencore EFIs, and messing with the Elgato utility but beyond that i'm not sure what else to try. Everywhere online seems to mention that the thunderbolt should just work on my machine, with some saying i need a custom firmware to get some things working properly (like hot plugging, which i don't really need but it would be nice) but don't mention anything about actually applying said firmware for my specific system/thunderbolt controller, and I can't find anything that matches on google. Also, I should mention that so far the dock has worked flawlessly on windows and in macOS, under system profiler it just says "No drivers are loaded" or "No hardware was found." when i boot the computer with the dock unplugged. I should also note that i have previously tried to get a Dell thunderbolt dock working, and might've messed around with my current macOS install. Ended up that the dock itself was faulty though (it wouldn't even detect under windows or linux), so I just returned it and never found out for sure if thunderbolt was working properly. That being said, i did try booting into a recovery partition (which should have stock kexts and all that afaik) and it wasn't able to recognize the USB drive i plugged into it. Any suggestions? Are there maybe custom drivers i should be using, or does anyone know of a guide i can follow to flash firmware on my machine? I have an i7-8750H and JHL6340 (Alpine Ridge 2C 2016) Thunderbolt 3 controller.
 
Top