Contribute
Register

Thunderbolt Help - OpenCore Asus Z590M-Plus with i9 10850k and ThunderboltEX 4 AIC

Joined
Sep 23, 2021
Messages
1
Motherboard
Asus Prime Z590M-PLUS
CPU
Intel i9 10850k
Graphics
Sapphire Pulse Radeon RX 5500XT
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Everything on this build works the way I need it to except that my system will not boot when thunderbolt is enabled in bios. The controller still acts as a USB 3.2 interface, so when thunderbolt is off the ports are still available (and by some miracle deliver signals to both my LG 5k and LG 4k Ultrafine displays) but none of the I/O are recognized at thunderbolt by the system, so features like daisy chaining do not work.

I used a configured ThunderboltEX 3 SSDT to get the card working with my system, but no configuration of BIOS setting seems to get the ports recognized as thunderbolt.

Obviously I'm pretty sure I'm one of the first to be trying to get this particular setup working properly, so I don't really expect anybody to have an answer, but I would appreciate help troubleshooting to try and get thunderbolt working properly and will gladly make a guide out of it if we can get it working.

My build:
CPU: i9 10850k
Mobo: Asus Prime Z590m-plus
GPU: Sapphire Pulse Radeon Rx 5500XT 8gb
Wifi/BT: Fenvi t-919
Ethernet: Intel i219v
Audio: Realtek ALC 897
RAM: Corsair Vengeance LPX 3200 64gb
Thunderbolt AIC: Asus ThunderboltEX 4 (intel JHL8540 thunderbolt controller)
MacOS: 11.6
OpenCore: 7.3

Thanks
 
Last edited:
Joined
Feb 5, 2015
Messages
32
Motherboard
Lenovo P520C
CPU
W-2150B
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
This seems to be a normal behaviour, the Thunderbolt ports won't get recognised in macOS but they just work.

I have a Gigabyte Z590I Vision D, it has the same "issue".

Also it won't support Thunderbolt Hotplug.
 

etc

Joined
Dec 7, 2018
Messages
56
Motherboard
ROG Z490-E
CPU
10700K
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. iOS
Everything on this build works the way I need it to except that my system will not boot when thunderbolt is enabled in bios. The controller still acts as a USB 3.2 interface, so when thunderbolt is off the ports are still available (and by some miracle deliver signals to both my LG 5k and LG 4k Ultrafine displays) but none of the I/O are recognized at thunderbolt by the system, so features like daisy chaining do not work.

I used a configured ThunderboltEX 3 SSDT to get the card working with my system, but no configuration of BIOS setting seems to get the ports recognized as thunderbolt.

Obviously I'm pretty sure I'm one of the first to be trying to get this particular setup working properly, so I don't really expect anybody to have an answer, but I would appreciate help troubleshooting to try and get thunderbolt working properly and will gladly make a guide out of it if we can get it working.

My build:
CPU: i9 10850k
Mobo: Asus Prime Z590m-plus
GPU: Sapphire Pulse Radeon Rx 5500XT 8gb
Wifi/BT: Fenvi t-919
Ethernet: Intel i219v
Audio: Realtek ALC 897
RAM: Corsair Vengeance LPX 3200 64gb
Thunderbolt AIC: Asus ThunderboltEX 4 (intel JHL8540 thunderbolt controller)
MacOS: 11.6
OpenCore: 7.3

Thanks
So your 5K UltraFine uses 4K as base resolution for scaling? And you see boot screen when both display ports connected to the AIC?
 
Joined
Jan 23, 2021
Messages
1
Motherboard
NP940X5N-X01US
CPU
Intel i7-885U @1.80.Ghz
Graphics
Radeon 540
Hi, my set up is actually very similar to yours and im having a hard time. Could I see your EFI so I can compare?
 
Top