Contribute
Register

[?] Thunderbolt 3 (and UAD-2) on Gigabyte Z170X GA5

Status
Not open for further replies.
Joined
Jan 4, 2016
Messages
53
Motherboard
Gigabyte Z170X Gaming 5
CPU
i7-6700K
Graphics
RX 5700 XT
Mac
  1. iMac
Mobile Phone
  1. Android
Hi,

TL;DR:
I have a Gigabyte Z170X Gaming 5 and Intel i7 6700K, and I was wondering if I can install a PCIe to Thunderbolt 3 card.
Do you have any experience whit this motherboard? In case which card you have?
Other question... Has anybody ever tried to install a UAD-2 Octo PCIe (https://www.uaudio.com/uad-accelerators/uad-2-pcie.html) on a Z170X GA5? Does it work?

Longer version:
I am considering to buy a UAD-2 satellite card, sadly this card is only available (for macOS) with two interfaces: PCIe or Thunderbolt (no USB 3).
I would prefer to buy the Thunderbolt version in order to easily move to another PC/iMac (in the future), but if the Thunderbolt option is not applicable (due to compatibility issue with my motherboard), I would opt for the PCIe format.

Thank you.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,141
Motherboard
Gigabyte Z690 Aero G
CPU
i5-12600K
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
You need to check Gigabyte's website to see if this motherboard has a Thunderbolt hearder. If not, then it will not support any of the Thunderbolt PCIe add-on cards.
 
Joined
Jan 4, 2016
Messages
53
Motherboard
Gigabyte Z170X Gaming 5
CPU
i7-6700K
Graphics
RX 5700 XT
Mac
  1. iMac
Mobile Phone
  1. Android
The funny thing is that seems impossible to find this card (GC-Alpine Ridge) in any reliable shop in Europe! :banghead:
I think I will opt for PCIe format... Hoping that will work with my motherboard!
 
Joined
Aug 17, 2017
Messages
308
Motherboard
ASUS Prime X299 Edition 30
CPU
i9-10980XE
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Joined
Jan 4, 2016
Messages
53
Motherboard
Gigabyte Z170X Gaming 5
CPU
i7-6700K
Graphics
RX 5700 XT
Mac
  1. iMac
Mobile Phone
  1. Android
...And I guess it works (since you're smiling) ;)
 
Joined
Jan 4, 2016
Messages
53
Motherboard
Gigabyte Z170X Gaming 5
CPU
i7-6700K
Graphics
RX 5700 XT
Mac
  1. iMac
Mobile Phone
  1. Android
Wow! You found it! It was not available some days ago!

Thank you! :thumbup:
 
Joined
Jul 20, 2017
Messages
32
Motherboard
Gigabyte Z170x ATX Gaming 5
CPU
I7-7700K
Graphics
GTX 1050
Mac
  1. MacBook Pro
  2. Mac Pro
I have this same motherboard (Z170x G5) and have the Alpine Ridge rev. 2.0 working in Windows, but have been unable to get it to work in macOS Sierra. Trying to get Apollo Twin MKII Quad Interface to work (Again, it works in windows). Any suggestions? Have tried:
  • Booting into Windows first then restarting to macOS (If rebooting is different than restarting please tell me)
  • Turning on Apollo first then powering on.
  • Changing BIOS to Legacy
  • Turning Security Level to NONE
  • Deleting TB .Kexts (none to delete)
If you need more info, please let me know.
 
Last edited:
Status
Not open for further replies.
Top