Contribute
Register

The Perfect Customac-Pro: X99-A II, i7-6950X, 128GB G.Skill TridentZ, Aorus GTX 1080 TI Xtreme

Status
Not open for further replies.

kgp

Retired
Joined
May 30, 2014
Messages
6,783
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Can you try something? Go To System Preferences>Energy Saver>Put hard disks to sleep when possible (UNCHECK THIS) and try to wake from sleep. Reboot then try.

you have a NVME right?

Done! No difference! reboot on wake!

Yes I have an NVMe. But I have a backsystem on SSD. To exclude NVMe as a source of reboot on wake, I removed it once and tried everything with the SSD. No difference!

NVMe is definitely not the source for reboot on wake...
 
Joined
Jul 26, 2011
Messages
64
Motherboard
Gigabyte x99 Ultra Gaming Rev 1.0
CPU
Intel Core i7 5820K
Graphics
Nvidia GTX 1080 Founder Edition
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. Android
  2. iOS
Have you looked for anything odd in console
 

kgp

Retired
Joined
May 30, 2014
Messages
6,783
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Have you looked for anything odd in console

As for instance? What do you mean by console? What and where should it I check?
 
Joined
Nov 17, 2010
Messages
170
Motherboard
Asus X-99 A II
CPU
i7-6900K
Graphics
Titan X Maxwell
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
As for instance? What do you mean by console? What and where should it I check?
Sorry it took so long to get back to this. Clients..
OK So I get an immediate reboot on forced Sleep.
I am down to keep banging on this and see what we come up with. I never put my machine to sleep (Editors don't actually sleep) so it's not a big deal to me. I totally failed at getting the Clover ALC Audio command to work. I am back to using the Apple.ALC. Kext and CodecCommander.kext

I plugged in a HDMI Monitor to check sound and it does work. Remember though I created an SSDT for my Nvidia to deal with booting with multiple monitors.

Screen Shot 2017-04-26 at 5.55.20 PM.png
 
Joined
Mar 20, 2016
Messages
31
Motherboard
Gigabyte Z270X-Gaming K5
CPU
i7-7700K
Graphics
GTX 1070
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
1.) :!::!::!::!: "OsxAptioFix2Drv-free2000.efi" needs to be in /EFI/CLOVER/Drivers64UEFI/ :!::!::!::!: An efi-file is not a kext-file :!::!::!::!:
There should not be any other "OsxAptioFixDrv**.efi" files in /EFI/CLOVER/Drivers64UEFI/
2.) If you did not mess up 1) the reason for your random reboots must be 2) the RAM memory. There is no other alternative :!:
3.) The SSDT-1.aml is for NVMe. Unless you do have a NVMe drive, you do not need it. If you have one, create your own NVme.aml following my guide.

I now that all help is appreciated on your side, but you also have to consider and follow my advices. Otherwise, my help might be just a waste of time...

Cheers,

KGP
thank you! for some reason now if boots up fine now every time and it has not been having any random reboots for a long time now, I let my computer powered on for about 2 hours and it still was without any reboot, the thing I did was just to add the OsxAptioFix2Drv-free2000.efi file again in the drivers64uefi, it was there before, but just replaced it and now it work for some reason hehe, but thank you so much for the help and the guide you made available for us who want to hackintosh :D
 
Joined
Jan 17, 2011
Messages
181
Motherboard
Asus Prime Z370-A
CPU
i7-8700K
Graphics
2xGTX 980 Ti, 1xGTX 970, UHD 630
Mobile Phone
  1. Android
  2. iOS
@KevinAGI, you mentioned in one of your former preplies, that you got native audio to work on your X99 Deluxe II. Could you explain the individual steps and attach the necessary files

The best way to get audio working on most Hackintosh computers is AppleALC
https://github.com/vit9696/AppleALC

It survives updates and uses oryginal Apple audio kext.

As far as HDMI audio is concerned follow the shilohh guide from the link below to get it working:
https://www.tonymacx86.com/threads/ssdt-gpu-graphics-card-injection.183354/
 
Last edited:
Joined
Jan 17, 2011
Messages
181
Motherboard
Asus Prime Z370-A
CPU
i7-8700K
Graphics
2xGTX 980 Ti, 1xGTX 970, UHD 630
Mobile Phone
  1. Android
  2. iOS
Done! No difference! reboot on wake!

Yes I have an NVMe. But I have a backsystem on SSD. To exclude NVMe as a source of reboot on wake, I removed it once and tried everything with the SSD. No difference!

NVMe is definitely not the source for reboot on wake...

Please install VoodooTSCSyn.kext (with proper edit) in Clover/kexts/10.12/ folder and check the difference. Somebody reported this helps reboots on wake from sleep.
 
Joined
Nov 17, 2010
Messages
170
Motherboard
Asus X-99 A II
CPU
i7-6900K
Graphics
Titan X Maxwell
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
The best way to get audio working on most Hackintosh computers is AppleALC
https://github.com/vit9696/AppleALC

It survives updates and uses oryginal Apple audio kext.

As far as HDMI audio is concerned follow the shilohh guide from the link below to get it working:
https://www.tonymacx86.com/threads/ssdt-gpu-graphics-card-injection.183354/
Thanks @beep That is exactly what I am doing with the addition of CodecCommander.kext. I'm not sure if I actually need that, but it is what the guide I read was using. Why should we have to use VoodooTSCSyn.kext with this build? We have proper boot with the Methods described on the first page.

Kevin
 

kgp

Retired
Joined
May 30, 2014
Messages
6,783
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Please install VoodooTSCSyn.kext (with proper edit) in Clover/kexts/10.12/ folder and check the difference. Somebody reported this helps reboots on wake from sleep.

Does not help either... :thumbdown
 

kgp

Retired
Joined
May 30, 2014
Messages
6,783
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
The best way to get audio working on most Hackintosh computers is AppleALC
https://github.com/vit9696/AppleALC

It survives updates and uses oryginal Apple audio kext.

As far as HDMI audio is concerned follow the shilohh guide from the link below to get it working:
https://www.tonymacx86.com/threads/ssdt-gpu-graphics-card-injection.183354/

The easiest way to get audio working on your hack is definitely VoodooHDA.kext, which can be downloaded from sourceforge. Its latest version, VoodooHDA.kext-289.zip works absolutely flawless and results in brilliant audio quality. It also directly enables HDMI Audio without any additional patching.

For testing I tried to compile the AppleALC source code distribution linked above with xcode. It did not work: 1 failure message. And as far I know, the shilohh guide refers to Maxwell GPUs and does not work for Pascal graphic cards, does it?

Cheers,

KGP
 
Last edited:
Status
Not open for further replies.
Top