Contribute
Register

The Perfect Customac-Pro: X99-A II, i7-6950X, 128GB G.Skill TridentZ, Aorus GTX 1080 TI Xtreme

Joined
May 28, 2016
Messages
69
Motherboard
ASUS X99 A II
CPU
I7 6900k
Graphics
GTX 970
I tried to install the thunderboltEX2 card under windows 10, it seems to be recognized, but it is not written thunderboltEX2 it just say thunderbolt device.

But when i come back to OSX , sometime just with thunderbolt card it goes, but when i put the prmise2r6 , i have a logo , a round crossed, and it freeze on it.

It just fully started 1 time with the pegasus2r6, and in device report i saw under "thunderbolt" section, pegasus2r , but i didn't see it in finder...

Maybe i don't put the correct bios setup.

Anybody can help me?

Thanks in advance.
 
Joined
May 28, 2016
Messages
69
Motherboard
ASUS X99 A II
CPU
I7 6900k
Graphics
GTX 970
I have question, on most of post when a i see bios configuration for thunderbolt, it is written thunderbolt(TM) support.
In my bios it is written thunderbolt(R) support, does it meens that my card thunderboltEX2 is not realy recognized?
And when the thunderboltEX2 card si well installed, we should see it in "about my mac/system report/thunderbolt " section , right?

Thanks.
 
Last edited:
Joined
May 28, 2016
Messages
69
Motherboard
ASUS X99 A II
CPU
I7 6900k
Graphics
GTX 970
YES! i succeded ! so my pegasus is recognized, but the thunderbolt card does no appear in system report. I just used the bios setup in this thread : https://www.tonymacx86.com/threads/the-perfect-customac-pro-x99-a-ii-i7-6950x-128gb-g-skill-tridentz-aorus-gtx-1080-ti-xtreme.211621/page-36

About the setup, what "legacy" does really mean? before i had "unique ID" in security level.

But i don't think it is optimal because with speed disk test i have speed about 500Mb/s but when i plug it to my mac mini thunderbolt port , i have about 700 MB/s. Do you have an idea?
And the promiss utility doesn't work.

Thanks.
 

kgp

Joined
May 30, 2014
Messages
6,611
Motherboard
Asus Prime X299 Deluxe
CPU
i9-7980XE
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
YES! i succeded ! so my pegasus is recognized, but the thunderbolt card does no appear in system report. I just used the bios setup in this thread : https://www.tonymacx86.com/threads/the-perfect-customac-pro-x99-a-ii-i7-6950x-128gb-g-skill-tridentz-aorus-gtx-1080-ti-xtreme.211621/page-36

About the setup, what "legacy" does really mean? before i had "unique ID" in security level.

But i don't think it is optimal because with speed disk test i have speed about 500Mb/s but when i plug it to my mac mini thunderbolt port , i have about 700 MB/s. Do you have an idea?
And the promiss utility doesn't work.

Thanks.
Legacy means "no password", no "unique ID", etc. and is the correct way.

Where do you expect your TB card to show up in Apple's system report?

To properly implement the NHI and XHC PCI drivers for your TB adaptor under Section "PCI" of Apple's system report and to achieve working TB and USB hot plug, you need to implement SSDT-X99-TB3HP.aml described and linked in my 10.13. and 10.14 X99 iMacPro guides, as I already mentioned repetitively to you!

Nevertheless, under "Thunderbolt" you will still find "no drivers implemented" as nobody is able so far to correctly implement the complete local TB node. However, already with properly loaded TB NHI and XHC drivers your TB adaptor should work flawless including TB and USB hot plug.
 
Joined
Sep 18, 2018
Messages
2
Motherboard
Asus X99-E WS USB3.1
CPU
i7-6950X
Graphics
Vega 64
Mac
iMac
Mobile Phone
iOS
I have a really strange behaviour. I followed the instructions from kgp. https://www.tonymacx86.com/threads/how-to-extend-the-imac-pro-to-x99-successful-build-extended-guide.227001/
After installing Bios, OSX, Windows and all the other stuff i am now on the TB3 (Titan Ridge Card) to install. It works with several TB drives (But not with the Promise Pegasus Raid, there is something wrong in the Bios, i can not push the Delete Key, to go into the Bios)
But the very strange thing is: Accidentally I changed in Advanced/Thunderbolt the Thunderbolt to off. If I start the OSX with TB (off) the connected Thunderbolt Disk will be mounted and receivable and I do not understand, how this can be.
If I check in the IOReg the Thunderbolt entries, they are written under BR02.
 
Last edited:
Joined
May 28, 2016
Messages
69
Motherboard
ASUS X99 A II
CPU
I7 6900k
Graphics
GTX 970
Thanks KGP, i will check the SSDT-X99-TB3HP.aml but can you give me the link to go into right page directly?

I don't understand what can i do with SSDT-X99-TB3HP.aml? where have i to put it? etc...

Thanks in advance.
 
Last edited:

kgp

Joined
May 30, 2014
Messages
6,611
Motherboard
Asus Prime X299 Deluxe
CPU
i9-7980XE
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
Joined
May 28, 2016
Messages
69
Motherboard
ASUS X99 A II
CPU
I7 6900k
Graphics
GTX 970
Thanks but it's a little beat triky for me , i don't understand what am i really suppose to do with this SSDT-X99-TB3HP.aml?

Can you explain faster?

Thanks.
 

kgp

Joined
May 30, 2014
Messages
6,611
Motherboard
Asus Prime X299 Deluxe
CPU
i9-7980XE
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
Thanks but it's a little beat triky for me , i don't understand what am i really suppose to do with this SSDT-X99-TB3HP.aml?

Can you explain faster?

Thanks.
Read guidelines as indicated...
 
Joined
May 28, 2016
Messages
69
Motherboard
ASUS X99 A II
CPU
I7 6900k
Graphics
GTX 970
Houa!! thanks, but it seems to complicate for me. Because if i do something wrong and my machin don't work anymore it's not good for my work.

At this moment pegasus works at 500MB/s, i would prefer more but it's better than my 2 drives mounted in miror that were at 140Mb/s.
 
Top