Contribute
Register

The everything works Asus Z390-I Gaming * i7-8700K * SAPPHIRE NITRO+ Radeon RX Vega 64 Build

trs96

Moderator
Joined
Jul 30, 2012
Messages
23,976
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Is there a way to fix TRIM issue has been started since Monterey OS?
Disabling trim is the only option. Samsung hasn't fixed it with a firmware update.
 
Joined
Aug 14, 2019
Messages
79
Motherboard
Asus Z390-I Gaming
CPU
i5-9600K
Graphics
UHD 630
Disabling trim is the only option. Samsung hasn't fixed it with a firmware update.
The strange thing in my setup, that setting trim time to zero changes nothing. But I'm using the old OC version (0.7.9). I didn't use my Hackintosh for some time. My be updating the OC will fix the issue. Thanks anyway.
 
Joined
Aug 14, 2019
Messages
79
Motherboard
Asus Z390-I Gaming
CPU
i5-9600K
Graphics
UHD 630
Hi gyus. I've been started OC update process. As of now, I'm at 0.8.2 version. The next version brought a lot of changes for NVRAM. Is there any benefits for our hardware to use OpenVariableRuntimeDxe.efi in opposite to the previous way? I can't understand if I should do anything with that.
Thanks in advance!
 

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
3,502
Motherboard
Asus Z690 Rog Strix G Gaming
CPU
i9-12900K
Graphics
RX 6900 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi gyus. I've been started OC update process. As of now, I'm at 0.8.2 version. The next version brought a lot of changes for NVRAM. Is there any benefits for our hardware to use OpenVariableRuntimeDxe.efi in opposite to the previous way? I can't understand if I should do anything with that.
Thanks in advance!
No, its not needed.
 
Joined
May 9, 2013
Messages
53
Motherboard
Asus ROG Strix Z390-I Gaming
CPU
i7-9700K
Graphics
UHD 630
Mobile Phone
  1. iOS
Any ideas how to solve bcm94352z doesn't work on ventura? Wifi and bluetooth not working. Everything was fine on monterey. Attaching my kexts folder. These exactly kexts were fine on monterey. So everything was working and up to date, opencore 0.8.7, latest kexts... once updated to monterey it just stopped working
 

Attachments

  • E5FF5D2E-15AD-4FF8-BAEC-E1325064B5CF.jpeg
    E5FF5D2E-15AD-4FF8-BAEC-E1325064B5CF.jpeg
    1.1 MB · Views: 5

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
3,502
Motherboard
Asus Z690 Rog Strix G Gaming
CPU
i9-12900K
Graphics
RX 6900 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Any ideas how to solve bcm94352z doesn't work on ventura? Wifi and bluetooth not working. Everything was fine on monterey. Attaching my kexts folder. These exactly kexts were fine on monterey. So everything was working and up to date, opencore 0.8.7, latest kexts... once updated to monterey it just stopped working
Are you sure you are using the correct version of the wireless kexts? There are multiple versions of the wireless kext to support which ever version of the OS you are using. One does not work for all...

Likewise installation instructions for enabling bluetooth have changed as well
 
Joined
May 9, 2013
Messages
53
Motherboard
Asus ROG Strix Z390-I Gaming
CPU
i7-9700K
Graphics
UHD 630
Mobile Phone
  1. iOS
Are you sure you are using the correct version of the wireless kexts? There are multiple versions of the wireless kext to support which ever version of the OS you are using. One does not work for all...

Likewise installation instructions for enabling bluetooth have changed as well
No, I'm not sure, because I'm a bit noob in these kind of things. At the same time, I guess bcm94352z is not Intel cart, right? I anyway tried to follow the guides from https://openintelwireless.github.io...ke-bluetooth-work-on-macos-monterey-and-newer, so I added IntelBTPatcher.kext and IntelBluetoothFirmware.kext that were missing, but that didn't help. Here is my EFI folder just in case it's easy for gurus to figure out what's the problem. Appreciate for help!
 

Attachments

  • EFI.zip
    20.4 MB · Views: 5
Joined
May 9, 2013
Messages
53
Motherboard
Asus ROG Strix Z390-I Gaming
CPU
i7-9700K
Graphics
UHD 630
Mobile Phone
  1. iOS
One change that was fixed, when I added those 2 kexts, is that Bluetooth started working, but wifi still doesn't work. It shows explanation mark on wifi icon and that's it.
 
Joined
May 9, 2013
Messages
53
Motherboard
Asus ROG Strix Z390-I Gaming
CPU
i7-9700K
Graphics
UHD 630
Mobile Phone
  1. iOS
Ok I just fixed the issue with installing newest version IntelBTPatcher.kext and IntelBluetoothFirmware.kext for Bluetooth and AirportBcrmFixup.text for Wifi.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
29,031
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
no, not sure, cause I'm a bit noob in these kind of things... at the same time I guess bcm94352z is not intel cart, right? I anyway tried to follow the guides from https://openintelwireless.github.io...ke-bluetooth-work-on-macos-monterey-and-newer, so I added IntelBTPatcher.kext and IntelBluetoothFirmware.kext that were missing, but that didn't help. Here is my EFI folder just in case it's easy for gurus to figure out what's the problem. Appreciate for help!
why have you got both broadcom and intel wifi kexts?
 
Top