Contribute
Register

The everything works Asus Z390-I Gaming * i7-8700K * SAPPHIRE NITRO+ Radeon RX Vega 64 Build

Joined
May 31, 2013
Messages
381
Motherboard
ASUS ROG Strix Z390-I Gaming
CPU
i9-9900K
Graphics
5700 XT
I upgraded to macOS 10.15.1. When I start the OS, I have endless loading if I use my RX 5700 XT card.

I tried updating Clover, using an argument, and even deleting a cupcake for graphics, but that doesn't help.


BIOS setup is performed according to the instructions for dGPU. How to make the RX 5700 XT work?

44596AFB-46CA-46E5-ACBA-EF0A5FFB26D5.jpeg
 
Last edited:
Joined
Feb 21, 2010
Messages
1,871
Motherboard
Asus Rog Strix Z390 Gaming E
CPU
i9-9900K
Graphics
5700 XT
Mac
MacBook Air
Mobile Phone
Android
Thanks for the follow up, I just gave that a try and it still reboots at the same spot every time.
Maybe try and update Whatevergreen.kext, I had to use the version available on this site (or from Acidanthera’s Github) after updating to 15.1. Without it black screen, no display.
 
Last edited:
Joined
May 31, 2013
Messages
381
Motherboard
ASUS ROG Strix Z390-I Gaming
CPU
i9-9900K
Graphics
5700 XT
How to get an AMD Radeon RX 5700 XT graphics card to run on an ASUS ROG STRIX Z390-I Gaming

You need to upgrade to macOS 10.15.1 (Final) and select the assembly CATAL-DGPU-EFI.zip. After that, you need to manually update the files:

Lilu.kext version 1.3.9 or later

WhateverGreen.kext version 1.3.4 or later

Clover can not be updated to a new version (it works like that).

To make it work you need to use a modified config. I added the Graphics section there, and added the boot argument agdpmod = pikera, and left everything else as @ModMike. Do not forget to add your SMBiOS to the config. I am using iMac 19.1 (9900K).

Снимок экрана 2019-11-03 в 08.00.33.png

Снимок экрана 2019-11-03 в 08.42.12.png

Full CLOVER folder for RX 5700 XT on macOS Catalina 10.15.1:
 

Attachments

Last edited:
Joined
May 31, 2013
Messages
381
Motherboard
ASUS ROG Strix Z390-I Gaming
CPU
i9-9900K
Graphics
5700 XT
Can you give an explanation for this statement? What version of clover are you running?
I use Clever 5082. My 4K monitor is connected via DisplayPort. I do not observe any problems. I have been using my computer for about 25 minutes. There is no flicker and no freezes either.
 
Joined
Nov 21, 2017
Messages
27
Motherboard
ASUS PRIME Z270-A
CPU
i7-7700K
Graphics
RX 580
Mac
iMac
Can you give an explanation for this statement? What version of clover are you running?
I use Clever 5082. My 4K monitor is connected via DisplayPort. I do not observe any problems. I have been using my computer for about 25 minutes. There is no flicker and no freezes either.
The Clover in EFI we are using is at the latest version though.
 
Joined
Sep 11, 2019
Messages
138
Motherboard
ASUS ROG STRIX z390-E Gaming
CPU
i9-9900K
Graphics
5700 XT
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini
Classic Mac
iBook, iMac, Power Mac, PowerBook, Xserve
Mobile Phone
iOS
The Clover in EFI we are using is at the latest version though.
Well, yes, but I'm still having freezing issues and he's running basically the same mobo as me. So it's worth looking at his EFI.
 
Joined
May 31, 2013
Messages
381
Motherboard
ASUS ROG Strix Z390-I Gaming
CPU
i9-9900K
Graphics
5700 XT
Well, yes, but I'm still having freezing issues and he's running basically the same mobo as me. So it's worth looking at his EFI.
I use all the files from @ModMike from the CATAL-DGPU-EFI.zip archive. I replaced only config.plist, Lilu.kext and WhateverGreen.kext.

Снимок экрана 2019-11-03 в 08.22.20.png
 
Joined
Sep 26, 2019
Messages
11
Motherboard
Asus Z390-I
CPU
i7 -8700
Graphics
RX 580
You mean ? For me its working in 10.15.1, too
Well, I have to switch igfx to primary display and boot blind, but it works now without messing up with jpg preview...
 
Joined
Oct 7, 2019
Messages
5
Motherboard
Asus ROG STRIX Z390-I GAMING
CPU
i7-9700K
Graphics
Vega 64
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Hello and thank you for your time for the finalization of this hackintosh :) New in this world, and I am has my first configuration. I put DGPU-EFI file because I use a sapphire Nitro+ Vega 64. Unlike WiFi, I put a Broadcom Bcm94360cs2 with a adapter NGFF m.2 key A / E.
And everything works perfectly well. Thanks to you ModMike :thumbup::clap:
Capture d’écran 2019-11-03 à 13.07.06.png
Capture d’écran 2019-11-03 à 13.09.26.pngCapture d’écran 2019-11-05 à 00.59.19.png
 
Last edited:
Top