Contribute
Register

The everything works Asus Z390-I Gaming * i7-8700K * SAPPHIRE NITRO+ Radeon RX Vega 64 Build

Joined
Aug 31, 2018
Messages
1,413
Motherboard
Asus ROG Strix Z390 I-Gaming
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook
Classic Mac
512K, iMac
Mobile Phone
iOS
..... its formated into NTFS... should i connect it with usb to sata and format it to HFS+ or AFPS?
Wait, what???? What kind of ssd and where is it installed?

When you start the install, cancel install by clicking on the Install MacOS in the top left corner and select Quit Install macOS:

399648


Then use Disk Utility to format APFS:

399646


Then restart your install by selecting Install macOS.
 
Last edited:
Joined
Sep 9, 2015
Messages
136
Motherboard
Gigabyte Z390 UD
CPU
i5-9600K
Graphics
RX 5700 XT
Mac
iMac, MacBook Air, Mac mini, Mac Pro
Mobile Phone
iOS
There have been 3 versions since then. Did you update EFI with latest? If you haven't and want to upgrade to latest BIOS, download and install the latest EFI before you update the BIOS.
Using the latest EFI modifications. But BIOS is 2012. I had problems after I upgraded BIOS on my old skylake build.
 
Joined
Aug 31, 2018
Messages
1,413
Motherboard
Asus ROG Strix Z390 I-Gaming
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook
Classic Mac
512K, iMac
Mobile Phone
iOS
Using the latest EFI modifications. But BIOS is 2012. I had problems after I upgraded BIOS on my old Skylake build.
No reason to update BIOS if everything is working well. You don't need the last ACPI patch and can delete it if it causes you issues:

399645
 
Last edited:
Joined
Aug 31, 2018
Messages
1,413
Motherboard
Asus ROG Strix Z390 I-Gaming
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook
Classic Mac
512K, iMac
Mobile Phone
iOS
tried dgpu too........ maybe dsdt may fix it.... waiting for it
I took a look at DSDT and it is VERY different. IT does not mean it can't work, just no the issue I thought it was. The install should have formatted NTFS volume to APFS but can you please check that it did? I have to assume yes since it started loading, unless you added an NTFS driver to Clover.
 
Joined
Mar 17, 2019
Messages
66
Motherboard
Asus Rog Strix Z390 - E
CPU
i3 8100
Graphics
Sapphire Radeon RX 580 8GB
Mac
MacBook Pro
Mobile Phone
iOS
Wait, what???? What kind of ssd and where is it installed?

When you start the install, cancel install by clicking on the Install MacOS in the top left corner and select Quit Install macOS:

View attachment 399648

Then use Disk Utility to format APFS:

View attachment 399646

Then restart your install by selecting Install macOS.

I'm not talking about pendrive....
I'm talking about SSD that I bought for installing macos....It came with ntfs format....

I'm not even getting to install screen... I'm just stuck at apple logo bar....

Yeah I'll format it once i get to install screen...
 
Joined
Mar 17, 2019
Messages
66
Motherboard
Asus Rog Strix Z390 - E
CPU
i3 8100
Graphics
Sapphire Radeon RX 580 8GB
Mac
MacBook Pro
Mobile Phone
iOS
I took a look at DSDT and it is VERY different. IT does not mean it can't work, just no the issue I thought it was. The install should have formatted NTFS volume to APFS but can you please check that it did? I have to assume yes since it started loading, unless you added an NTFS driver to Clover.
No I didn't added any NTFS drivers to clover.... I don't even know how to do that....
I just used unibeast to create installer drive... copied your efi.... so one part of usb is in AFPS....another part FAT32
 
Joined
Oct 26, 2013
Messages
106
Motherboard
ASUS Z390-I
CPU
i7-8700K
Graphics
Radeon VII
hello again, sorry for the late update from me. works had been crazy lately, here's my update maybe useful from some of you :

some basic
1. I tried this guide with dGPU EFI
2. currently run at Mojave 10.14.4
3. with Radeon VII (i know this not natively supported yet)

condition
1. 99% working build (sound, Bluetooth & wifi with a replacement card etc)
2. USB seems to be working now with latest dGPU EFI from this guide (kind of working.. more on that latter)
3. Radeon VII works but without proper acceleration (or not at all?), here is a couple of pics :
399708
399709

but performance wise its kind of mix bag, brucex test takes about 34 -40 sec.

Problem
1. i got random freezes, eg. my hack suddenly freezes but the audio in the background continues to play.there is no specific ways that i can replicate the freezes. it so random and to get it to work again are for me to force shutdown (hold the power button).

2. another type of freezes or error are the audio suddenly makes glitchy noises and then stop working altogether and at this point, the mouse cursor and general UI start to lag to hell too.

3. my handoff and continuity still not reliable, sometimes handoff works, and sometimes doesn't. and features like unlock with apple watch 100% broken.

question
1. at this guide there are attachment ssdt-uiac.aml, what is that? and where do i put that on to my hackintosh?

2. for the radeon VII, i read a couple of posts that 10.14.5 beta 1 makes radeon VII bearable for day-to-day use. how to install beta macosx and if i doing it, are files and guide in this thread still works with beta macOS?

3. and if i go the beta route, what happened if the public release comes? i just upgrade to non-beta os or i must repeat the Hackintosh process all over again?

thx btw.
 
Last edited:
Joined
Mar 17, 2019
Messages
66
Motherboard
Asus Rog Strix Z390 - E
CPU
i3 8100
Graphics
Sapphire Radeon RX 580 8GB
Mac
MacBook Pro
Mobile Phone
iOS
I took a look at DSDT and it is VERY different. IT does not mean it can't work, just no the issue I thought it was. The install should have formatted NTFS volume to APFS but can you please check that it did? I have to assume yes since it started loading, unless you added an NTFS driver to Clover.
I even tried removing every ssd... and booting only with usb installer......

Still same problem with errors in verbose...
 
Joined
Mar 17, 2019
Messages
66
Motherboard
Asus Rog Strix Z390 - E
CPU
i3 8100
Graphics
Sapphire Radeon RX 580 8GB
Mac
MacBook Pro
Mobile Phone
iOS
Tried this guide this morning and it worked like a charm, first time out of the box! This is the single most painless hackintosh experience I've had so far. All up and running in 10.4.4. Cheers!

Note: I initially had trouble booting from the USB but that was only due to me not using Disk Utility correctly to make the stick bootable. That set me back about an hour. Oh well!
wonder how he did this.... cause same motherboard....
 
Top