Contribute
Register

The audio fails to return from sleep mode

Joined
Jan 1, 2011
Messages
81
Motherboard
Gigabyte Z170X-UD5
CPU
i7-6700K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
Best to not 'store' these kexts in C/Kexts/other folder because if the kext in that folder is not the same as the one in /L/E it may cause problems. If you want to store copies, put them in a a different folder, such as ~/documents
I do keep them in a separate folder, thanks.
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,458
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Joined
Oct 4, 2013
Messages
2
Motherboard
GA-H77N-WIFI
CPU
i5-3750K
Graphics
GT730
Mac
MacBook Pro
Mobile Phone
Android
I've been watching this thread as I've had the same problem. Updating from 10.14.3 introduced the issue. Since I didn't see any progress, I went ahead and tried a clean install of 10.14.4 but the issue continued.

I noticed that my AppleALC was not the current version (current is 1.3.7 as of Apr 9). I updated to that and it appears to have fixed my issue.


About the update: I don't mess with kexts as everything normally works, so I'm unfamiliar with best/correct method to do it right. I removed AppleALC.kext from /L/E and used an old kext utility to install the new AppleALC. It was placed in /S/L/E. If /L/E is where it's supposed to be, let me know & I'll move it there & fix permissions.
 
Joined
Jan 1, 2011
Messages
81
Motherboard
Gigabyte Z170X-UD5
CPU
i7-6700K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
I noticed that my AppleALC was not the current version (current is 1.3.7 as of Apr 9). I updated to that and it appears to have fixed my issue.
Thanks! I used KextBeast to install 1.3.7 into Library/Extensions and after testing - so far - it has solved the problem for me.
 
Joined
Jun 21, 2010
Messages
268
Motherboard
Gigabyte Z370 AORUS Ultra Gaming
CPU
i7-8700K
Graphics
RX 570
Mac
MacBook Air
Classic Mac
iMac
Mobile Phone
Android, iOS
in my system it helped to use AppleALC in new version 1.3.7 located in EFI/clover/kext/other/
and deleting an old relict (RealtekALC v. 2.8) from L/E/
After that sound is okay after wake from sleep.
 
Joined
Nov 13, 2016
Messages
7
Motherboard
Asrock Z87 Extreme4
CPU
i5-4670K
Graphics
RX 580
Mac
iMac
Mobile Phone
Android
Top