Contribute
Register

The 4K Dell OptiMac - Core i7-4790 - Quadro NVS 510 Graphics - LG 4K 27" IPS Monitor

trs96

Moderator
Joined
Jul 31, 2012
Messages
13,186
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
I dont know what DEHCI does or whether it needs fixing or just leaving out.
That is a Rehabman SSDT which excludes USB ports from showing up on the EHCI controller. It's needed so the the USB SSDT will work properly. Keep it if USB 3 function is important to you.
 
Joined
Jan 21, 2012
Messages
457
Motherboard
HP 8300 Elite
CPU
i5-3570
Graphics
GTX 710
Mobile Phone
Android
That is a Rehabman SSDT which excludes USB ports from showing up on the EHCI contr...
Seems a 'must have' sort of thing but why do we have different results here?

Edit: A. - I hadnt put usbinjectall.kext on the UEFI partition, once kext was in place then DEHCI worked and did its job (I think) with a single USB 3 bus and all other USB's hanging off from that.

Ive been using it today before working out what was wrong with the usb and it has been very nice, quite quiet and a feeling of being just a bit sharper than 7010. Awaiting LP bracket for the quadro and cheapo pci drive bits, and really not going to get a 4k monitor.

As far as I can tell, Im now exactly where I should have been (but wasn't) if I'd followed your instructions but for removing a tick in PluginType - which enabled the CPU to step down to 800Mhz. (Except insignificant difference of only fakesmc and usbinjectall being in Clover/kexts/other and not duplicated where all the other kext are in /L/Extensions).

I mapped out on paper the USB ports for the SFF but suspect thats already been done and used in the USB ssdt?

Sleep, Audio, Speedstepping, Graphics - All A1.

Another nice build.
 

Attachments

Last edited:

trs96

Moderator
Joined
Jul 31, 2012
Messages
13,186
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
I've tested removing PluginType=True from my .plist and then power mgt. seems to work normally. i7-4790 only uses 1.63W of power and the clock speed stays close to 800 MHz most of the time. Seems we don't need PluginType=True. The 2nd IPG shows maxing out all 4 cores 8 threads. It turbos up to 3.8 GHz which is normal for these Dells. The fans don't even ramp up at all when maxing out the CPU, they stay quiet. Kind of like in an iMac Pro. The difference is that the i7-4790K in an iMac 15,1 will often reach the high 90s C in temperature. These Optiplexes never even get close to 80C. The fans in a regular iMac will often get very loud just before the throttling occurs.

410887
410888
 
Last edited:

trs96

Moderator
Joined
Jul 31, 2012
Messages
13,186
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
To everyone using the config.plist from this guide:

If you want to save a little more electricity while your OptiMac idles, just uncheck the box for PluginType in CC. It's in the ACPI/SSDT section as shown below.

410889
 
Joined
Jan 21, 2012
Messages
457
Motherboard
HP 8300 Elite
CPU
i5-3570
Graphics
GTX 710
Mobile Phone
Android
I think PM/Sleep also works with another set of settings but seems to miss out some of the speedsteps - With ticks in Generate - PluginType, P + C states, and Plugin Type set to 1: I went with the 1st (none ticked option) thinking the less we do the better but not fully tested either and still to test all the USB ports.
Edit - USB tested and all good.
 
Last edited:

trs96

Moderator
Joined
Jul 31, 2012
Messages
13,186
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
I think PM/Sleep also works with another set of settings
Sleep works on my system. The only thing to resolve is a black screen after wake from sleep. I'll look into a possible patch for that so we can keep speedstep completely working.
 
Joined
Jan 21, 2012
Messages
457
Motherboard
HP 8300 Elite
CPU
i5-3570
Graphics
GTX 710
Mobile Phone
Android
The only thing to resolve is a black screen after wake from sleep.
No longer a black screen issue on my machine, sleep and wake are perfect. I thought that was to do with PluginType but I may have missed some other difference. If you post your PR files Ill do a compare or take a look at mine.
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
13,186
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
No longer a black screen issue on my machine, sleep and wake are perfect. I thought that was to do with PluginType but I may have missed some other difference. If you post your PR files Ill do a compare or take a look at mine.
Yes, if you could just zip up your Clover folder I'll see what is different.
 
Joined
Jan 21, 2012
Messages
457
Motherboard
HP 8300 Elite
CPU
i5-3570
Graphics
GTX 710
Mobile Phone
Android
See previous post with image, PR files attached there.
 
Joined
Jan 21, 2012
Messages
457
Motherboard
HP 8300 Elite
CPU
i5-3570
Graphics
GTX 710
Mobile Phone
Android
Checked BIOS settings (which aren't shown in PR files) and noticed I didn't use

Video
Primary Display -> Auto (For HD4600)

But set it to Intel explicitly and I think the machine BIOS is on version A12
EDIT: And I used
Legacy Option ROMS - Enabled
 
Last edited:
Top