Contribute
Register

The 4K Dell OptiMac - 9020 MT - Core i7-4790 - Radeon RX 570 - LG 4K IPS Monitor

Joined
Jul 25, 2017
Messages
27
Motherboard
AsRock Z170
CPU
core i5 6500
Graphics
MSI RX 580
Mac
MacBook Pro
Hey, I tried that with downloading Catalina through the terminal app, but it keeps pulling me into Recovery Utilities when I boot to the USB and try to install OSX. I'm doing two computers and tried it on both. Same issue. I'm thinking it's the USB drive or something up with the downloaded Catalina file. I might try a lower version of Catalina and see if it makes a difference.
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
17,420
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
Hey, I tried that with downloading Catalina through the terminal app, but it keeps pulling me into Recovery Utilities when I boot to the USB and try to install OSX.
You are supposed to enter Utilities and then Disk Utility to format your SSD before the install. After that select Install macOS.

Screen Shot 22.jpg
 
Joined
Dec 20, 2018
Messages
180
Motherboard
NUC7
CPU
i5
Graphics
HD 620
Mac
iMac
Mobile Phone
iOS
It looks like the they did lengthen that to a full size mini PCIe slot on the 9020 USFF. I have the 9010 USFF but not the 9020.

So you might need to get a half mini to full size mini PCIe converter. You'll also need to use the AirportBRCM fixup kext and possibly one other that I'm not recalling right now. Those are needed for BT to work. Perhaps @BillyGoatGruff could give you the details on that.
You can use an adapter like this (link). Or make your own from a piece of an old gift or rewards card?
I can't help you with Catalina... my 9010 USFF is still at Mojave.
half PCI mini adapter.png
 
Last edited:

trs96

Moderator
Joined
Jul 31, 2012
Messages
17,420
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
Ok, followed that. I formatted the SSD a while back. I get to utilities and then it keeps saying that Catalina is damaged/corrupted and cannot install. This is on two machines. Also I upgraded and am now using UniBeast installer 7.
Unibeast 7.1.1 is not meant for a Catalina install.

Screen Shot 27.jpg

You would use 10.3.0 for making a Catalina installer. Make one of those for UEFI booting and see if it works then. If not try the following terminal, change the date trick and see if it helps you do the install.

 
Joined
Jul 25, 2017
Messages
27
Motherboard
AsRock Z170
CPU
core i5 6500
Graphics
MSI RX 580
Mac
MacBook Pro
Sorry, it shows up as UniBeast 7 after you download it. I used UniBeast 10.3 in the latest attempt to install.

That's exactly the error I get though. I noticed in the bios that the time was 2018. I'll have to change it in the BIOS? Or, just in terminal?
 
Last edited:
Joined
Jul 25, 2017
Messages
27
Motherboard
AsRock Z170
CPU
core i5 6500
Graphics
MSI RX 580
Mac
MacBook Pro
Post Install: Seems like sleep is broke. I sleep it and when it wakes it restarts. During post-install, copying the kexts/patches/etc over, I opened the EFI on the SSD partition but I didn't see clover at all. I just saw an Apple folder. I copied over the Clover and Boot folder into the SSD EFI folder, but it just didn't look right.
 
Joined
Nov 6, 2019
Messages
64
Motherboard
Optiplex 9020 MT
CPU
i7-4770
Graphics
HD 4600
Mac
iMac, MacBook Pro, Mac mini
2 months from China to Australia ?? Hard to believe that it could take that long. Did you call or email the seller ?
My 24-8pin adapter cable from Moddiy arrived today! Ordered it on the 5/5, left HK on the 22/5 (by boat due to suspension of airmail) and arrived her 21/7. Almost 2 months to the day! Of course I ordered another one off eBay just the other day :banghead:
Anyway, I noticed that it doesnt look at all like the picture on the Moddiy website in that it is missing the extra single pin plug that we didn't know the purpose off. It looks just like the ones from Amazon/eBay...picture attached. Hoping it is good quality and looking forward to finally getting my PSU and RX 580 in the Optiplex!

Just to refresh my memory, what changes do I need to make to the BIOS and Clover?

I'm thinking: Legacy boot options off, primary video to Auto or AMD (when the option is available). Do I need any changes in Clover? Can't think of any but I'll check back through post 1, 2 and 3.

What am I expecting with sleep/wake when the RX 580 is in? Should it restart on wake or just be blank? I'm using SMBIOS 15.1
 

Attachments

Joined
Feb 5, 2020
Messages
63
Motherboard
Dell 9020 MT
CPU
i7-4790
Graphics
RX 570
Mac
MacBook Pro
Mobile Phone
iOS
My 24-8pin adapter cable from Moddiy arrived today! Ordered it on the 5/5, left HK on the 22/5 (by boat due to suspension of airmail) and arrived her 21/7. Almost 2 months to the day! Of course I ordered another one off eBay just the other day :banghead:
You will have another one for your next build :)

Anyway, I noticed that it doesnt look at all like the picture on the Moddiy website in that it is missing the extra single pin plug that we didn't know the purpose off. It looks just like the ones from Amazon/eBay...picture attached. Hoping it is good quality and looking forward to finally getting my PSU and RX 580 in the Optiplex!
The one I ordered from eBay looks like yours and worked fine.

I'm thinking: Legacy boot options off, primary video to Auto or AMD (when the option is available). Do I need any changes in Clover? Can't think of any but I'll check back through post 1, 2 and 3.
You will want to set primary video to Auto if you want the macOS Quick Look feature to work.

What am I expecting with sleep/wake when the RX 580 is in? Should it restart on wake or just be blank? I'm using SMBIOS 15.1
Sleep/wake will not work with dedicated GPU. One of, if not the only, drawbacks of the extremely good OptiMac build ;)
 
Last edited:
Top