Contribute
Register

The 4K Dell OptiMac - 9020 MT - Core i7-4790 - Radeon RX 570 - LG 4K IPS Monitor

trs96

Moderator
Joined
Jul 31, 2012
Messages
20,320
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Thank you for the work put in this.
Looks like your second Haswell system. I've got two as well. They're still very capable machines. Great value here.
 
Joined
Oct 23, 2012
Messages
10
Motherboard
Dell Optiplex 9020 MT Q77 Board
CPU
core i7 4790
Graphics
MSI RX 570 / Samsung U28E590
Mac
  1. MacBook Pro
Looks like your second Haswell system. I've got two as well. They're still very capable machines. Great value here.

Hi, no I just did not visit the forum for a long time and it seemed mandatory to add a mainboard to the signature. I pasted the wrong one :)
 
Joined
Jun 5, 2020
Messages
35
Motherboard
Optiplex 7020 SFF
CPU
i5 4590
Graphics
HD4600
Alright, success with this system, my first one! I ended up using open core by following Zearp's OptiHack guide. However, even with changing the DVMT pre-alloc to 0x3 (96 Mb) my 4K monitor is still only outputting at 2K (using DP->DP). Otherwise everything is working smoothly (iServices, sleep, etc.).

Update: I was able to fix 4k with info from this thread.
 
Last edited:
Joined
Aug 22, 2014
Messages
270
Motherboard
Gigabyte Z390 Designare
CPU
i7-9700K
Graphics
RX 6800 XT
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
There will be better support for that once we switch to OpenCore bootloader and Catalina. Stay with Mojave for now and wait till we get the OC info posted.

@trs96 Is there any way we can enable FileVault? If so, can you write us a instruction on how to do this?
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
20,320
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
@trs96 Is there any way we can enable FileVault? If so, can you write us a instruction on how to do this?
Only attempt this after you've made a bootable backup that you've tested working. You might want to test out FileVault from a USB flash drive with Clover on it first before making the changes below on your SSDs efi partition.

You will need specific drivers in /EFI/CLOVER/drivers/UEFI/

They are: ApfsDriverLoader.efi - AppleGenericInput.efi - AppleUiSupport.efi - HFSPlus.efi - OpenRuntime.efi and VirtualSmc.efi

You will already have some of these in drivers/UEFI

Find the others here: https://github.com/acidanthera/AppleSupportPkg/releases/tag/2.0.9

Use version 2.0.9 and not newer or older versions.
 
Joined
Jun 5, 2020
Messages
35
Motherboard
Optiplex 7020 SFF
CPU
i5 4590
Graphics
HD4600
There will be better support for that once we switch to OpenCore bootloader and Catalina. Stay with Mojave for now and wait till we get the OC info posted.

I was able to get Catalina running on my Dell Optiplex 7020 SFF using OpenCore 0.5.9 - I posted my install notes and config.plist over in the 4k thread (patching 4k was the only hurdle I experienced but everything's working now): https://www.tonymacx86.com/threads/...intel-4600-integrated-gpu.282589/post-2137953
 
Joined
Aug 22, 2014
Messages
270
Motherboard
Gigabyte Z390 Designare
CPU
i7-9700K
Graphics
RX 6800 XT
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
@trs96 Thanks, I will try the FileVault tomorrow.

I have another question; how should I proceed with dual boot with Windows 10, it seems that with the selected bios options I’m not able to boot into Windows 10. After selecting default settings in bios again, it works (when selecting my Windows 10 as the first boot ssd drive). see attached screenshot, partly Dutch but the text below is in English.
 

Attachments

  • 9AECD3D2-DE2F-4F92-A911-E5A2B70599D3.jpeg
    9AECD3D2-DE2F-4F92-A911-E5A2B70599D3.jpeg
    3.5 MB · Views: 38

trs96

Moderator
Joined
Jul 31, 2012
Messages
20,320
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
I’m not able to boot into Windows 10. After selecting default settings in bios again, it works
Is Windows installed UEFI ? If not, you can't boot it from the Clover menu.
 
Joined
Aug 22, 2014
Messages
270
Motherboard
Gigabyte Z390 Designare
CPU
i7-9700K
Graphics
RX 6800 XT
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Is Windows installed UEFI ? If not, you can't boot it from the Clover menu.

yes UEFI. I can approach it from clover. but after selecting it in clover I can see the Windows circle spinning for a while (20 seconds or so) and then I get that blue screen. Sometimes it comes with auto repair but that doesn’tfix it. Only revert bios todefault settings helps (But of course then macOS doesn’t boot anymore).
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
20,320
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
but after selecting it in clover I can see the Windows circle spinning for a while
Try removing the macOS drive, unplug the Sata cable to it. Then see if Windows will boot from BIOS. Do you get the same blue screen of death then ?
 
Top