Contribute
Register

The 4K Dell OptiMac - 9020 MT - Core i7-4790 - Radeon RX 570 - LG 4K IPS Monitor

Joined
Jul 30, 2017
Messages
156
Motherboard
Dell 9020
CPU
i7-4770
Graphics
RX570
Mac
  1. iMac
Mobile Phone
  1. Android
@Daneland if you are booting from an ssd but loading OSX from a NVMe drive - copy the EFI folder from the SSD to the EFI partition on the NVMe drive and then run the Problem Reporting script.
I dont have a NVMe drive. I have 4 drives (SSD MacOS and boot drive), Win10, TimeMachine, Storage
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
21,051
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
The only thing that looks out of order is this 1WEG 2 .kext you have.

Screen Shot 22.jpg
 
Joined
Jul 30, 2017
Messages
156
Motherboard
Dell 9020
CPU
i7-4770
Graphics
RX570
Mac
  1. iMac
Mobile Phone
  1. Android
Joined
Jun 23, 2019
Messages
47
Motherboard
Dell Optiplex 9020
CPU
i7-4790
Graphics
RX 580
Mac
  1. Mac mini
Mobile Phone
  1. iOS
I was creating my UniBeast installer for Catalina last night per the documentation. After I copied MultiBeast to the USB installer and ejected it, I came to this instruction:
"Once creation of the UniBeast installer has completed, you will need to replace the UniBeast created config.plist with the custom one attached below. Do this before ejecting the UniBeast installer or you'll have to mount the EFI manually later."
Oooops.
This means I should erase the USB drive again, repeat the installer creation process, and NOT EJECT until after I have swapped config.plists - correct?
Thank you all for you patience and help.
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
21,051
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
This means I should erase the USB drive again, repeat the installer creation process, and NOT EJECT until after I have swapped config.plists - correct?
No, you don't have to recreate the installer. Just mount the EFI partition, use Clover Configurator or EFI mounter app. Then move the .plist to the USB.
 
Joined
Aug 14, 2016
Messages
6
Motherboard
Gigabyte B75M-D3H
CPU
i3 3225
Graphics
HD4000
Thank you for the wonderful guide. It worked perfectly for me on my 9020.

Though I am facing an irritating and recurring issue. At times the display does not turn back on from sleep. There is a trigger in the display and I can hear the keys in the background, but the display does not turn on.

BUT, if I replug-in the monitor cable, the display seems to start working again.

I'm quite confused as to what could be the issue.

This ONLY happens sometimes, maybe 1 in 10 times, but I'd like to get to the bottom of this.

Any help would be much appreciated!
 
Joined
Jan 21, 2012
Messages
1,000
Motherboard
HP 8300 Elite
CPU
i5-3570
Graphics
GT 710
Mobile Phone
  1. Android
@sibot Cabling is sometimes an issue -using DP to DP connectors is significant to monitor wake ups. Check your BIOS settings for Graphics and Legacy BIOS are in accordance with this thread. If none of that works you might try adding or removing

<key>PciRoot(0x0)/Pci(0x2,0x0)</key>
<dict>
<key>AAPL,ig-platform-id</key>
<data>
AwAiDQ==
</data>
<key>device-id</key>
<data>
EgQAAA==
</data>
<key>enable-hdmi20</key>
<data>
AQAAAA==
</data>
<key>framebuffer-patch-enable</key>
<data>
AQAAAA==
</data>
<key>hda-gfx</key>
<string>onboard-1</string>
</dict>
which sets up the onboard graphics and this may either help or interfere with sleep
 
Last edited:

trs96

Moderator
Joined
Jul 31, 2012
Messages
21,051
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
@sibot Cabling is sometimes an issue -using DP to DP connectors is significant to monitor wake ups. Check your BIOS settings for Graphics and Legacy BIOS are in accordance with this thread. If none of that works you might try adding or removing....

which sets up the onboard graphics and this may either help or interfere with sleep
Do you remove this from Devices/Properties in the config.plist for your system ? Does it improve wake from sleep ?
 
Joined
Jan 21, 2012
Messages
1,000
Motherboard
HP 8300 Elite
CPU
i5-3570
Graphics
GT 710
Mobile Phone
  1. Android
Do you remove this from Devices/Properties in the config.plist for your system ? Does it improve wake from sleep ?
No, its always been there for machines without an external GPU and it should be there, but when using an external gpu I have had builds (one of the nvdia cards) where removing helped waking.

I think it was one of the things that was different between this and the alternative build but I might be misremembering.
 
Joined
Jul 30, 2017
Messages
156
Motherboard
Dell 9020
CPU
i7-4770
Graphics
RX570
Mac
  1. iMac
Mobile Phone
  1. Android
Did not make any difference. When it fails to boot ( actually boots but like the sleep issue HDMI output stops) if I plug DP cable it works( without booting from beginning). I dont know perhaps it gives a clue
I tried different boot options, legacy enable, multi display, auto etc, nothing helps. Is there anything you can think of ?

Solved
Used Hackintool to install Lillu and WG Kexts to Extensions folder and now I can boot from 570
 
Last edited:
Top