Contribute
Register

Temporary Solution for Mavericks Audio Issues

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,538
Motherboard
GA-Z270X-UD5
CPU
Core i3-7100
Graphics
HD 630
Mac
MacBook Pro, Mac mini
Classic Mac
Apple, PowerBook
Mobile Phone
iOS
There are certain random issues with audio in Chrome/Flash since 10.8.4- one solution I've found is to use the older patched AppleHDAs from MultiBeast 5.4.3. The AppleHDA version is 2.3.7. Current AppleHDA is 2.6.0.

Here's a list of versions of AppleHDA since 10.7:

Screen Shot 2014-03-09 at 12.13.14 PM.png

Hope this helps.

Older MultiBeast revisions can be found in the MultiBeast Archive:
http://www.tonymacx86.com/downloads.php?do=cat&id=6
 

kut

Joined
Nov 4, 2011
Messages
6
Motherboard
10.9
CPU
i5 3470
Graphics
650gtx
Mac
iMac
Classic Mac
iMac
Mobile Phone
Android, iOS
B

BoxedKian

Guest
Surpassed these issues way back when MultiBeast 5.5.5 came out, I'm never in a mood to do a lot of bug testing and messing around. I solved my problems by buying a USB Sound Card for $5 on Amazon's that was floating around in the forums. Quality was okay, I feel like it wasn't as good as my motherboard audio (which is a first considering I'm used to using external sound cards on my work system).
 
Joined
Aug 2, 2013
Messages
39
Motherboard
GA-Z77X-UD5H
CPU
i7 3770K
Graphics
GTX 970
Mac
MacBook Pro
I am having random static-y/crackling playback on my system. It happens in Chrome/Flash within a couple minutes, but happens to a lesser degree system-wide (Chrome goes to full static, while iTunes gets random cracks and pops after 20 minutes or so).

If I roll back to the 5.3.7 audio drivers, do I just need to run that version of Multibeast, check just the ALC898 (without DSDT) and it will uninstall the current drivers and install that one?
 
Joined
Jul 4, 2012
Messages
311
Motherboard
Gigabyte Aorus Z390 Ultra
CPU
i5-9600K
Graphics
Vega 56
Mac
iMac, MacBook Pro
Mobile Phone
iOS
I had issues with sound on my hack for a while. It mainly was with flash in web browsers. The solutions was a usb audio device. I turned off the audio in the motherboard bios and simply plugged in a generic usb audio adapter. Sold 99 percent of my issue. Makes updates much easier. It just worked.

The sound quality of the 5 dollar adapter, while not really bad, wasn't as good so I did upgrade to a 'DAC". Much more Mac like, it just works. Even with flash.
 
Joined
Aug 2, 2013
Messages
39
Motherboard
GA-Z77X-UD5H
CPU
i7 3770K
Graphics
GTX 970
Mac
MacBook Pro
I had issues with sound on my hack for a while. It mainly was with flash in web browsers. The solutions was a usb audio device. I turned off the audio in the motherboard bios and simply plugged in a generic usb audio adapter. Sold 99 percent of my issue. Makes updates much easier. It just worked.

The sound quality of the 5 dollar adapter, while not really bad, wasn't as good so I did upgrade to a 'DAC". Much more Mac like, it just works. Even with flash.
Disappointed to drop $100 on another device when everything was working in 10.8.4, but frankly I blame Apple since they can't seem to update anything anymore without breaking ten more things (this issue is not limited to Hackintoshes). And I see your point on clearing up the headaches - what model DAC did you go with?
 
Joined
Sep 5, 2013
Messages
103
Motherboard
GA-H87N-WIFI
CPU
4770
Graphics
GTX 750
Mac
MacBook Air, MacBook Pro
Hum, is it random? Because on my h87-n-wifi i've never had any problem of cracking sound. I don't use chrome though
 
Joined
Sep 22, 2012
Messages
613
Motherboard
UD5H
CPU
3770k OC to 4.8ghz EVO 212
Graphics
GTX 760 SLI
Mac
Classic Mac
Mobile Phone
My crackling issue goes away if I use the black audio port or if I keep a microphone plugged into the front jack.
 
Joined
Apr 17, 2011
Messages
8
Motherboard
Gigabyte Z390 Designare
CPU
i7-9700K
Graphics
UHD 630
Older MultiBeast revisions can be found in the MultiBeast Archive
Tonymacx86, didn't find the 5.5.5 version for OS X 10.8.5 in the archive, is there something wrong with it?
 

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,538
Motherboard
GA-Z270X-UD5
CPU
Core i3-7100
Graphics
HD 630
Mac
MacBook Pro, Mac mini
Classic Mac
Apple, PowerBook
Mobile Phone
iOS
Tonymacx86, didn't find the 5.5.5 version for OS X 10.8.5 in the archive, is there something wrong with it?
That is the current version for 10.8.5- it is in the main download directory.
 
Top