Contribute
Register

Temporary Installation Guide for Haswell Systems [10.8.4 only]

Status
Not open for further replies.
Joined
Nov 22, 2011
Messages
133
Motherboard
Gigabyte H97M-D3H
CPU
Intell Core i5 4690
Graphics
MSI GTX770 Twin Frozr OC
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I'm getting everything installed and all. However, after installing the UserDSDT + NullCPUPowerManagement I won't be able to boot. Basically getting the incompatible CPU family error in a kernel panic. I get this when I boot from USB and choose the HD I've installed MacOS X on. (will post screenshot if I run into that error again).
 
Joined
Nov 22, 2011
Messages
133
Motherboard
Gigabyte H97M-D3H
CPU
Intell Core i5 4690
Graphics
MSI GTX770 Twin Frozr OC
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Odd, getting mixed results now. After I install + do multibeast with UserDSDT + NullCPUPowerManagement I get the apple logo, and then a white screen which doesn't really do anything...
 

Obvious Answer Man

Super Moderator
Joined
Jan 12, 2010
Messages
1,390
I'm getting everything installed and all. However, after installing the UserDSDT + NullCPUPowerManagement I won't be able to boot. Basically getting the incompatible CPU family error in a kernel panic. I get this when I boot from USB and choose the HD I've installed MacOS X on. (will post screenshot if I run into that error again).
Did you do steps 6-9 in the OP?
 
Joined
Mar 8, 2013
Messages
36
Motherboard
Windows8
CPU
4770k
Graphics
770
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
What's op. And BTW I've got the same problems white screen.:banghead:
 
Joined
Nov 22, 2011
Messages
133
Motherboard
Gigabyte H97M-D3H
CPU
Intell Core i5 4690
Graphics
MSI GTX770 Twin Frozr OC
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Did you do steps 6-9 in the OP?

I did. Oddly enough I'm not getting any kernel panics anymore after installing UserDSDT + NullCPUPowerManagement. It's just a white screen. I get the same white screen when I boot the USB stick to install, but after 1 second or so it goes away and I see the installer.

After installing and copying the mech-kernel to the boot disk, it boots fine and all. It's just that as soon as I install the UserDSDT + NullCPUPowerManagement it comes up with the apple logo, then switches to a white screen and it stays on that. No HD activity at all at that point. I doublechecked my multibeast download just to be sure, but that one is the latest version.

- - - Updated - - -

What's op. And BTW I've got the same problems white screen.:banghead:

Original Post ;)

Gonna grab some sleep now, will continue fiddling with this tomorrow :)
 
Joined
Jul 29, 2012
Messages
134
Motherboard
OSX Mavericks 10.9
CPU
Intel i5-4670K
Graphics
EVGA GTX760 2GB
Mac
Classic Mac
Mobile Phone
  1. iOS
Works Great...

but there are some Issues with Sound. It shows correct in Systeminfo but won't work. Am i missing something ?

Installed DSDT-free ALC892...

*EDIT*

Why is my Signature invisible ?
 
Joined
Nov 22, 2011
Messages
133
Motherboard
Gigabyte H97M-D3H
CPU
Intell Core i5 4690
Graphics
MSI GTX770 Twin Frozr OC
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Turns out I have to use graphicsenabler=no for the gtx770. Up and running now!

Stuff to work on:
Sound: Speakers are selectable after installing the without dsdt alc898, but nothing more than some static clicks every few seconds.
Console log shows:
Code:
8/17/13 9:47:14.000 AM kernel[0]: Sound assertion in AppleHDAController at line 5921
8/17/13 9:47:14.000 AM kernel[0]: Sound assertion in AppleHDAController at line 5605
8/17/13 9:47:14.000 AM kernel[0]: Sound assertion in AppleHDAEngine at line 9973
iCloud: iCloud doesn't work and gives the "unable to sign in because of a problem communicating with iCloud" error. Installed hnak's appleintel1000e and got network, just no iCloud. Already tried EthernetBuiltIn=Yes in boot.plist, but it won't budge.
 
Joined
Mar 8, 2013
Messages
36
Motherboard
Windows8
CPU
4770k
Graphics
770
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
Dude, you just made my day.
But cant you download like a driver from multibeast saying that you want to boot with graphicsenabler=no?
 
Joined
Nov 22, 2011
Messages
133
Motherboard
Gigabyte H97M-D3H
CPU
Intell Core i5 4690
Graphics
MSI GTX770 Twin Frozr OC
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Dude, you just made my day.
But cant you download like a driver from multibeast saying that you want to boot with graphicsenabler=no?

Multibeast can! Check the screenshot.
 

Attachments

  • Screen Shot 2013-08-17 at 11.12.55.png
    Screen Shot 2013-08-17 at 11.12.55.png
    133.9 KB · Views: 373
Status
Not open for further replies.
Top