Contribute
Register

Tearing problem Radeon 570 - Multi screen

Joined
Mar 13, 2018
Messages
5
Motherboard
MSI B85M-G43
CPU
i5-4690K, 4x4,2GHz
Graphics
ATI Radeon RX 570 Armor 4G OC
Hi everybody.
I'm building a video installation using simultaneously 6 screens.
Here's the configuration I'm using :

Hackintosh :
- Mobo : MSI B85M-G43
- CPU : i5-4690K, 4x4,2GHz
- GPU : ATI Radeon RX 570 Armor 4G OC
- RAM : Crucial 16Go, DDR3-1600, CL9
- HD : SSD Samsung 850 Pro 500go
- Matrox Triple Head2Go Display Port Edition

Software : Millumin

TV's : 6 TV HD LED HDMI Plugs (4 of 65" and 2 of 40")

I'm experiencing problems with tearing in some videos, quite randomly.
I tried to put the TV's in 50Hz, son it can match with the video frame rates.
When the tearing appears, I tried to close Millumin, and open a window in the finder, when I put this window in te zone of tearing it is still here.
Is it possible for me to help the Radeon with synchronisation with drivers (through Clover configurator maybe ?)
Does anyone have already fought this kind of problems ?
I searched a lot in forums and stuff but it is quite particular due to the installation.
I thank you for your attention !
 
Joined
Mar 13, 2018
Messages
5
Motherboard
MSI B85M-G43
CPU
i5-4690K, 4x4,2GHz
Graphics
ATI Radeon RX 570 Armor 4G OC
Up ! Does anyone have a similar problem with ATI GPU ?
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,923
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Have you used the MultiBeast option that sets RadeonDeInit=Yes in your config.plist? The option takes the place of using Luli and Whatevergreen kexts. If not, run MultiBeast and just select the following:
Customize > Graphics Configuration > AMD Graphics Fixup
Build > Install​
After MultiBeast completes, reboot. You should be good to go now.

See the MultiBeast Features document, page 7, for more information.
 
Joined
Mar 13, 2018
Messages
5
Motherboard
MSI B85M-G43
CPU
i5-4690K, 4x4,2GHz
Graphics
ATI Radeon RX 570 Armor 4G OC
Thank you Stork for your reply.
I'll download Multibeast and try this on next monday and will tell you if the tearing stops !
Many thanks, really !
 
Joined
Mar 13, 2018
Messages
5
Motherboard
MSI B85M-G43
CPU
i5-4690K, 4x4,2GHz
Graphics
ATI Radeon RX 570 Armor 4G OC
Good evening Stork !
I tried the Multibeast option that you suggested : so far, no tearing...
I will use the installation a lot during the next three days, and will tell you if the problem totally disappeared.
Meanwhile, thanks again for your attention !
 
Joined
Mar 13, 2018
Messages
5
Motherboard
MSI B85M-G43
CPU
i5-4690K, 4x4,2GHz
Graphics
ATI Radeon RX 570 Armor 4G OC
Bad news : I still have tearing appearing randomly.
My GPU is called Radeon Pro 570 by my system though, which is good I guess.
Would you have another idea to help refresh the vsync ?
 
Joined
Sep 23, 2018
Messages
1
I had the same problem.
try SwithXRes software .
Set the same refresh rate at all monitors .
For me it solve Your problem.
Regards
 
Joined
Sep 27, 2018
Messages
1
Bad news : I still have tearing appearing randomly.
My GPU is called Radeon Pro 570 by my system though, which is good I guess.
Would you have another idea to help refresh the vsync ?
Hi! I'm having the same problems. Were you able to find a solution?
 
Top