Contribute
Register

System randomly rebooting

Status
Not open for further replies.
Joined
Mar 9, 2011
Messages
73
Motherboard
ASRock Z370M-ITX/ac
CPU
I3-8350K
Graphics
UHD 630
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
I have just updated my son's machine to Mojave (not without issues, but I'm there now).

It is a Gigabyte Z87X-UD5H with a NVIDIA GeForce GTX 770 4 GB graphics card and 32Gb RAM. And two SSD cards (one with new Mojave on and one with Mavericks on which I am migrating from), and two 1Gb HDD (one for data, one for TimeMachine).

The system was working fine on Mavericks.

Issue now is that the machine is randomly restarting, sometimes during boot process, sometimes during logon. After logging on, it seems to be fine.

I have read that NVIDIA is not supported on Mojave, but it seems to work fine - when it works. Any ideas? Thanks in advance folks.
 

Edhawk

Moderator
Joined
Aug 2, 2013
Messages
3,928
Motherboard
MSI Z370-A Pro
CPU
i5-8500
Graphics
Sapphire Pulse RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
The Nvidia GTX 770 graphics card is natively supported in macOs including Mojave, Catalina and Big Sur. So it shouldn't be an issue with the Nvidia GPU causing the reboots.

Depending on which kexts and config.plist settings you have selected it could be a simple issues of uninstalling/deleting a kext or editing your config to solve this issue.

If you have migrated from Mavericks to Mojave you have skipped a lot of changes in macOS. Your bootloader's config may need some settings revised to get it working correctly with Mojave.
  1. Which bootloader are you using, Clover or OpenCore?
  2. Which version of the bootloader are you using?
  3. Assumption: You are using Mojave 10.14.6 and have applied all the macOs supplemental and Security updates.
  4. Do you have any third-party kexts installed to your /System/Library/Extensions (/S/L/E) or /Library/Extensions (/L/E) folder?
    • I ask this because since the release of El Capitan it has been set that the /S/L/E folder in particular should be left unchanged and any third-party kexts, such as FakeSMC.kext, AppleALC.kext, Lilu.kext and WhateverGreen.kext should be placed in the /EFI/CLOVER/kexts/Other folder.
    • Here is a guide that deals with the use of Third-Party kexts - https://www.tonymacx86.com/threads/...an-sierra-high-sierra-mojave-catalina.268964/
  5. Have you created any custom SSDT's for your system, such as SSDT-EC.aml, SSDT-PLUG & SSDT-HPET.aml, these may be required for your system to run Mojave.
    • These can be created using your systems DSDT.aml and Corpnewt's SSDT-Time script. They would be specific for your system, along with a few essential ACPI readme patches.
    • Here is a link to download the SSDT-Time folder from Corpnewt's GitHub repository - https://github.com/corpnewt/SSDTTime
You may want to share your current setup, so we can see what you are using and then make some suggestions that might help solve the current issues you are facing. If you do, just remember to redact/delete the SMBIOS Serial Number, Board Serial Number, SmUUID, MLB and ROM entries from your config.plist before posting a copy here.
 
Joined
Mar 9, 2011
Messages
73
Motherboard
ASRock Z370M-ITX/ac
CPU
I3-8350K
Graphics
UHD 630
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
The Nvidia GTX 770 graphics card is natively supported in macOs including Mojave, Catalina and Big Sur. So it shouldn't be an issue with the Nvidia GPU causing the reboots.

Depending on which kexts and config.plist settings you have selected it could be a simple issues of uninstalling/deleting a kext or editing your config to solve this issue.

If you have migrated from Mavericks to Mojave you have skipped a lot of changes in macOS. Your bootloader's config may need some settings revised to get it working correctly with Mojave.
  1. Which bootloader are you using, Clover or OpenCore?
  2. Which version of the bootloader are you using?
  3. Assumption: You are using Mojave 10.14.6 and have applied all the macOs supplemental and Security updates.
  4. Do you have any third-party kexts installed to your /System/Library/Extensions (/S/L/E) or /Library/Extensions (/L/E) folder?
    • I ask this because since the release of El Capitan it has been set that the /S/L/E folder in particular should be left unchanged and any third-party kexts, such as FakeSMC.kext, AppleALC.kext, Lilu.kext and WhateverGreen.kext should be placed in the /EFI/CLOVER/kexts/Other folder.
    • Here is a guide that deals with the use of Third-Party kexts - https://www.tonymacx86.com/threads/...an-sierra-high-sierra-mojave-catalina.268964/
  5. Have you created any custom SSDT's for your system, such as SSDT-EC.aml, SSDT-PLUG & SSDT-HPET.aml, these may be required for your system to run Mojave.
    • These can be created using your systems DSDT.aml and Corpnewt's SSDT-Time script. They would be specific for your system, along with a few essential ACPI readme patches.
    • Here is a link to download the SSDT-Time folder from Corpnewt's GitHub repository - https://github.com/corpnewt/SSDTTime
You may want to share your current setup, so we can see what you are using and then make some suggestions that might help solve the current issues you are facing. If you do, just remember to redact/delete the SMBIOS Serial Number, Board Serial Number, SmUUID, MLB and ROM entries from your config.plist before posting a copy here.
Many thanks, Edhawk. Let me work through your points one by one and get back to you. It's suppertime here now, so it will be tomorrow morning, UK time, before I can reply.
 
Joined
Mar 9, 2011
Messages
73
Motherboard
ASRock Z370M-ITX/ac
CPU
I3-8350K
Graphics
UHD 630
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Here are the first replies. More to follow.

The Nvidia GTX 770 graphics card is natively supported in macOs including Mojave, Catalina and Big Sur. So it shouldn't be an issue with the Nvidia GPU causing the reboots.

Depending on which kexts and config.plist settings you have selected it could be a simple issues of uninstalling/deleting a kext or editing your config to solve this issue.

If you have migrated from Mavericks to Mojave you have skipped a lot of changes in macOS. Your bootloader's config may need some settings revised to get it working correctly with Mojave.
  1. Which bootloader are you using, Clover or OpenCore?
Clover 4934

  1. Which version of the bootloader are you using?
  2. Assumption: You are using Mojave 10.14.6 and have applied all the macOs supplemental and Security updates.

I have done a clean install (not an update, I tried that and got into a right pickle) of Mojave 10.14.6. I have now applied the security and supplemental updates.

  1. Do you have any third-party kexts installed to your /System/Library/Extensions (/S/L/E) or /Library/Extensions (/L/E) folder?
    • I ask this because since the release of El Capitan it has been set that the /S/L/E folder in particular should be left unchanged and any third-party kexts, such as FakeSMC.kext, AppleALC.kext, Lilu.kext and WhateverGreen.kext should be placed in the /EFI/CLOVER/kexts/Other folder.
    • Here is a guide that deals with the use of Third-Party kexts - https://www.tonymacx86.com/threads/...an-sierra-high-sierra-mojave-catalina.268964/

I will investigate and report.

  1. Have you created any custom SSDT's for your system, such as SSDT-EC.aml, SSDT-PLUG & SSDT-HPET.aml, these may be required for your system to run Mojave.
    • These can be created using your systems DSDT.aml and Corpnewt's SSDT-Time script. They would be specific for your system, along with a few essential ACPI readme patches.
    • Here is a link to download the SSDT-Time folder from Corpnewt's GitHub repository - https://github.com/corpnewt/SSDTTime

No, I haven't.

You may want to share your current setup, so we can see what you are using and then make some suggestions that might help solve the current issues you are facing. If you do, just remember to redact/delete the SMBIOS Serial Number, Board Serial Number, SmUUID, MLB and ROM entries from your config.plist before posting a copy here.

I had trouble getting my config.plist last night. Will try through other means today.

Thanks again. More to follow.

Steve
 
Joined
Mar 9, 2011
Messages
73
Motherboard
ASRock Z370M-ITX/ac
CPU
I3-8350K
Graphics
UHD 630
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
  1. Do you have any third-party kexts installed to your /System/Library/Extensions (/S/L/E) or /Library/Extensions (/L/E) folder?
    • I ask this because since the release of El Capitan it has been set that the /S/L/E folder in particular should be left unchanged and any third-party kexts, such as FakeSMC.kext, AppleALC.kext, Lilu.kext and WhateverGreen.kext should be placed in the /EFI/CLOVER/kexts/Other folder.
    • Here is a guide that deals with the use of Third-Party kexts - https://www.tonymacx86.com/threads/...an-sierra-high-sierra-mojave-catalina.268964/
  2. Have you created any custom SSDT's for your system, such as SSDT-EC.aml, SSDT-PLUG & SSDT-HPET.aml, these may be required for your system to run Mojave.
    • These can be created using your systems DSDT.aml and Corpnewt's SSDT-Time script. They would be specific for your system, along with a few essential ACPI readme patches.
    • Here is a link to download the SSDT-Time folder from Corpnewt's GitHub repository - https://github.com/corpnewt/SSDTTime
You may want to share your current setup, so we can see what you are using and then make some suggestions that might help solve the current issues you are facing. If you do, just remember to redact/delete the SMBIOS Serial Number, Board Serial Number, SmUUID, MLB and ROM entries from your config.plist before posting a copy here.
Here is a redacted version of my config file. Since I did a clean install with the recommended UniBeast and Multibeast, I assume that I have only incorporated valid components. I have redacted what I found. Please let me know if I missed something.

I will have a read of the guide that you linked to next.
 

Attachments

  • config copy for TonyMac.txt
    5.4 KB · Views: 32
Joined
Mar 9, 2011
Messages
73
Motherboard
ASRock Z370M-ITX/ac
CPU
I3-8350K
Graphics
UHD 630
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Do you have any third-party kexts installed to your /System/Library/Extensions (/S/L/E) or /Library/Extensions (/L/E) folder?
  • I ask this because since the release of El Capitan it has been set that the /S/L/E folder in particular should be left unchanged and any third-party kexts, such as FakeSMC.kext, AppleALC.kext, Lilu.kext and WhateverGreen.kext should be placed in the /EFI/CLOVER/kexts/Other folder.
  • Here is a guide that deals with the use of Third-Party kexts - https://www.tonymacx86.com/threads/...an-sierra-high-sierra-mojave-catalina.268964/
The attached is System/Library/Extensions. I installed some of my son's music apps. But this was after the instability.

There is no Library/Extensions folder for the Admin account I am using.
 

Attachments

  • Screenshot 2021-06-14 at 10.43.00.png
    Screenshot 2021-06-14 at 10.43.00.png
    63.2 KB · Views: 33

Feartech

Moderator
Joined
Aug 3, 2013
Messages
27,565
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
The attached is System/Library/Extensions. I installed some of my son's music apps. But this was after the instability.

There is no Library/Extensions folder for the Admin account I am using.
you should keep your hackintosh kexts in your efi
 

Edhawk

Moderator
Joined
Aug 2, 2013
Messages
3,928
Motherboard
MSI Z370-A Pro
CPU
i5-8500
Graphics
Sapphire Pulse RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
For future reference don't rename the config.plist with the .txt file type. That is not the correct way to save a config and is likely to corrupt the file.

Tools for editing config.plist:
I would recommend you download and use Clover Configurator when opening, saving and editing config.plist files - https://mackie100projects.altervista.org/download-clover-configurator/

Kexts:
First you should not have these kexts in your /Library/Extensions folder:
  • AppleALC.kext
  • FackeSMC.kext
  • Lilu.kext
They should all be in the /EFI/CLOVER/kexts/Other folder.

Along with these additional kexts:
  • WhateverGreen.kext - For Intel and Nvidia graphics
  • USBInjectAll.kext - For Intel USB ports
  • IntelMausiEthernet.kext - your motherboard has two Intel Ethernet ports so you probably need a second ethernet kext this might be the SmallTreeIntel82576.kext.
  • AHCIPortInjector.kext - cosmetic for additional (Marvell) SATA port identification
These additional kexts along with the latest versions of AppleALC and Lilu.kext are attached below for you to use in your /EFI/CLOVER/kexts/Other folder.

SSDT:
I have also attached an SSDT-XOSI.aml, which will need to be added to the /EFI/CLOVER/ACPI/patched folder. This SSDT works in conjunction with an ACPI Rename Patch. When used together they help your system work better with macOS.

Config.plist:
Your config lacks a lot of common patches, fixes and other entries that are common for a Z87/Z97 Haswell system.

Below I have attached screenshots of your current config.plist (left hand images) and beside that I have attached screenshots of the settings I use with my Haswell system, both Z87 and Z97 motherboards.

1.ACPI screenshot, no rename patches, not CPU power Management options or ACPI fixes selected.
Screenshot 2021-06-14 at 15.40.31.png Screenshot 2021-06-14 at 15.40.42.png

2. ACPI screenshot 2, additional ACPI fixes not selected.
Screenshot 2021-06-14 at 15.49.34.png Screenshot 2021-06-14 at 15.40.55.png

3. Boot screenshot, lack of boot arguments, NeverHibernate option not selected
Screenshot 2021-06-14 at 15.41.07.png Screenshot 2021-06-14 at 15.41.35.png

4. Devices screenshot, no need for Fake ID 0x0 entries, Audio HDAreset not selected, no IGPU framebuffer in the Properties section. The one shown is for a HD4600 using the iMac 15,1 SMBIOS.
Screenshot 2021-06-14 at 15.41.57.png Screenshot 2021-06-14 at 15.42.08.png

5. GUI screenshot, the Haswell board uses an UEFI bios, so no need to select Legacy=first, Additional Hide volumes can be added to keep the Clover boot screen clear. Changed boot theme name to Mojave.
Screenshot 2021-06-14 at 15.42.26.png Screenshot 2021-06-14 at 15.42.38.png

6. Graphics screenshot, you do not need to use Intel Inject=true when using WhateverGreen.kext and the appropriate Intel framebuffer, as shown in the Devices > Properties section in screenshot 4. No other Graphics options required for your GTX 770 discrete graphics card either. WhateverGreen.kext will deal with any renames and fixes for your Nvidia card.
Screenshot 2021-06-14 at 15.42.54.png Screenshot 2021-06-14 at 15.43.04.png

7. Kexts and Kernel Patches screenshot, as you were migrating from Mavericks to Mojave you will have completely missed the need to add the USB port Limit patches to your config.plist. These four patches for Mojave (bottom two are for Catalina) are required so your USB ports work with macOS in Mojave. I have also adde the Kernel Fix 'AppleRTC=true' and patches for Trim on an SSD and External icons (Yellow) fix.
Screenshot 2021-06-14 at 15.43.17.png Screenshot 2021-06-14 at 15.43.42.png

8. Rt Variables screenshot, this contains a new MLB and a ROM generated using the iMac 15,1 SMBIOS, both of which are essential when trying to get Messages, iTunes, App Store and iCloud to work correctly.
Screenshot 2021-06-14 at 15.43.56.png Screenshot 2021-06-14 at 15.44.24.png

9. SMBIOS screenshot, I have changed the SMBIOS to the iMac 15,1 (if you hadn't guessed that already) as this is a more compatible SMBIOS for the newer versions of macOS up to and incluidng Big Sur. It doesn't work in the new beta of macOS Monterey, as Apple dropped these systems from support (well not without an additional boot argument). The SMBIOS screen should be fully populated if you want your son's system to run macOS Mojave correctly.
Screenshot 2021-06-14 at 15.44.36.png Screenshot 2021-06-14 at 15.44.48.png

10. System Parameters screenshot, you don't need to have the 'Inject System ID=true' option enabled, as it is not used by Clover, it is a carry over from Chameleon/Chimera that is no longer used. You should have the Inject Kexts=true option enabled when you have your system's kexts added to the /EFI/CLOVER/kexts/Other folder, as instructed above.
Screenshot 2021-06-14 at 15.45.02.png Screenshot 2021-06-14 at 15.45.30.png

A copy of the config-Haswell.plist is attached below, for you to use as a base for the changes required to your current config.plist.

I have also attached a copy of the the Mojave boot theme, which you should add to your /eFI/CLOVER/themes folder.

screenshot.png Mojave theme for the boot screen.

Hope this helps.
 

Attachments

  • Additional Kexts.zip
    1.6 MB · Views: 28
  • SSDT-XOSI.aml.zip
    685 bytes · Views: 32
  • config-Haswell.plist 2.zip
    2.5 KB · Views: 27
  • Mojave.zip
    803.5 KB · Views: 32
Joined
Mar 9, 2011
Messages
73
Motherboard
ASRock Z370M-ITX/ac
CPU
I3-8350K
Graphics
UHD 630
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
For future reference don't rename the config.plist with the .txt file type. That is not the correct way to save a config and is likely to corrupt the file.

Tools for editing config.plist:
I would recommend you download and use Clover Configurator when opening, saving and editing config.plist files - https://mackie100projects.altervista.org/download-clover-configurator/

Kexts:
First you should not have these kexts in your /Library/Extensions folder:
  • AppleALC.kext
  • FackeSMC.kext
  • Lilu.kext
They should all be in the /EFI/CLOVER/kexts/Other folder.

Along with these additional kexts:
  • WhateverGreen.kext - For Intel and Nvidia graphics
  • USBInjectAll.kext - For Intel USB ports
  • IntelMausiEthernet.kext - your motherboard has two Intel Ethernet ports so you probably need a second ethernet kext this might be the SmallTreeIntel82576.kext.
  • AHCIPortInjector.kext - cosmetic for additional (Marvell) SATA port identification
These additional kexts along with the latest versions of AppleALC and Lilu.kext are attached below for you to use in your /EFI/CLOVER/kexts/Other folder.

SSDT:
I have also attached an SSDT-XOSI.aml, which will need to be added to the /EFI/CLOVER/ACPI/patched folder. This SSDT works in conjunction with an ACPI Rename Patch. When used together they help your system work better with macOS.

Config.plist:
Your config lacks a lot of common patches, fixes and other entries that are common for a Z87/Z97 Haswell system.

Below I have attached screenshots of your current config.plist (left hand images) and beside that I have attached screenshots of the settings I use with my Haswell system, both Z87 and Z97 motherboards.

1.ACPI screenshot, no rename patches, not CPU power Management options or ACPI fixes selected.
View attachment 521737 View attachment 521738

2. ACPI screenshot 2, additional ACPI fixes not selected.
View attachment 521756 View attachment 521739

3. Boot screenshot, lack of boot arguments, NeverHibernate option not selected
View attachment 521740 View attachment 521741

4. Devices screenshot, no need for Fake ID 0x0 entries, Audio HDAreset not selected, no IGPU framebuffer in the Properties section. The one shown is for a HD4600 using the iMac 15,1 SMBIOS.
View attachment 521742 View attachment 521743

5. GUI screenshot, the Haswell board uses an UEFI bios, so no need to select Legacy=first, Additional Hide volumes can be added to keep the Clover boot screen clear. Changed boot theme name to Mojave.
View attachment 521744 View attachment 521745

6. Graphics screenshot, you do not need to use Intel Inject=true when using WhateverGreen.kext and the appropriate Intel framebuffer, as shown in the Devices > Properties section in screenshot 4. No other Graphics options required for your GTX 770 discrete graphics card either. WhateverGreen.kext will deal with any renames and fixes for your Nvidia card.
View attachment 521746 View attachment 521747

7. Kexts and Kernel Patches screenshot, as you were migrating from Mavericks to Mojave you will have completely missed the need to add the USB port Limit patches to your config.plist. These four patches for Mojave (bottom two are for Catalina) are required so your USB ports work with macOS in Mojave. I have also adde the Kernel Fix 'AppleRTC=true' and patches for Trim on an SSD and External icons (Yellow) fix.
View attachment 521748 View attachment 521749

8. Rt Variables screenshot, this contains a new MLB and a ROM generated using the iMac 15,1 SMBIOS, both of which are essential when trying to get Messages, iTunes, App Store and iCloud to work correctly.
View attachment 521750 View attachment 521751

9. SMBIOS screenshot, I have changed the SMBIOS to the iMac 15,1 (if you hadn't guessed that already) as this is a more compatible SMBIOS for the newer versions of macOS up to and incluidng Big Sur. It doesn't work in the new beta of macOS Monterey, as Apple dropped these systems from support (well not without an additional boot argument). The SMBIOS screen should be fully populated if you want your son's system to run macOS Mojave correctly.
View attachment 521752 View attachment 521753

10. System Parameters screenshot, you don't need to have the 'Inject System ID=true' option enabled, as it is not used by Clover, it is a carry over from Chameleon/Chimera that is no longer used. You should have the Inject Kexts=true option enabled when you have your system's kexts added to the /EFI/CLOVER/kexts/Other folder, as instructed above.
View attachment 521754 View attachment 521755

A copy of the config-Haswell.plist is attached below, for you to use as a base for the changes required to your current config.plist.

I have also attached a copy of the the Mojave boot theme, which you should add to your /eFI/CLOVER/themes folder.

View attachment 521759 Mojave theme for the boot screen.

Hope this helps.
Wow, Edhawk. Thank you so much. That's such a full and diligent reply. It's going to take me a while to work through this and set up a to-do list. I'm going to go dark for a while as I do this. I'll be back.
 
Joined
Mar 9, 2011
Messages
73
Motherboard
ASRock Z370M-ITX/ac
CPU
I3-8350K
Graphics
UHD 630
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
The latest news here is that I started Clover Configurator and did as it suggested and updated my version of Clover to the latest and restarted --- and now I can't boot the system at all. I can't get past Clover, which tells me it has a config.plist problem and can't present me with a list of UEFI drives to select from. So right now, the system is bricked and I can't figure out at way back in.

I can reboot from the Flash drive, but that doesn't get me very far (I'm typing this on a macbook).

Any ideas how I get from a latest version of Clover boot screen back to my Mojave, which I was making progress on Edhawk's worklist?

Thanks.
 
Status
Not open for further replies.
Top