Contribute
Register

System halted after updating 5109

Status
Not open for further replies.
Joined
Nov 25, 2019
Messages
5
Motherboard
Gigabyte GA-Z170-HD3P
CPU
i5-7600k
Graphics
Sapphire RX580 8Gb Nitro+ SE
After restart doesn't show the list of disks but this error.

XArray::ElementAt(xsize) -> Operator [] : index > m_lenA fatal error happened. System halted.

How i can downgrade or solve this problem?

Thanks in advance.
I had the same problem.

Remove strings from config.plist
<key>ScreenResolution</key>
<string>...</string>

and change Theme

<key>Theme</key>
<string>...</string>
or remove this strings too.

And you will be happy :)
 
Last edited:
Joined
Apr 6, 2020
Messages
2
Motherboard
Gigabyte GA-Z97N-wifi
CPU
Intel i3
Graphics
Intel HD Graphics 4600 1536 MB graphics
Hi there.

It depends on which version of macOS you are running. The El Capitan USB installer should be able to boot your system, at least if it is pre-Mojave, maybe even Mojave and Catalina. You can actually use the Clover Options menu to turn-off any settings that might interfere, or add ones you need. You are after a basic boot here, it doesn't matter at this point if sound or LAN works, or if graphics are accelerated etc. Then, if you can boot just copy the older Clover installer you know is okay, to the destination drive and run it.

You can do quite a lot just using the Terminal app on the El Cap installer, but that depends on your confidence using it.

:)

Hey all, thanks for all of the quick replies. I managed to downgrade back, and my system is working very well now. Don't know where I'd be without Unibeast though!

Cheers
 
Joined
May 28, 2018
Messages
44
Motherboard
Intel NUC8i5BEH
CPU
i5-8259U
Graphics
Iris Plus 655
5111 released a little while ago. also seems to have theme issues. as I find one them that still works (carbon) , I did not roll back.
 
Joined
May 24, 2018
Messages
37
Motherboard
Asus Rog Strix Z370e
CPU
i7-8700K
Graphics
HD 630
Mac
  1. iMac
  2. MacBook
Mobile Phone
  1. Android
Long time I didn't update and got same issue with 5112.
Trying @djchange fix got me this error when loading config.plist in CC
Clover Configurator could not be synchronized because an error occurred: Close tag on line 581 does not match open tag dict

I must have deleted something wrong ! I boot from an old EFI backup under clover 4741

What would be the best way to fix this ? any help much appreciated

1<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>ACPI</key>
<dict>
<key>DSDT</key>
<dict>
<key>Debug</key>
<false/>
<key>DropOEM_DSM</key>
<false/>
<key>Fixes</key>
<dict>
<key>FixHDA</key>
<true/>
<key>FixShutdown</key>
<true/>
</dict>
<key>Name</key>
<string>DSDT.aml</string>
<key>Patches</key>
<array>
<dict>
<key>Comment</key>
<string>Rename HDAS to HDEF</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
SERBUw==
</data>
<key>Replace</key>
<data>
SERFRg==
</data>
</dict>
<dict>
<key>Comment</key>
<string>change SAT0 to SATA</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
U0FUMA==
</data>
<key>Replace</key>
<data>
U0FUQQ==
</data>
</dict>
<dict>
<key>Comment</key>
<string>change HECI to IMEI</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
SEVDSQ==
</data>
<key>Replace</key>
<data>
SU1FSQ==
</data>
</dict>
<dict>
<key>Comment</key>
<string>change GFX0 to IGPU</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
R0ZYMA==
</data>
<key>Replace</key>
<data>
SUdQVQ==
</data>
</dict>
<dict>
<key>Comment</key>
<string>change PEGP to GFX0</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
UEVHUA==
</data>
<key>Replace</key>
<data>
R0ZYMA==
</data>
</dict>
<dict>
<key>Comment</key>
<string>change PPMC to PMCR</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
UFBNQw==
</data>
<key>Replace</key>
<data>
UE1DUg==
</data>
</dict>
<dict>
<key>Comment</key>
<string>change EC0 to EC</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
RUMwXw==
</data>
<key>Replace</key>
<data>
RUNfXw==
</data>
</dict>
</array>
<key>ReuseFFFF</key>
<false/>
</dict>
<key>SSDT</key>
<dict>
<key>DropOem</key>
<false/>
<key>Generate</key>
<dict>
<key>CStates</key>
<false/>
<key>PStates</key>
<false/>
<key>PluginType</key>
<true/>
</dict>
</dict>
</dict>
<key>Boot</key>
<dict>
<key>Arguments</key>
<string>dart=0 -alcbeta shikigva=60 nvda_drv=1 -lilubetaall keepsyms=1 -disablegfxfirmware -wegbeta</string>
<key>CustomLogo</key>
<string>Apple</string>
<key>Debug</key>
<false/>
<key>DefaultVolume</key>
<string>LastBootedVolume</string>
<key>Legacy</key>
<string>PBR</string>
<key>Secure</key>
<false/>
<key>Timeout</key>
<integer>3</integer>
<key>XMPDetection</key>
<string>Yes</string>
</dict>
<key>CPU</key>
<dict>
<key>UseARTFrequency</key>
<false/>
</dict>
<key>Devices</key>
<dict>
<key>Audio</key>
<dict>
<key>Inject</key>
<integer>7</integer>
<key>ResetHDA</key>
<true/>
</dict>
<key>FakeID</key>
<dict>
<key>ATI</key>
<string>0x0</string>
<key>IMEI</key>
<string>0x0</string>
<key>IntelGFX</key>
<string>0x59128086</string>
<key>LAN</key>
<string>0x0</string>
<key>NVidia</key>
<string>0x0</string>
<key>SATA</key>
<string>0x0</string>
<key>WIFI</key>
<string>0x0</string>
<key>XHCI</key>
<string>0x0</string>
</dict>
<key>USB</key>
<dict>
<key>FixOwnership</key>
<false/>
<key>HighCurrent</key>
<true/>
<key>Inject</key>
<false/>
</dict>
</dict>
<key>DisableDrivers</key>
<array>
<string>Nothing</string>
</array>
<key>GUI</key>
<dict>
<key>ConsoleMode</key>
<string>Mix</string>
<key>CustomIcons</key>
<false/>
<key>EmbeddedThemeType</key>
<string>Daytime</string>
<key>Hide</key>
<array>
<string>\EFI\BOOT\BOOTX64.EFI</string>
</array>
<key>Language</key>
<string>en:0</string>
<key>Mouse</key>
<dict>
<key>DoubleClick</key>
<integer>500</integer>
<key>Enabled</key>
<true/>
<key>Mirror</key>
<false/>
<key>Speed</key>
<integer>8</integer>
</dict>
<key>Scan</key>
<dict>
<key>Entries</key>
<true/>
<key>Legacy</key>
<true/>
<key>Linux</key>
<true/>
<key>Tool</key>
<true/>
</dict>
<key>Graphics</key>
<dict>
<key>Inject</key>
<dict>
<key>ATI</key>
<false/>
<key>Intel</key>
<false/>
<key>NVidia</key>
<false/>
</dict>
<key>NvidiaSingle</key>
<false/>
<key>RadeonDeInit</key>
<false/>
<key>ig-platform-id</key>
<string>0x59120000</string>
</dict>
<key>KernelAndKextPatches</key>
<dict>
<key>AppleIntelCPUPM</key>
<true/>
<key>AppleRTC</key>
<true/>
<key>Debug</key>
<false/>
<key>DellSMBIOSPatch</key>
<false/>
<key>KernelCpu</key>
<false/>
<key>KernelLapic</key>
<false/>
<key>KernelPm</key>
<true/>
<key>KernelXCPM</key>
<true/>
<key>KextsToPatch</key>
<array>
<dict>
<key>Comment</key>
<string>Enable TRIM for SSD</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
AEFQUExFIFNTRAA=
</data>
<key>InfoPlistPatch</key>
<false/>
<key>Name</key>
<string>com.apple.iokit.IOAHCIBlockStorage</string>
<key>Replace</key>
<data>
AAAAAAAAAAAAAAA=
</data>
</dict>
<dict>
<key>Comment</key>
<string>Disable NVDARequiredOS</string>
<key>Disabled</key>
<true/>
<key>Find</key>
<data>
TlZEQVJlcXVpcmVkT1MA
</data>
<key>InfoPlistPatch</key>
<false/>
<key>Name</key>
<string>NVDAStartupWeb</string>
<key>Replace</key>
<data>
AAAAAAAAAAAAAAAAAAAA
</data>
</dict>
<dict>
<key>Comment</key>
<string>USB Port limit patch 10.14.1 10.14.2 Beta by DalianSky</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
g/sPD4OPBAAA
</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.14,10.14.1,10.14.2</string>
<key>Name</key>
<string>com.apple.driver.usb.AppleUSBXHCI</string>
<key>Replace</key>
<data>
g/sPkJCQkJCQ
</data>
</dict>
<dict>
<key>Comment</key>
<string>USB Port limit patch 10.14 (credits FredWst)</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
g/sPD4MDBQAA
</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.14.0</string>
<key>Name</key>
<string>com.apple.driver.usb.AppleUSBXHCI</string>
<key>Replace</key>
<data>
g/sPkJCQkJCQ
</data>
</dict>
<dict>
<key>Comment</key>
<string>USB 10.13.6+ by PMHeart+FredWst</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
g32IDw+DpwQAAA==
</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.13.6</string>
<key>Name</key>
<string>com.apple.driver.usb.AppleUSBXHCI</string>
<key>Replace</key>
<data>
g32ID5CQkJCQkA==
</data>
</dict>
<dict>
<key>Comment</key>
<string>disable port limit in XHCI kext (credit PMHeart)</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
g32UDw+DlwQAAA==
</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.13.4,10.13.5</string>
<key>Name</key>
<string>com.apple.driver.usb.AppleUSBXHCI</string>
<key>Replace</key>
<data>
g32UD5CQkJCQkA==
</data>
</dict>
<dict>
<key>Comment</key>
<string>change 15 port limit to 26 in XHCI kext (credit FredWst)</string>
<key>Disabled</key>
<true/>
<key>Find</key>
<data>
g32UDw+DlwQ=
</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.13.4</string>
<key>Name</key>
<string>com.apple.driver.usb.AppleUSBXHCI</string>
<key>Replace</key>
<data>
g32UGg+DlwQ=
</data>
</dict>
<dict>
<key>Comment</key>
<string>Change 15 port limit to 24 in XHCI kext 10.13 PB1</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
g32MEA==
</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.13.0,10.13.1,10.13.2,10.13.3</string>
<key>Name</key>
<string>AppleUSBXHCIPCI</string>
<key>Replace</key>
<data>
g32MGw==
</data>
</dict>
<dict>
<key>Comment</key>
<string>change 15 port limit to 26 in XHCI kext</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
g710////EA==
</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.12.x</string>
<key>Name</key>
<string>com.apple.driver.usb.AppleUSBXHCIPCI</string>
<key>Replace</key>
<data>
g710////Gw==
</data>
</dict>
<dict>
<key>Comment</key>
<string>change 15 port limit to 26 in XHCI kext</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
g72M/v//EA==
</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.11.x</string>
<key>Name</key>
<string>com.apple.driver.usb.AppleUSBXHCIPCI</string>
<key>Replace</key>
<data>
g72M/v//Gw==
</data>
</dict>
<dict>
<key>Comment</key>
<string>External icons patch</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
RXh0ZXJuYWw=
</data>
<key>InfoPlistPatch</key>
<false/>
<key>Name</key>
<string>AppleAHCIPort</string>
<key>Replace</key>
<data>
SW50ZXJuYWw=
</data>
</dict>
<dict>
<key>Comment</key>
<string>AQC 107 10 GbE v2</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
YnVpbHQtaW4=
</data>
<key>InfoPlistPatch</key>
<false/>
<key>Name</key>
<string>AppleEthernetAquantiaAqtion</string>
<key>Replace</key>
<data>
qrvM3aq7zN0=
</data>
</dict>
</array>
</dict>
<key>RtVariables</key>
<dict>
<key>BooterConfig</key>
<string>0x28</string>
<key>CsrActiveConfig</key>
<string>0x3</string>
<key>ROM</key>
<string>UseMacAddr0</string>
</dict>
<key>SMBIOS</key>
<dict>
<key>BiosReleaseDate</key>
<string>08/30/2019</string>
<key>BiosVendor</key>
<string>Apple Inc.</string>
<key>BiosVersion</key>
<string>IM191.88Z.F000.B00.1908302134</string>
<key>Board-ID</key>
<string>Mac-4B682C642B45593E</string>
<key>BoardManufacturer</key>
<string>Apple Inc.</string>
<key>BoardSerialNumber</key>
<string>C02712200J9H69FJC</string>
<key>BoardType</key>
<integer>10</integer>
<key>BoardVersion</key>
<string>1.0</string>
<key>ChassisAssetTag</key>
<string>iMac-Aluminum</string>
<key>ChassisManufacturer</key>
<string>Apple Inc.</string>
<key>ChassisType</key>
<string>0x09</string>
<key>EfiVersion</key>
<string>1037.0.73.0.0</string>
<key>Family</key>
<string>iMac</string>
<key>FirmwareFeatures</key>
<string>0xFD8FF576</string>
<key>FirmwareFeaturesMask</key>
<string>0xFFDFFF7F</string>
<key>LocationInChassis</key>
<string>Part Component</string>
<key>Manufacturer</key>
<string>Apple Inc.</string>
<key>Mobile</key>
<false/>
<key>PlatformFeature</key>
<string>0x22</string>
<key>ProductName</key>
<string>iMac19,1</string>
<key>SerialNumber</key>
<string>C02TGZYFH7JY</string>
<key>SmUUID</key>
<string>0D6728B7-6CBA-434C-89B4-05FB6E5500CE</string>
<key>Version</key>
<string>1.0</string>
</dict>
<key>SystemParameters</key>
<dict>
<key>InjectKexts</key>
<string>Yes</string>
<key>InjectSystemID</key>
<true/>
</dict>
</dict>
581</plist>
 
Joined
Nov 25, 2019
Messages
5
Motherboard
Gigabyte GA-Z170-HD3P
CPU
i5-7600k
Graphics
Sapphire RX580 8Gb Nitro+ SE
Long time I didn't update and got same issue with 5112.
Trying @djchange fix got me this error when loading config.plist in CC
Clover Configurator could not be synchronized because an error occurred: Close tag on line 581 does not match open tag dict

I must have deleted something wrong ! I boot from an old EFI backup under clover 4741

What would be the best way to fix this ? any help much appreciated
Don't use Clover Configurator!
I attach my config.plist - it can be used
and update kexts: Lilu.kext and WhateverGreen.kext from github
 

Attachments

  • config.plist.zip
    2.5 KB · Views: 55
Joined
May 28, 2018
Messages
44
Motherboard
Intel NUC8i5BEH
CPU
i5-8259U
Graphics
Iris Plus 655
updated clover to 5117. All the themes that were failing on earlier versions, preventing successful boot now work for me!
 
Status
Not open for further replies.
Top