Contribute
Register

System doesn't boot after installation.

Status
Not open for further replies.
Joined
Jan 9, 2018
Messages
8
Motherboard
ASUS Rog Strix Z370-G
CPU
i7- 8700K Coffee Lake
Graphics
IGPU
Mac
  1. iMac
  2. MacBook
Hey Folks

So I just put together my first Hackintosh. When it turned on I installed High Sierra without a worry and ran MultiBeast to do the post-Installation. So Far so good.
I installed everything but wasn't sure which Graphics driver to install for my Onboard GPU (Coffee Lake 8700K), so I went with HD630. However, after rebooting it didn't give me HD graphics so I ran MultiBeast again and only checked Intel HD3000 and Installed it.
There it is. Now whenever I turn it on it doesn't boot. It shows the bar underneath the Apple to boot and automatically reboots after it's done. Same thing for when trying to boot from my USB.

Any recommendations? Please consider that I'm new to this and not an IT guy. Would boot flags help me? If so which?

Thank you for any help!

ASUS Rog Strix Z370-G
Intel 8700K
500GB 960PRO SSD
2x16GB Ballistix Sports
 
Joined
Jul 25, 2012
Messages
6,711
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hey Folks

So I just put together my first Hackintosh. When it turned on I installed High Sierra without a worry and ran MultiBeast to do the post-Installation. So Far so good.
I installed everything but wasn't sure which Graphics driver to install for my Onboard GPU (Coffee Lake 8700K), so I went with HD630. However, after rebooting it didn't give me HD graphics so I ran MultiBeast again and only checked Intel HD3000 and Installed it.
There it is. Now whenever I turn it on it doesn't boot. It shows the bar underneath the Apple to boot and automatically reboots after it's done. Same thing for when trying to boot from my USB.

Any recommendations? Please consider that I'm new to this and not an IT guy. Would boot flags help me? If so which?

Thank you for any help!

ASUS Rog Strix Z370-G
Intel 8700K
500GB 960PRO SSD
2x16GB Ballistix Sports

  • This is a long shot but worth trying if you can boot to Clover Boot Manager(CBM) Screen and edit "Options".
    • Reboot
    • Once in CBM screen , immediately scroll down to "Options" below the disk icons, before automatic booting starts
    • As shown in the uploaded 3 images, type in to edit the fields shown.
    • Note: in SMBIOS only needed editing is Product Name: field as "iMac18,3" ; other fields can be left unfilled
    • Once editing is completed, press Return to reach CBM screen and boot your System disk.
    • Take photo(s) of any screen image you find as a problem during this troubleshoot to upload to the Forum
  • If this succeeds to reach desktop you will need to edit CLOVER.
  • If you need help, please post again in detail with screen images as needed to amplify.
 

Attachments

  • 1_CBM_Optiosn_Boot Args.png
    1_CBM_Optiosn_Boot Args.png
    879.8 KB · Views: 273
  • 2.CBM_Options_SMBIOSpng.png
    2.CBM_Options_SMBIOSpng.png
    1.1 MB · Views: 267
  • 3_.CBM_Options_Graphics Injector.png
    3_.CBM_Options_Graphics Injector.png
    696.3 KB · Views: 244
Joined
Jan 9, 2018
Messages
8
Motherboard
ASUS Rog Strix Z370-G
CPU
i7- 8700K Coffee Lake
Graphics
IGPU
Mac
  1. iMac
  2. MacBook
  • This is a long shot but worth trying if you can boot to Clover Boot Manager(CBM) Screen and edit "Options".
    • Reboot
    • Once in CBM screen , immediately scroll down to "Options" below the disk icons, before automatic booting starts
    • As shown in the uploaded 3 images, type in to edit the fields shown.
    • Note: in SMBIOS only needed editing is Product Name: field as "iMac18,3" ; other fields can be left unfilled
    • Once editing is completed, press Return to reach CBM screen and boot your System disk.
    • Take photo(s) of any screen image you find as a problem during this troubleshoot to upload to the Forum
  • If this succeeds to reach desktop you will need to edit CLOVER.
  • If you need help, please post again in detail with screen images as needed to amplify.
Hey cmn

It worked, thank you!
You don't happen to also know what to change in CLOVER (I assume that you are talking about the config.plist)?
 
Joined
Jul 25, 2012
Messages
6,711
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hey cmn

It worked, thank you!
You don't happen to also know what to change in CLOVER (I assume that you are talking about the config.plist)?
  • Yes. I can help you with that.
  • You need to first mount EFI partition of the System Hard disk using Clover Configurator Vibrant; DOWNLOAD
  • Download and install that .
  • Give me time to post images of how to use that to edit your CLOVER in a few minutes.
 

Attachments

  • 1.B Mount EFI Partition on desktop.png
    1.B Mount EFI Partition on desktop.png
    423.1 KB · Views: 266
  • 2.CCV Mount EFI .png
    2.CCV Mount EFI .png
    300 KB · Views: 225
  • 2.Save edited config.png
    2.Save edited config.png
    308.9 KB · Views: 215
Joined
Jan 9, 2018
Messages
8
Motherboard
ASUS Rog Strix Z370-G
CPU
i7- 8700K Coffee Lake
Graphics
IGPU
Mac
  1. iMac
  2. MacBook
  • Yes. I can help you with that.
  • You need to first mount EFI partition of the System Hard disk using Clover Configurator Vibrant; DOWNLOAD
  • Download and install that .
  • Give me time to post images of how to use that to edit your CLOVER in a few minutes.
I can't seem to mount it to my desktop. It appears in my finder, but not on my desktop. Did you just drag and drop it?
 
Joined
Jul 25, 2012
Messages
6,711
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hey cmn

It worked, thank you!
You don't happen to also know what to change in CLOVER (I assume that you are talking about the config.plist)?

  • If you have not already setup "Finder"-> "Preferences", please do so by clicking "Finder>Preferences> [√] Hard disks [√] External disks
  • This will mount the icons of connected disks on the Right side of your Desktop screen for easy access.
  • Launch downloaded CCV
  • Mount EFI of your System Hard disk (dark icon) on the Desktop as shown in the CCV screen shots.
  • Click Mounted EFI and navigate EFI>CLOVER .
  • Open CLOVER and you can see /kexts/Other
  • It is good to delete numbered folders 10.6 to 10.13 and keeping only "Other"
  • Other is the one that must have Essential kexts like latest FakeSMC+ Your Ethernet.kext+ Lilu+IntelGraphicsFixup.kext.
  • The last 2 kexts should be installed in System/Library/Extensions ( and possibly /L/E) using Kext wizard or Kext Utility.
  • Then you should open config.plist using CCV .
  • See the CCV window image showing config.plist menu bar in the top half of Left Panel of CCV window from ACPI to System Parameters..
  • The items I had asked you to edit from CBM screen Options are the same things you have to edit and include to avoid having to insert on every reboot.
    • Boot : [√] Verbose(-v) [√]dart=0 [√] disablegfxfirmware
      Graphics card Fake ID is in "Devices " menu
    • Graphics [√]Inject Intel and ig-platform Id fields are in "Graphics" Menu on the Left Panel of CCV
    • SMBIOS > easy to find and toward its Right end up and down arrow heads will click open to reveal iMac18, 3 to choose with all the required fields for your machine
  • "Save" edited C.plist is through the arrow at th bottom of CCV tool bar
  • If you need help there with images I can do but will take time to create.
 
Last edited:
Joined
Jul 25, 2012
Messages
6,711
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
I can't seem to mount it to my desktop. It appears in my finder, but not on my desktop. Did you just drag and drop it?
See the next post about Finder Preferences Setup
 

Attachments

  • Finder Preferences.png
    Finder Preferences.png
    51.7 KB · Views: 114
Joined
Jan 9, 2018
Messages
8
Motherboard
ASUS Rog Strix Z370-G
CPU
i7- 8700K Coffee Lake
Graphics
IGPU
Mac
  1. iMac
  2. MacBook
Got to the point to download and install lilu + IntelGraphicsFixup.kext (my Wifi worked from the beginning) to sys/lib/ext.
I can't see the config.plist in the CCV though. There's a field "create config" in the lower half.
 
Joined
Jan 9, 2018
Messages
8
Motherboard
ASUS Rog Strix Z370-G
CPU
i7- 8700K Coffee Lake
Graphics
IGPU
Mac
  1. iMac
  2. MacBook
Ah Sorry, everything in the upper half IS the config... My Brain starts running low on Sugar.
 
Joined
Jul 25, 2012
Messages
6,711
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Got to the point to download and install lilu + IntelGraphicsFixup.kext (my Wifi worked from the beginning) to sys/lib/ext.
I can't see the config.plist in the CCV though. There's a field "create config" in the lower half.
Path to config.plist:
  • /EFI/EFI/CLOVER>config.plist
  • Right click config.plist from within CLOVER folder you had already opened to see /kexts/Other
  • Right-click context menu should locate installed Clover Configurator Vibrant or CCV for short
  • Open config.plist with CCV and check its Left panel top for menus .
  • You have to edit Boot|Devices|Graphics|SMBIOS as shown in edited images
 

Attachments

  • 1.CLOVER:kexts:Other.png
    1.CLOVER:kexts:Other.png
    24.1 KB · Views: 186
  • 2.Configplist_CCV_Boot.png
    2.Configplist_CCV_Boot.png
    146.5 KB · Views: 206
  • 3.config.plist_CCV_Devices.png
    3.config.plist_CCV_Devices.png
    126.5 KB · Views: 226
  • 4.config.plist_CCV_Graphics.png
    4.config.plist_CCV_Graphics.png
    119.6 KB · Views: 231
  • 5.configplist_CCV_SMBIOS.png
    5.configplist_CCV_SMBIOS.png
    159.1 KB · Views: 191
Status
Not open for further replies.
Top