<< Solved >> System a bit sluggish and showing wrong CPU clock [Opencore; Big Sur]

Not open for further replies.
Jan 22, 2020
Intel Core i5 4670
Intel HD 4600
Mobile Phone
  1. Android
Hi there! I finally managed to transition from Clover to Opencore, and besides hardware DRM is broken due to the fact that I'm using the iGPU as the display output (since I have no dGPU), everything seems to work pretty well so far (Including iMessages, FaceTime, shutdown, restart, sleep and wake)...

The only issue is that it appears to be a bit slower than I think it should be... Lightweight apps like iMessages bounces from 7 to 10 times on the dock before loading... I have an SSD, and with Clover it used to be fast, but now it looks like I only have a fast HD (even booting takes longer than with Clover)... Also: "About this Mac" shows a 1,4ghz core i5, and it looks like something is actually limiting the actual cpu clock to 1,4ghz... I followed up Dortania's guide so I have no idea of what could be wrong...

My system: MSI H81-I; Core i5 4670; 1 x 8GB /1600Mhz Kingston HyperX Fury; Intel HD4600

Can someone please help me? I'm attaching my EFI folder, and I can also make a video of it booting and opening Apps (I'll be also running Geekbench)...

(Also: what are these strange .txt files on my EFI partition?; Also2: did I miss any kext or efi driver?; Also3: do I need all these kexts and efi drivers that I have? Also4: I'm suspecting that it could be that I may also need specific drivers for the SATA controller or something related to data reading/writing, since Logic easily says "System Overload or disk too slow", and I used to work on heavier projects with my mid 2013 MacBook Air, which has a much slower 4250U Core i5 CPU)

EDIT: Also noticed that everytime I turn my pc on, I have to set the DPI of my mouse, and manually select "Internal Speakers" as the sound output on the menubar, since it isn't saving these things... (Didn't tried resetting NVRAM from the OpenCore menu, and I'm not going to do it either, since it CORRUPTED my motherboard firmware once...)

EDIT 2: Geekbench 5 CPU test results: 367 for Single Core / 1299 for Multi Core... It's clear that OpenCore is actually limiting my CPU clock or something (as it is an i5 4670, it should be something around 887 for Single Core / 2799 for Multi Core)... My test results:

EDIT 3: Partially Solved the problems by myself... Now the CPU is reaching from 3.4 to 3.8ghz as it should be...

Thank you very much!


    2.1 MB · Views: 83
Last edited:
Hey Hi i have the exact and same problem as yours , I feel lag on system though m.2 ssd , how did you solve it ,please let me know
Not open for further replies.