Contribute
Register

Surface Book 2 15" Mojave on external HDD Guide

Status
Not open for further replies.
Joined
Oct 9, 2018
Messages
6
Motherboard
Microsoft SurfaceBook 2 15 - Clover UEFI
CPU
i7-8650U
Graphics
UHD 620, GTX 1060, 3240 x 2160
Mobile Phone
  1. iOS
This is what I did to get my SurfaceBook 2 15" running Mojave on a USB external hard drive.
So far, keyboard, trackpad, and display works.
No audio, wifi, GTX 1060 attempted.​

Steps here are the parts that I used from this main laptop guide
Installing clover to USB
- Format USB stick using Option 1: MBR with FAT32
- Install RehabMan's Clover installer package to “CLOVER EFI” partition for clover UEFI
- Make sure to click the "Customize" button on the installer.
This allows for installing proper drivers64UEFI.​
- Copy HFSPlus.efi to drivers64UEFI
- NOT IN LAPTOP GUIDE: copy apfs.efi from macOS installer package to drivers64UEFI
without this clover will not detect the ext drive and cannot boot into macOS
found here: https://www.tonymacx86.com/threads/...8rPleicQUguHNYy2WDtYQedFDuSPliG8#post-1706261
In short you need to:
  1. Find the High Sierra Installer
  2. Show its Package Contents
  3. Navigate to Contents > SharedSupport
  4. Mount BaseSystem.dmg
  5. In the mounted DMG, Navigate to usr > standalone > i386
  6. Copy the file apfs.efi to your desktop
  7. Install Clover again
  8. After the install is successful, find the mounted EFI partition
  9. Copy the apfs.efi to BOTH /EFI/CLOVER/drivers64UEFI AND /EFI/CLOVER/drivers64 (Copy that file to BOTH directories or Clover wont see an APFS formatted drive!)
Preparing essential kext
- Copied kext files to kext/Other from links provided in guide:
FakeSMC
VoodooPS2Controller
USBInjectAll
Lilu
WhateverGreen
SATA-unsupported​
Choosing a config.plist
- Go to github link from guide and chose "config_HD615_620_630_640_650.plist" for UHD620
- Edit the config.plist to change the ig-platform-ids to 0x12345678 and delete the # in front of "ig-platform-ids"​
DVMT-prealloc on Broadwell/Skylake/Kaby Lake
Did not touch these settings since from my understanding of the guide, it is enabled by default?​
Note regarding CPU power management and SSDTs
Did not touch​
Building the OS X installer
Used 'createinstallmedia' method​
BIOS settings: unavailable items were not found in BIOS menu of the SurfaceBook 2
VT-d unavailable
DEP unavailable

Secure boot: disabled
Legacy boot unavailable
CSM unavailable
fast boot unavailable

Boot from USB: enabled
SATA mode unavailable
TPM: disabled
Using the OS X Installer
- check injectEDID from options menu
- highlight "install_osx" and pressed space bar
- check Set Nvidia to VESA
- check verbose if you want to see errors​
- select "Boot macOS with selected options"
- MacOS installer will start
- partition your drive to have a MacOS Extended Journaled parition of a size you want your mac to have in DiskUtility if you havent.
- I named my partition on my ext HDD as "Hackintosh"
- start macOS installer and install to the partition, "Hackintosh" for me​
- macOS installer will go to 2 min then appear to crash/reboot. if it reboots to windows, reboot back into macOS partition with USB stick and ext HDD plugged in.
- from here macOS should initialize from the hackintosh partition and show desktop.​
Install clover to mac partition
- Go back and open the clover package but this time choose install location to the hackintosh partition.
- install the same exact things to the clover folders you did in the beginning of this guide.
- boot from ext USB hackintosh partition​
POST IINSTALL
Need to figure out how to scale down resolution. everything is too small on this 3240x2160 screen.​


Problems I had that I solved to get to this point, the solutions have been incorporated into this guide
Problem: macOS installer didnt load after selecting the option from Clover.
Solution: make sure to follow this guide and the main laptop guide on the config.plist part. it tells you to delete the # in front of "ig-platform-ids" and change the value to 0x12345678 using the plist editor, I used Xcode.​
Problem: Clover does not detect USB external HDD. When I try to boot from USB with only the ext drive connected it just boots to my internal drive with windows (maybe macOS fails to load?). In the Clover menu I only see boot windows from internal drive or boot installer from my usb stick where clover is installed on.
Solution: copy the apfs.efi from mojave installer package.​
 

Attachments

  • DB5F285B-E156-49EC-B765-A097D038D6C1.jpeg
    DB5F285B-E156-49EC-B765-A097D038D6C1.jpeg
    600.4 KB · Views: 2,005
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,445
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Problem: MacOS Mojave Installer crashes on verbose screen before Apple logo shows.

I have attached the following:
photo of screen where verbose stopped
EFI/CLOVER ZIP file without themes directory​

Please let me know of anything I can do to help you understand/fix this issue I am having.

Full overview of steps I have taken so far:
Followed guide https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
Installing clover to USB
Option 1: MBR with FAT32
Installed clover installer package to “CLOVER EFI” partition for clover UEFI
Did not forget HFSPlus.efi
Not installing to SSD on my SurfaceBook. Will be installing to USB ext HDD​
Preparing essential kext
Copied kext files to kext/Other from links provided in guide:
FakeSMC
VoodooPS2Controller
USBInjectAll
Lilu
WhateverGreen​
4K settings: SurfaceBook 2 15" is not quite 4K but also I am not absolutely sure what the guide means by “It is enabled with kernel flag -cdfon. The -cdfon kernel flag is default in all guide plists.” Does that mean this CoreDisplayFixup is enabled by default?
Copied SATA-unsupported kext as well.​
Choosing a config.plis
Went to github link from guide and chose "config_HD615_620_630_640_650.plist" for my UHD620 as I read that it works at this link: https://www.tonymacx86.com/threads/intel-uhd620-and-i7-8550u.253584/
DVMT-prealloc on Broadwell/Skylake/Kaby Lake
Did not touch these settings since from my understanding of the guide, it is enabled by default?​
Note regarding CPU power management and SSDTs
Did not touch​
Building the OS X installer
Used 'createinstallmedia' method​
BIOS settings: italicized items were not found in BIOS menu of the SurfaceBook 2
VT-d
DEP

Secure boot: disabled
Legacy boot
CSM
fast boot

Boot from USB: enabled
SATA mode
TPM: disabled
Using the OS X Installer
Successfully loaded clover
Selected "install_osx" and pressed space bar
Ran installer with verbose enabled​
ISSUE: the installer starts showing what I think is the verbose. The first screen of text goes the about a third of the screen and completes then the second screen fills the whole screen then it boots back to windows. Attached is a shot of the last bit before booting to windows. What does all that mean?​

No misc/preboot.log. You forgot to press F2.
Please read FAQ, "Problem Reporting" carefully.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
Oct 9, 2018
Messages
6
Motherboard
Microsoft SurfaceBook 2 15 - Clover UEFI
CPU
i7-8650U
Graphics
UHD 620, GTX 1060, 3240 x 2160
Mobile Phone
  1. iOS

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,445
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Problem: MacOS Mojave Installer crashes on verbose screen before Apple logo shows.

I have attached the following:
photo of screen where verbose stopped
EFI/CLOVER ZIP file without themes directory​

Please let me know of anything I can do to help you understand/fix this issue I am having.

Full overview of steps I have taken so far:
Followed guide https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
Installing clover to USB
Option 1: MBR with FAT32
Installed clover installer package to “CLOVER EFI” partition for clover UEFI
Did not forget HFSPlus.efi
Not installing to SSD on my SurfaceBook. Will be installing to USB ext HDD​
Preparing essential kext
Copied kext files to kext/Other from links provided in guide:
FakeSMC
VoodooPS2Controller
USBInjectAll
Lilu
WhateverGreen​
4K settings: SurfaceBook 2 15" is not quite 4K but also I am not absolutely sure what the guide means by “It is enabled with kernel flag -cdfon. The -cdfon kernel flag is default in all guide plists.” Does that mean this CoreDisplayFixup is enabled by default?
Copied SATA-unsupported kext as well.​
Choosing a config.plis
Went to github link from guide and chose "config_HD615_620_630_640_650.plist" for my UHD620 as I read that it works at this link: https://www.tonymacx86.com/threads/intel-uhd620-and-i7-8550u.253584/
DVMT-prealloc on Broadwell/Skylake/Kaby Lake
Did not touch these settings since from my understanding of the guide, it is enabled by default?​
Note regarding CPU power management and SSDTs
Did not touch​
Building the OS X installer
Used 'createinstallmedia' method​
BIOS settings: italicized items were not found in BIOS menu of the SurfaceBook 2
VT-d
DEP

Secure boot: disabled
Legacy boot
CSM
fast boot

Boot from USB: enabled
SATA mode
TPM: disabled
Using the OS X Installer
Successfully loaded clover
Selected "install_osx" and pressed space bar
Ran installer with verbose enabled​
ISSUE: the installer starts showing what I think is the verbose. The first screen of text goes the about a third of the screen and completes then the second screen fills the whole screen then it boots back to windows. Attached is a shot of the last bit before booting to windows. What does all that mean?​

Your drivers64UEFI is wrong.
Refer to the guide:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

"fast boot" should be disabled (as mentioned in the guide)
 
Joined
Oct 9, 2018
Messages
6
Motherboard
Microsoft SurfaceBook 2 15 - Clover UEFI
CPU
i7-8650U
Graphics
UHD 620, GTX 1060, 3240 x 2160
Mobile Phone
  1. iOS
Your drivers64UEFI is wrong.
Refer to the guide:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

"fast boot" should be disabled (as mentioned in the guide)

My mistake.
I started all over. Here are the things I did differently.
Installed your personal Clover.
Followed the directions that I missed last time for the Customize settings for Clover UEFI.
Edited the config.plist for Hd620 to change the ig-platform-ids to 0x12345678 and delete the # in front of ig-platform-ids.

Booted to macOS installer with injectEDID, Set Nvidia to VESA, verbose. And selected boot macOS with selected options.
Installer started.
I plugged my usb ext HDD and the installer recognized my mac extended journaled partition and installed macOS to that partition.
At 2 minutes left, Showed verbose and shut off and started windows. When I went back to boot from usb using SurfaceBook method (hold down volume -, press power for a second, release volume - when windows screen shows) then it booted into the macOS start up screen where it shows 30 min. Looked like the extHDD was setting up for the first time. This went to full completion without crashing or rebooting.

I read that this 2 minute crash is actually not a crash here https://www.tonymacx86.com/threads/high-sierra-installer-crashes-on-asus-z170.249748/page-2

This shut off then went back to windows. When I booted from usb again it showed clover and with extHDD plugged in, it shows “boot macOS from install_osx”
Selected same options and booted back into installer and made me go through the Mojave installer again. Same exact thing where it stops at 2 minutes but now when I boot back into usb it doesn’t load my extHDD. If I try to boot from my extHDD it just restarts and boots to the internal hd with windows.
Even in clover I don’t see an option to boot from the partition on the extHDD where I installed macOS I called “Hackintosh”

Any idea what steps to take?

Attached is the loading screen and completion screen when I think the pc started up from the extHDD for the first boot of Mojave and initializing. The verbose is the shot when the Mojave installer shut off at 2 min.
 

Attachments

  • A054F04B-BABB-41A4-84B3-9A69958C9FBA.jpeg
    A054F04B-BABB-41A4-84B3-9A69958C9FBA.jpeg
    1.3 MB · Views: 426
  • D9CF3923-F998-4920-9B0C-F65B1E0ED8DF.jpeg
    D9CF3923-F998-4920-9B0C-F65B1E0ED8DF.jpeg
    418.8 KB · Views: 426
  • 373FA2B9-91B2-4EDC-A7BE-E6F08652A98B.png
    373FA2B9-91B2-4EDC-A7BE-E6F08652A98B.png
    8.1 MB · Views: 355
  • 1DAE4053-4DE8-4103-822D-4FC6B06504BF.png
    1DAE4053-4DE8-4103-822D-4FC6B06504BF.png
    8.9 MB · Views: 367
  • CLOVER.zip
    1.8 MB · Views: 348

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,445
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
My mistake.
I started all over. Here are the things I did differently.
Installed your personal Clover.
Followed the directions that I missed last time for the Customize settings for Clover UEFI.
Edited the config.plist for Hd620 to change the ig-platform-ids to 0x12345678 and delete the # in front of ig-platform-ids.

Booted to macOS installer with injectEDID, Set Nvidia to VESA, verbose. And selected boot macOS with selected options.
Installer started.
I plugged my usb ext HDD and the installer recognized my mac extended journaled partition and installed macOS to that partition.
At 2 minutes left, Showed verbose and shut off and started windows. When I went back to boot from usb using SurfaceBook method (hold down volume -, press power for a second, release volume - when windows screen shows) then it booted into the macOS start up screen where it shows 30 min. Looked like the extHDD was setting up for the first time. This went to full completion without crashing or rebooting.

I read that this 2 minute crash is actually not a crash here https://www.tonymacx86.com/threads/high-sierra-installer-crashes-on-asus-z170.249748/page-2

This shut off then went back to windows. When I booted from usb again it showed clover and with extHDD plugged in, it shows “boot macOS from install_osx”
Selected same options and booted back into installer and made me go through the Mojave installer again. Same exact thing where it stops at 2 minutes but now when I boot back into usb it doesn’t load my extHDD. If I try to boot from my extHDD it just restarts and boots to the internal hd with windows.
Even in clover I don’t see an option to boot from the partition on the extHDD where I installed macOS I called “Hackintosh”

Any idea what steps to take?

Attached is the loading screen and completion screen when I think the pc started up from the extHDD for the first boot of Mojave and initializing. The verbose is the shot when the Mojave installer shut off at 2 min.

Sounds like Clover is not able to scan your external USB where you installed.
Perhaps you should install to the main drive.
 
Joined
Oct 9, 2018
Messages
6
Motherboard
Microsoft SurfaceBook 2 15 - Clover UEFI
CPU
i7-8650U
Graphics
UHD 620, GTX 1060, 3240 x 2160
Mobile Phone
  1. iOS
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,445
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Solved! I had to copy apfs.efi from Mojave installer package and paste into drivers64UEFI. I found this here.
https://www.tonymacx86.com/threads/...8rPleicQUguHNYy2WDtYQedFDuSPliG8#post-1706261

was able to boot into macOS desktop.keyboard and trackpad works. display looks great.

I changed the entire 1st post into a SurfaceBook 2 ext HDD guide.

ApfsDriverLoader-64.efi + ApfsImageLoader-64.efi is supposed to replace apfs.efi.
No idea why it wasn't working on your system.
 
Joined
Oct 9, 2018
Messages
6
Motherboard
Microsoft SurfaceBook 2 15 - Clover UEFI
CPU
i7-8650U
Graphics
UHD 620, GTX 1060, 3240 x 2160
Mobile Phone
  1. iOS

Attachments

  • Screen Shot 2018-10-27 at 10.34.29 AM.png
    Screen Shot 2018-10-27 at 10.34.29 AM.png
    42 KB · Views: 371
  • Screen Shot 2018-10-27 at 10.34.55 AM.png
    Screen Shot 2018-10-27 at 10.34.55 AM.png
    47.5 KB · Views: 320
  • Screen Shot 2018-10-27 at 10.35.41 AM.png
    Screen Shot 2018-10-27 at 10.35.41 AM.png
    106.3 KB · Views: 389
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,445
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Status
Not open for further replies.
Top