Contribute
Register

Successfully migrated from HDD to SSD

Joined
Sep 11, 2016
Messages
8
Motherboard
GIGABYTE Z97X-UD5H F9F
CPU
i5-4690K
Graphics
EVGA GeForce GT 740
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
I have been on Yosemite (with clover) for the last two years. The machine was very stable. I have two monitors connected to NVidia graphics card. Integrated graphics is not being used and is disabled in BIOS. Decided to migrate to 500 GB SSD from 1TB SSD. Bought Samsung 850 EVO 500GB 2.5-Inch SATA III drive.

Originally planned to do a fresh install, however before doing that thought why not try a bare metal restore from the time machine backup. I tried a full TM backup restore on my MacBook Pro a month ago and was very impressed with the result.

Here are the steps to restore a full time machine backup on the SSD drive.

1) Formatted SSD drive using disk utility.
2) Boot machine using Yosemite USB installer (I saved the USB from original instal). I used "-v" and had to boot in safe mode as other wise the machine would not boot.
3) After the welcome message, opened terminal and issued following command to run Time Machine:
# /System/Installation/CDIS/Time\ Machine\ System/Restore.app/Contents/MacOS/Time\ Machine\ System\ Restore
4) Chose latest backup
5) Specified SSD as destination and started restore. It took little over 4 hours for complete restore (200 GB over network).
6) After the restore was done, tried to install clover on SSD. But it would not install.
7) Boot machine using HDD (it was already connected).
8) Installed clover on SSD (this was little tricky as Time Machine set the same disk lable on SSD as it was on HDD. Later renamed lable on SSD using finder).
9) Copied config.plist from HDD EFI/Clover/config.plist to SSD EFI/Clover/config.plist
10) Copied all kexts from EFI/kexts/10.10 to SSD EFI/kexts/10.10
11) Tried booting from SSD and the machine booted fine. The trick was to install clover on new disk and copy config.plist and all kexts.
12) Enabled trimforce
# sudo trimforce enable
 
Joined
Aug 23, 2015
Messages
6
Motherboard
HP Elitebook 840 G3-N75-Clover
CPU
i5-6300U
Graphics
HD520, 1920×1080
Mobile Phone
iOS
Hi,

I managed to install hackintosh on my gf's HP Probook 650 G1 (specs at the end) but bought SSD after I set whole machine up (System preferences, downloaded apps, entered all licences, synced all iCloud stuff). I didn't want to do that all over again so I decided to Restore from Time Machine Backup. The machine is working fine but I am not sure if I need to do some extra work?

I checked the SSD in System profile and it says TRIM support: No. I am not sure if I should enable TRIM or does it mean I cannot be enabled at all?

Also, I check partitions on the drive and it has 5.6 GB VM partition. Inside (mounted to /var/vm) there is a folder named sleepimage (as suggested in guide) and swapfile0 which is 1 GB. On my main hackintosh (which was installed directly on SSD), this partition is only 20.5 kB and there is no swapfileX. Should I disable swap?

Thank you

Specs of my gf's laptop:

BIOS: L77 (ver. 01.46)
CPU: Intel Core i5 4200M @ 2.5 GHz (Haswell, 2 core, 4 HT)
Chipset: Intel 8 Series
GPU: integrated Intel HD Graphics 4600
Display: 1920x1080
Ethernet: Intel I217V
Wifi + BT: BCM94352HMB/AW-CE123H (Mini PCI-E, supports WiFi/ac and BT4LE)


P.S:
Decided to migrate to 500 GB SSD from 1TB SSD.
I assume you migrated from 1TB *HDD* not SSD. ;)
 
Top