Contribute
Register

Successfully install Catalina 10.15.1 on GA Z370P D3 + i9 9900KF + Vega 64

Joined
Jul 16, 2011
Messages
19
Motherboard
Gigabyte X299 Aorus Gaming 3
CPU
i9-7980XE
Graphics
Vega 64
Mac
iMac, MacBook Pro
Classic Mac
Workgroup Server
Mobile Phone
iOS
I just successfully install Catalina 10.15.1 to GA Z370P D3 + i9 9900KF + Vega 64. It was not too dificult as I ecspect. If somebody need help, contact me.
 
Joined
Jul 16, 2011
Messages
19
Motherboard
Gigabyte X299 Aorus Gaming 3
CPU
i9-7980XE
Graphics
Vega 64
Mac
iMac, MacBook Pro
Classic Mac
Workgroup Server
Mobile Phone
iOS
1. I used unibeast for creating usb with 10.15.0.
2. Than, I replace clover, which is created by unibeast, with "Clover_v2.4k_r4961-UEFI-EmuNVR".
3. In clover config.plist , the most important thing for me was:
ACPI Patch (find) A00A9353 54415301 (with) A00A910A FF0BFFFF
4. SMBIOS iMac 19,1
5. kexts: WhatEverGreen 1.3.4 and Lily 1.3.9
 
Joined
Jan 10, 2019
Messages
20
Motherboard
Gigabyte Z390 Aorus Pro WiFi
CPU
i7-8700
Graphics
RX 570
Mac
iMac, MacBook Pro
Mobile Phone
iOS
I appreciate your time. I have a similar setup.
Clover 5098 not working. Unibeast only goes to Mojave.

I will try it with this clover version and see.

Thank you again.
 
Joined
Jul 16, 2011
Messages
19
Motherboard
Gigabyte X299 Aorus Gaming 3
CPU
i9-7980XE
Graphics
Vega 64
Mac
iMac, MacBook Pro
Classic Mac
Workgroup Server
Mobile Phone
iOS
I solved this with ACPI patch. Try with my efi.
 

Attachments

Joined
Jan 18, 2020
Messages
3
Motherboard
ASRock Z390 Pro4
CPU
Inter Core i9-9900KF @ 3.60GHz, 3601 Mhz, 8 Core
Graphics
XFX Radeon RX 570 RS XXX Edition 8GB GDDR5
I've been a browser of these forums for a while now, and finally created an account just to say thank you @sashamed for sharing your EFI here. I was struggling to successfully install Catalina on a new build (specs below), and I decided to replace my EFI with yours in a last ditch effort. It worked!

My Hackintosh build specs:

CPU: Inter Core i9-9900KF @ 3.60GHz, 3601 Mhz, 8 Core
BIOS: American Megatrends Inc. P4.20, 5/3/2019
Motherboard: ASRock Z390 Pro4
RAM: XPG 32GB DIMM 3200MHz (2 x 16GB)
GPU: XFX Radeon RX 570 RS XXX Edition 8GB GDDR5
SSD: 1TB - Dual booting Windows (NTFS 478GB) & Hackintosh (FAT32 478GB)

EDIT - Had to create MacOS partition as FAT32 in Windows, then reformat to Mac Extended Journal in Disk Utility during install. Didn't have to make any changes whatsoever to the provided EFI File.
 
Last edited:
Joined
May 26, 2017
Messages
50
Motherboard
GIGABYTE GA-Z170-HD3P
CPU
i5-6500
Graphics
HD 530
Mac
iMac, MacBook, MacBook Pro, Mac mini, Mac Pro
Mobile Phone
Android
I've been a browser of these forums for a while not, but finally created an account just to say thank you @sashamed for sharing your EFI here. I was struggling to successfully install Catalina on a new build (specs below), and I decided to replace my EFI with yours in a last ditch effort. It worked!

My Hackintosh build specs:

CPU: Inter Core i9-9900KF @ 3.60GHz, 3601 Mhz, 8 Core
BIOS: American Megatrends Inc. P4.20, 5/3/2019
Motherboard: ASRock Z390 Pro4
RAM: XPG 32GB DIMM 3200MHz (2 x 16GB)
GPU: XFX Radeon RX 570 RS XXX Edition 8GB GDDR5
SSD: 1TB - Dual booting Windows (NTFS 478GB) & Hackintosh (FAT32 478GB)

Quick question.... Can you confirm that you have the KF version of the i9-9900 and not the K version? I have been having issues with getting the i9-9900KF hack running with the configuration I had, I ordered the same mobo as you and the same vga card is coming thursday. Can you also confirm that you have his EFI running wtihout modification or did you have to modify it?
 
Joined
Jul 13, 2016
Messages
1,909
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
Vega 64
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
Hackintosh (FAT32 478GB)
This can not be not on Catalina if you check your drive was changed to APFS during the install of Catalina.
 
Joined
Jul 13, 2016
Messages
1,909
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
Vega 64
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
Quick question.... Can you confirm that you have the KF version of the i9-9900 and not the K version? I have been having issues with getting the i9-9900KF hack running with the configuration I had, I ordered the same mobo as you and the same vga card is coming thursday. Can you also confirm that you have his EFI running wtihout modification or did you have to modify it?
Any version of 8th gen/9th gen cpu should work with K without K or the F versions.
 
Top