Contribute
Register

SUCCESSFUL Yosemite Install with ASUS GTX 750 Ti - but with HDMI not working on NVIDIA Web Drivers 3

Status
Not open for further replies.
Joined
Oct 8, 2015
Messages
2
Mac
Classic Mac
Mobile Phone
hey buddy, this is not windows. So one can not find cmd.exe then where to write this and what the warranty violation of the card by going through your method
 
Joined
Apr 11, 2014
Messages
1
Mac
Classic Mac
Mobile Phone
Hello

I own this card https://www.asus.com/Graphics_Cards/GTX750TIPH2GD5/specifications/
And as described I was unable to boot using dvi or hdmi monitors. Only VGA. And without webdrivers.

The only way to make that card work is to flash another firmware

View attachment 139718

I used this one (attached) from this card http://www.asus.com/it/Graphics_Cards/STRIXGTX750TIOC2GD5/specifications/

I guess the Palit one could work as well

Loading the same VBIOS through Chameleon does not work


This is the only solution for this peculiar card (GTX750TI-PH-2GD5).


Instruction:
1) Download nvflash version 5.206.0.1 for Windows (google it)
2) unzip and open "cmd" then change directory to the unzipped dir
3) execute "nvflash --protectoff"
4) save your current bios (to be sure) "nvflash --save original.rom"
5) if you use only one card execute "nvflash -6 GM107.rom" <<-- this is the file I attached here, unrar it first (otherwise add the option --index=NUM where NUM is the number of your card, use --list to know the number of your card)

The software will beep as soon as it finishes and it will ask some confirmation prompts

MAKE THIS FLASH AT YOUR OWN RISK!!!

I took the risk and I succeeded.

Can anyone tell me if this process (flashing the rom) compromise the full use of this card in other operating systems namely Windows?

Regards
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,275
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Can anyone tell me if this process (flashing the rom) compromise the full use of this card in other operating systems namely Windows?

Regards

It shouldn't.
 
Joined
Oct 19, 2015
Messages
1
Motherboard
asus strix
CPU
i7 10700
Graphics
rx580
Mac
  1. iMac
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
I confirm that My asus gtx750 oc (not the Ti edition ) has now the hdmi port working in el capitan after the palit firmware flash founded At www.techpowerup.com (palit gtx750 )
 
Joined
Sep 30, 2015
Messages
43
Motherboard
Asus P8H61-I r2.0
CPU
i7-3770K
Graphics
R9 290X
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
it is Asus GTX 750 Ti 2GB OC, ironically.
seriously? I got the same card. I tried it so many times work on it over night at couldnt make it possible works. I went through all sorts of forums and still couldnt make it work. I'll try to flash my card next week when im not busy at school and work. BUT if still persist not to work. Im just gonna stick to Intel Graphics HD 4000
 
Joined
Jul 6, 2015
Messages
3
Motherboard
Gigabyte GA-H97N-WiFi
CPU
i5-4460
Graphics
HD 4600
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I confirm that My asus gtx750 oc (not the Ti edition ) has now the hdmi port working in el capitan after the palit firmware flash founded At www.techpowerup.com (palit gtx750 )


Yes!
Work! No problem, no lag!
OS X El Capitan
10.11.1 (Build 15B42) & MS Windows 10 Home x64 HDMI port


Before: http://www.techpowerup.com/vgabios/161156/asus-gtx750-2048-140402.html

my_Nvidia geforce gtx 750.jpgmy_Nvidia geforce gtx 750_sensors.jpg

After: http://www.techpowerup.com/vgabios/154549/palit-gtx750-1024-140103.html

LATER-my_Nvidia geforce gtx 750.jpgLATER-my_Nvidia geforce gtx 750_sensors.jpg

Thanks everybody!
 
Joined
Sep 21, 2013
Messages
12
Motherboard
Gigabyte Z68X-UD3H
CPU
i5-3340
Graphics
GTX 750 Ti
Classic Mac
  1. Classic
  2. iMac
  3. LC
  4. Performa
  5. Plus
  6. Power Mac
Mobile Phone
  1. Android
Hi :)

I did the bios flash as described above. Now my DVI output works well, but Yosemite doesn't see my second screen connected to VGA. I don't know why.
 
Joined
Mar 21, 2014
Messages
35
Motherboard
HP 6300
CPU
3770
Graphics
HD4000
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
My card is the ASUS GTX 750 TI OC 2GB.

Didn't work for me. Using 10.11.2 and latest NVIDIA drivers that goes with 10.11.2, a single DVI port works. Must boot with nvda_drv=1. Other ports don't work. If I connect other DVI port the behavior is that the BIOS screen shows on the first DVI and after getting into OS X the other DVI port is switched to. Never can get multi monitor to work.

Tried flashing Palit and STRIX flashes. With STRIX system gets into my desktop and after 10 seconds screen goes white. With Palit the system reboots just before getting to desktop.

I give up. Anyone know how to solve this?

mine.jpg
 
Joined
Mar 21, 2014
Messages
35
Motherboard
HP 6300
CPU
3770
Graphics
HD4000
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
Update:

Tested the HDMI and have multi-monitor with HDMI and a DVI port.
So 2 out of 3 work. I'll take it. No BIOS change required.
 
Joined
Mar 14, 2013
Messages
1
Motherboard
OSX
CPU
Intel
Graphics
Nvidia
Mac
Classic Mac
Mobile Phone
Hello,

i would really appreciate it if someone could help me out. it's a confusion to get the asus gtx 750 ti oc 2gb work with yosemite 10.10.5 (14F1509). The machine runs with clover. I've already installed the newest nvidia web driver. nvda_drv=1 bootflag is already in the config.plist. I always get a black screen.

The only port that works at the moment is vga. But need the dvi port for my display.

I've already change the vbios with palit rom. the good thing is, that the dvi works suddenly on yosemite. but only for a few seconds. the screen turns grey and the systems freez.

I can boot into yosemite with nv_disable=1. But it only laggy and slow.

this is my GPU: Asus Homepage
MOBO: Gigabyte Z97x-UD5H-BK
CPU: i7 4790k

Hope someone can give me the solution.
 
Status
Not open for further replies.
Top