Contribute
Register

Successful Installation of PB 6 - USB working.

LSP

Joined
Feb 11, 2011
Messages
97
Motherboard
Gigabyte Z170X-UD5 th
CPU
i7 6700K
Graphics
RX580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Upgraded to Mojave Public Beta 6 with no issues. everything works. One issue but resolved. Im running a custom SSDT for usb natively with the port limit patch as I have more than 15 ports. lost some of the ports upon first boot. Had to add USBinjectall.kext to Clover /kexts/other and reboot to activate the ports. Then removed USBInjectall and rebooted to all ports working.
 

Attachments

  • Screen Shot 2018-08-13 at 9.26.08 PM.png
    Screen Shot 2018-08-13 at 9.26.08 PM.png
    85 KB · Views: 100
Joined
Dec 26, 2015
Messages
38
Motherboard
MSI H310M Pro - VH
CPU
i3 8100
Graphics
UHD 630 / GT 610
Mac
  1. iMac
Mobile Phone
  1. iOS
Upgraded to Mojave Public Beta 6 with no issues. everything works. One issue but resolved. Im running a custom SSDT for usb natively with the port limit patch as I have more than 15 ports. lost some of the ports upon first boot. Had to add USBinjectall.kext to Clover /kexts/other and reboot to activate the ports. Then removed USBInjectall and rebooted to all ports working.


I think its 'beta 7' but still no acceleration on UHD 630 i3 8100 on MSI H310M Pro VH. Ive tried 'ig-platform-id 59120000 + intelgfx 5916/28086' which gives me a blank screen on HDMI which is where Im guessing it works but need to do some port remapping. Would love some port remapping suggestions. I am new to this so easy instructions are welcome. Btw tried the Framebuffer injections on 10.13 and they give me the same blank screen.

My only issue would be to solve the blank screen right now. Sleep/Wake and audio and things will be left for later!
 

Attachments

  • Screenshot 2018-08-14 at 12.10.34 AM.png
    Screenshot 2018-08-14 at 12.10.34 AM.png
    3.5 MB · Views: 69
  • EFI.zip
    21.6 MB · Views: 46
Joined
Sep 11, 2012
Messages
31
Motherboard
Gigabyte GA-Z170X-UD5 TH
CPU
i7-6700K
Graphics
GTX 670, GTX 1080
Mac
  1. MacBook Air
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. iOS
For me I get the Web drivers (387.10.10.10.40.105) to recognise my Nvidia GTX 1080 by editing the required OS in the Info.plist (see code)

But there does not seem to be accelerated graphics, does anyone have an idea how we could modify the drivers to work on Mojave?

Bash:
sudo /usr/libexec/PlistBuddy -c "Set :IOKitPersonalities:NVDAStartup:NVDARequiredOS "$(sw_vers -buildVersion) /Library/Extensions/NVDAStartupWeb.kext/Contents/Info.plist
sudo touch /Library/Extensions/
 

Attachments

  • Screenshot 2018-08-14 at 16.12.17.png
    Screenshot 2018-08-14 at 16.12.17.png
    203 KB · Views: 64
  • Screenshot 2018-08-14 at 16.13.43.png
    Screenshot 2018-08-14 at 16.13.43.png
    82.6 KB · Views: 56
  • Screenshot 2018-08-14 at 16.36.12.png
    Screenshot 2018-08-14 at 16.36.12.png
    127.1 KB · Views: 44
Last edited:
Joined
Nov 5, 2010
Messages
476
Motherboard
MSI TRX40 Creator
CPU
AMD Threadripper 3970X
Graphics
Radeon VII / RX 6800 XT
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
I think its 'beta 7' but still no acceleration on UHD 630 i3 8100 on MSI H310M Pro VH. Ive tried 'ig-platform-id 59120000 + intelgfx 5916/28086' which gives me a blank screen on HDMI which is where Im guessing it works but need to do some port remapping. Would love some port remapping suggestions. I am new to this so easy instructions are welcome. Btw tried the Framebuffer injections on 10.13 and they give me the same blank screen.

My only issue would be to solve the blank screen right now. Sleep/Wake and audio and things will be left for later!
Have you tried using the latest Lilu+WhateverGreen?
 
Joined
Dec 26, 2015
Messages
38
Motherboard
MSI H310M Pro - VH
CPU
i3 8100
Graphics
UHD 630 / GT 610
Mac
  1. iMac
Mobile Phone
  1. iOS
Have you tried using the latest Lilu+WhateverGreen?

Yes I did ... I am looking to get a new motherboard, which kinda seems difficult at the moment for cheap but that would most likely solve the issue. I think if anyone is specifically going to build a hackintosh the best way to do so is get a good quality and widely supported motherboard. I have had no trouble in the past when I used a mid range motherboard but the current H310 boards are really garbage. MSI boards also have a DVMT issue which should be solved in Whatevergreen. I would suggest to buy a supported ASUS/GIGABYTE B360 atleast for anyone going coffee lake but to be honest a cheap Z370 should basically be something people should look out for. I've never had motherboards bother me because I've always used Intel boards till 3rd gen which were great (not specifically for hackintosh but in general for linux and stuff) and then used MBP. After going back to a desktop and trying a hackintosh I think a well supported and good quality board will very much lessen the pain especially in coffee lake where the Z370s vs lower end boards are a little different and you lose out a lot on the really low end boards like full PCIe M.2 slots. Please skip the H310 boards really. These things really are cheap, the USB ports on mine also have trouble sometimes which could be a BIOS issue. Overall definitely skip H310. I paid almost 90$ for this 50$ garbage board in my country.

On the hackintosh note someone has a successful build with H310 Pro VDH which is very similar to mine except the DVI port which the person has remapped successfully to get full acceleration. That EFI/config or any re mappings dont work on my board because of the missing DVI (which is really HDMI). I also have a GT 610 which is also having an issue where its just crashing and also dont see a mouse cursor. Most likely due to no acceleration. I think I will try 10.13.6 again next week and see if the GT610 works. But I think my best bet is a Z370 which should also give me a decent upgrade path.
 
Joined
Jul 13, 2016
Messages
2,753
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
Vega 64
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
But I think my best bet is a Z370 which should also give me a decent upgrade path.

Get a z370 Gigabyte or Asus board, lots of people here running either of those I believe the Asus has a DVI port on it. However it might be easier for you to just pick up a RX 560 - 580 just stay away from XFX in my experiences.
 
Top