Contribute
Register

Success: Z97 Sabretooth Mark 2, I7-4790K, Asus Radeon RX 560

Status
Not open for further replies.
Joined
Apr 17, 2018
Messages
1
Motherboard
Sabretooth Z97
CPU
I5
Graphics
Radeon 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. SE
Mobile Phone
  1. iOS
Just wanted to report that this built went smoothly without additional tinkering/drivers. Key was to get the BIOS settings right.

Works like a charm with three monitors.

FB

Untitled.png
 
Last edited:
Joined
Dec 23, 2017
Messages
60
Motherboard
Asus Sabertooth Z97 Mark II
CPU
i7-4790K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
Just wanted to report that this built went smoothly without additional tinkering/drivers. Key was to get the BIOS settings right.

Works like a charm with three monitors.

FB

View attachment 329069
could you please share your bios settings ? I'm waiting on sabertooth to get here to replaces my blown up maximus hero VII and id appreciate it if you could share your bios settings that worked for you.
thanks
 
Joined
Feb 19, 2016
Messages
212
Motherboard
ASUS ZenBook UX430UA-DH74
CPU
i7-8550U
Graphics
Intel 620 1920x1080
could you please share your bios settings ? I'm waiting on sabertooth to get here to replaces my blown up maximus hero VII and id appreciate it if you could share your bios settings that worked for you.
thanks

I have the similar Z97 motherboard and I just did high sierra install this weekend. BIOS settings should be:

Load Optimized Defaults
Peripherals>xHCI Mode>Auto
Peripherals>xHCI Hand-off>ENABLED
Peripherals>EHCI Hand-off>ENABLED
BIOS Features>VT-d>DISABLED
BIOS Features>Boot Mode Selection>UEFI (if you made UEFI bootable USB, otherwise chose Legacy)
Save and Exit


 
Joined
Dec 23, 2017
Messages
60
Motherboard
Asus Sabertooth Z97 Mark II
CPU
i7-4790K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
starcentral - THANK YOU SOOOO MUCH
I bought a z97m2 board from someone and it got here yesterday. open the box and 4 bent pins. major bummer.
guy says send it back and i'll bend them back and send it back to you. LMFAO..NOT
ordered an ASUS refurb z97m2 yesterday. should be here in the next 3 days.
can't wait to get my hackintosh back up and running..
 
Joined
Dec 23, 2017
Messages
60
Motherboard
Asus Sabertooth Z97 Mark II
CPU
i7-4790K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
starcentral - everything went smoothly other than a dead bios battery that I didn't think to check until I had everything put back together and set up and was wondering why my bios setting kept changing. I resolved that issue. I also don't get any video from the RX580 unless bios is set to auto for the GPU. It don't like me setting bios to PCI only for the GPU. Here is the last problem that I'm not sure how to attack. When I shut down, it does not shut down, its goes right to a reboot and starts back up. I have to turn the power supply switch to off to keep it shut down. Is the correct resolution to go into clover DSDT and tick the fix shutdown box ? I don't want to do the wrong thing and wind up in a non bootable condition.
Thanks

Sorry I should have also told you im running Mojave 10.14.2 . I did not reinstall anything.
I changed the MObo and to my astonishment, it popped up and loaded Mojave and ran just fine.
I was running Mojave 10.14.2 when the Hero VII board died.
I would have never dreamed that would have happened with such a major change as a motherboard.
I guess the Maximus hero VII and the sabertooth z97 are VERY close to the same as far as the hardware configuration is concerned. I can do a fresh install if need be but don't want to go through it if I don't have to.
 
Last edited:
Joined
Dec 23, 2017
Messages
60
Motherboard
Asus Sabertooth Z97 Mark II
CPU
i7-4790K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
Ok, I mounted my EFI partition and opened the config.plist file and ticked fixshutdown. this did not fix the problem.
it still goes into reboot and won't shut down.
Any help is appreciated.
Please bear in mind that I'm still a NEWB so im no wizard with Hackintosh .
 
Joined
Dec 23, 2017
Messages
60
Motherboard
Asus Sabertooth Z97 Mark II
CPU
i7-4790K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
OK, I followed the instructions to the letter in this thread - https://www.tonymacx86.com/threads/restarts-after-shutdown-security-update-question.270864/


[SOLVED]
1. enabling slide=0 field (boot) in Clover Configurator
2. removing AptioMemoryFix-64.efi from /EFI/CLOVER/drivers64UEFI folder
3. adding EmuVariableUefi-64.efi and OsxAptioFix2Drv-free2000.efi into /EFI/CLOVER/drivers64UEFI folder
4. restart system


and that has not worked either.
is it because I'm using older hardware and Osx ?
Mojave 10.14.2
Mac Pro (mid 2012 ) - Is this an issue ? - this was the only way I could get preview to work
Z97 MARK II Asus board
I7 4790K
RX 580 GPU
 
Last edited:
Status
Not open for further replies.
Top