Contribute
Register

[SUCCESS] Yosemite to Sierra - Asus Sabertooth X79

Joined
Dec 27, 2012
Messages
12
Motherboard
Asus Sabertooth X79
CPU
i7-3820
Graphics
GTX 980 Ti
Mobile Phone
iOS
I just wanted to say a big thank you dnovosad!

I've been using my Yosemite Hackintosh happily for the last 3 years, and didn't want to upgrade unless it was absolutely necessary!

Well I bought an Acer XR382CQK monitor and noticed that my GTX 780ti just wasn't cutting it anymore. So I upgraded to a GTX 1070, (stupidly) without checking if it was compatible on Yosemite, and of course I found out that it wasn't. I'd already upgraded to Sierra on my 2012 MacBook Pro, so it was probably about time that I did the same with the Hackintosh, as a lot of software is dropping Yosemite support anyway.

When I came across your guide for the same motherboard as mine (Sabertooth X79), I was so happy!
Following the guide was easy, and migrating from Chimera to Clover was actually a lot easier than expected!

A few things I wanted to add to your guide:

USB 3.0 support: I noticed right after the sierra install, before installing any Multibeast drivers, that the USB3.0 worked already, without doing anything, and that it was only after installing the 3rd Party USB 3.0 GenericUSBXHCI.kext that the USB3.0 stopped working. So it might be worth checking if you have that installed and then remove it.
I'm running 10.12.6, and Unibeast 7.1.1 so I don't know if there was a change in there that fixed the USB3.0 support, but it worked for me right out of the box.

Audio support: This one was really annoying to get working, but I got there in the end.
First, start out with a fresh AppleHDA.kext, and don't install anything with Multibeast, remove anything if you already have installed drivers. then you need to download SSDT-HDEF+-1.aml from here

Then you need to follow the AppleHDA Realtek Audio Methods - Required: a. native AppleHDA.kext, b. EFI mounted

1. cloverALC (c. SIP disabled, d. Clover and e. network required)
Download/View Raw: audio_cloverALC.command.zip

Options I chose in the CloverALC:

Confirm Realtek ALC892: Y
Clover Audio ID Injection: Y
Use Audio ID: 1: Y (because the motherboard has 6 audio ports)
Motherboard (300/200/X299/X99/Other = n) : N (because it is X79)

I then restarted and it all worked fine!

Also, if you have a GTX 1070, or any 1000 series for that matter, when installing FakeSMC, make sure you delete the file FakeSMC_GPUSensors.kext from the system/library/extensions, otherwise you will get a Kernal Panic, because Pascal GPUs aren't supported.

Only other problems I had was having to convert my Windows 10 partition from MBR to GPT, which I used WinPE and MBR2GPT to convert it, as I was using Legacy before so it was compatible with Chimera Bootloader. And now it's showing 4 different windows partitions in the Clover Boot menu, and I haven't figured out how to remove them yet! EDIT: deselected Legacy from the GUI settings in Clover Configurator and it worked.

I'm also trying to change the Clover boot menu resolution, as it's all stretched on my Ultrawide monitor, but this isn't a biggie!
Oh my God! I'm almost crying!!!
Now I've got sound thanks to you! :clap::headbang:
I've been almost a year muted and now I'm listening!

Thanks!

This forum rocks!
 
Joined
Dec 27, 2012
Messages
12
Motherboard
Asus Sabertooth X79
CPU
i7-3820
Graphics
GTX 980 Ti
Mobile Phone
iOS
GOOD NEWS.

Usb Fix.

Use Multibeast 9.2.1 -> 3rd party USB 3.0 + 7/8/9 Series USB Support

In boot options using Clover Configurator add -gux_defer_usb2 -gux_no_idle

Also, my ethernet stopped working so I also installed Drivers -> Network -> AppleIntelE1000e v3.3.3
Gonna give it a try soon...
Thanks!
 
Joined
Dec 27, 2012
Messages
12
Motherboard
Asus Sabertooth X79
CPU
i7-3820
Graphics
GTX 980 Ti
Mobile Phone
iOS
Ok...Now I have a problem that maybe is related to the last changes.
Two of my disk drives are missing. They're not launching anymore. They even appear in the BIOS.
Is there any chance that making those tweaks to enable audio could have disable something related to the Marvell PCIe 9128 controller?
Could be this the reason to the dissapearing of my disks?
What do you think?
Any help would be deeply appreciated.
 
Joined
Nov 22, 2011
Messages
3
Motherboard
Asus X79 Sabertooth
CPU
i7-3930K
Graphics
GT 640
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Hey guys,

great to hear that Sierra is working on an X79 Sabertooth. So I won't give up on my X79 Sabertooth / i7-3930 / GT640 ProTools Rig. At the moment I would be happy to get even Yosemite working. With Unibeast 5.2 I always get stuck in the middle (s.Att. if interested). Unibeast 6.2 won't even load the bootloader. Any hint where to find a good guide for a setup like this?
Thanks in advance!

et71
 

Attachments

Joined
Jan 6, 2015
Messages
6
Motherboard
ASUS Sabertooth X79
CPU
I7-4930K
Graphics
GTX 980
Hey dnovosad, thank you for this amazing post for Asus X79 users !

It is now necessary for me to upgrade from Yosemite, do your guide work also for High Sierra ?
To those that are running High Sierra, did you follow this guide to succeed installing ? With the same DSDT file ?
dnovosad, did you finally upgrade ? If yes how did you do it ? thanks for your answers guys !
 
Joined
Nov 22, 2011
Messages
3
Motherboard
Asus X79 Sabertooth
CPU
i7-3930K
Graphics
GT 640
Mac
iMac, MacBook Pro
Mobile Phone
iOS
After digging a little deeper I found the solution for my installation issue in this amazing forum. Thank you all so much for your time and effort!
Everything seems to be working but I don't have USB 3.0. My setup is pretty much the same as dnovosad's (difference: GT640 graphics), so maybe you can tell me if you solved it and how...
Thanks in advance,

et71
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,347
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 970
@rajas, please add details of your Motherboard to your profile (personal details).
Your motherboard is not yosemite.

@et71, please update your profile (personal details) with your Motherboard, CPU and iGPU or Graphics Card(s).
If you have a prebuilt computer enter make and model instead of motherboard.
The Rules said:
Profiles are mandatory so that others can assist you.
 
Joined
Jan 6, 2015
Messages
6
Motherboard
ASUS Sabertooth X79
CPU
I7-4930K
Graphics
GTX 980
profile updated. I will try to install High Sierra following this guide on another HDD...
 
Joined
Jan 6, 2015
Messages
6
Motherboard
ASUS Sabertooth X79
CPU
I7-4930K
Graphics
GTX 980
UPGRADE SUCCESSFULL !!! Running High Sierra without bugs :clap::clap::clap:
Big Thanks to dnovosad !!!
 
Joined
Dec 28, 2018
Messages
1
Motherboard
Asus Sabertooth X79
CPU
4930K
Graphics
GTX 960
UPGRADE SUCCESSFULL !!! Running High Sierra without bugs :clap::clap::clap:
Big Thanks to dnovosad !!!
Hello @rajas

I was successfully able to update to Sierra using @dnovosad 's guide but I am experiencing problems updating to high Sierra 10.13.6.

I am able to get to the High Sierra installer via clover but at the 2 minutes mark the installer crashes and displays the attached error.


Did you update to 10.13.6 or 10.13.3?
Did you have to modfiiy your SMBIOS settings mine are set to the mac 14.2 template?
What flags did you have set?

Appreciate your thoughts.

Kind Regards,

Daniel
 

Attachments

Top