Contribute
Register

[SUCCESS] Yosemite to Sierra - Asus Sabertooth X79 (10.13.6)

Joined
Sep 4, 2013
Messages
36
Motherboard
ASUS Sabertooth x79
CPU
i7-3930K
Graphics
GTX 980ti
Mac
Mac Pro
Hi guys, I've just updated my system to 10.13.6 High Sierra and everything works great!!

Screen Shot 2019-11-29 at 9.05.44 PM.png


Running latest native NVIDIA drivers.

Screen Shot 2019-11-29 at 9.06.01 PM.png


Fully updated to the latest patch 10.13.6 2019-006.

Links & Notes

Before you begin make sure you have 1) Sierra OS USB and 2) Time Machine backup that's on a separate drive. If you've already created High Sierra OS USB ignore this:
update failed can't boot > format the drive, convert APFS back to HFS+ (Google) you should be doing this in terminal on Sierra OS USB. Do a clean install of Sierra OS, restart > boot from UEFI Sierra OS USB and do Time Machine recovery to get all your stuff back. Try High Sierra Installation again notice what went wrong the first time. I did that after destroying partition trying to update to 10.13.6 caused by a simple nvidia driver panic. :shh:


Update Directly to MacOS High Sierra (official)
Follow steps 1 through 8
Using Clover Configurator mount System Drive EFI and install Lilu and WhateverGreen Kexts under Kext Installer.

• High Sierra is not available on App Store, but I was able to get a copy on Archive.org
Search for: Mac OS X High Sierra 10.13

• If you are getting installer error, to bypass change you time settings to something like 09/21/2017

• Post install > Update Nvidia Drivers (If you are running Nvidia Web Driver it will prompt to update)

• If you are using F8 when booting and seeing lots of boot entries use the below to sort it out:
Remove extra Clover BIOS boot entries

////////////////////////////////////////////////////////////////////////////////////////////////////////
During update let Clover automatically boot into installer/OS even if you had to hard restart!!!
////////////////////////////////////////////////////////////////////////////////////////////////////////


• Run AppStore and update to 10.13.16
10.13.16 installation might hang after DSMOS has arrived. To fix, hard restart and when in clover change boot flag from nvda_drv=1 to nv_disable=1 (I managed to screw this part so bad I had to start from scratch)

• after 10.13.16, update nvidia drivers then check and install the latest patch from AppStore (10.13.6 2019-006)

• Post patch update nvidia drivers one last time.

• update your bootable USB to High Sierra OS. Use UniBeast 8.3.2 - High Sierra.
Make sure Install macOS High Sierra.app is in Applications folder.
If you get an error "Couldn't copy apfs.efi" follow step 19 here.
Use Clover Configurator to Mount EFI and add DSDT from this thread. Use boot flags you had previously on Sierra OS USB and add kext-dev-mode=1 and cpus=1
Test your USB.

Enjoy!! :headbang:
 
Last edited:
Top