Contribute
Register

[Success] WORKING Intel Wifi Drivers for 7265AC on Catalina

Joined
Feb 18, 2018
Messages
790
Motherboard
Gigabyte TRX40 Aorus Xtreme
CPU
Ryzen 3970X
Graphics
RX 6900 XT
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. Xserve
Mobile Phone
  1. iOS
There should be a full guide on this. The first command didn't work for me probably cause I'm doing something wrong LOL. And after reading some posts, it seems like more needs to be done than just type in those commands.

There are 2 different kexts and methods being discussed in this thread so it can get confusing as to which one people are talking about.

It would be better is this could be split into 2 different threads but as of now it isn't.

Which of the 2 kexts are you trying to use?
 
Joined
May 7, 2020
Messages
3
Motherboard
ASUSTek Computer Inc. UX434FL (U3E1)
CPU
Intel Core i7-8565U
Graphics
Nvidia GeForce MX250
There are 2 different kexts and methods being discussed in this thread so it can get confusing as to which one people are talking about.

It would be better is this could be split into 2 different threads but as of now it isn't.

Which of the 2 kexts are you trying to use?
I think I am using the latest one. "AppleIntelWifiV2"
 
Joined
May 7, 2020
Messages
3
Motherboard
ASUSTek Computer Inc. UX434FL (U3E1)
CPU
Intel Core i7-8565U
Graphics
Nvidia GeForce MX250
How are you using that?
I didn't actually mean I'm using it. I just meant that's the one I downloaded, but I can't get it working. First of all, my wifi card is too new I think (Intel Wireless-AC 9560 ), and when I tried the first command it gave me an error.
 
Joined
Feb 18, 2018
Messages
790
Motherboard
Gigabyte TRX40 Aorus Xtreme
CPU
Ryzen 3970X
Graphics
RX 6900 XT
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. Xserve
Mobile Phone
  1. iOS
I didn't actually mean I'm using it. I just meant that's the one I downloaded, but I can't get it working. First of all, my wifi card is too new I think (Intel Wireless-AC 9560 ), and when I tried the first command it gave me an error.

Can you post a screen shot of your command and the error.
 
Joined
May 24, 2017
Messages
146
Motherboard
Intel NUC6I3SYH
CPU
i3-6100U
Graphics
HD 520 (1920 x 1080)
Mobile Phone
  1. iOS
I didn't actually mean I'm using it. I just meant that's the one I downloaded, but I can't get it working. First of all, my wifi card is too new I think (Intel Wireless-AC 9560 ), and when I tried the first command it gave me an error.

I think there are AppleIntelWiFi.kext, AppleIntelWiFiV2.kext & itlwm.kext. So i do not know which is which. However the development looks promising.
 
Joined
Feb 18, 2018
Messages
790
Motherboard
Gigabyte TRX40 Aorus Xtreme
CPU
Ryzen 3970X
Graphics
RX 6900 XT
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. Xserve
Mobile Phone
  1. iOS
I think there are AppleIntelWiFi.kext, AppleIntelWiFiV2.kext & itlwm.kext. So i do not know which is which. However the development looks promising.

The V2 one is actually an older version of the 1st one!

@Zemelware
If you are using one of those 1st 2, have you edited the plist file? It won't work until you do.

Where is the kext saved to (which folder) and what commands are you entering? Please post a screenshot.
 
Last edited:
Joined
May 24, 2017
Messages
146
Motherboard
Intel NUC6I3SYH
CPU
i3-6100U
Graphics
HD 520 (1920 x 1080)
Mobile Phone
  1. iOS
The V2 one is actually an older version of the 1st one!

@Zemelware
If you are using one of those 1st 2, have you edited the plist file? It won't work until you do.

Where is the kext saved to (which folder) and what commands are you entering? Please post a screenshot.

the AppleIntelWiFi.kext has caused KPs.... so thats why i am not using it atm..
 
Joined
May 28, 2018
Messages
48
Motherboard
Intel NUC8i5BEH
CPU
i5-8259U
Graphics
Iris Plus 655
I didn't actually mean I'm using it. I just meant that's the one I downloaded, but I can't get it working. First of all, my wifi card is too new I think (Intel Wireless-AC 9560 ), and when I tried the first command it gave me an error.

I have a 9650 and the version from post 136 worked for me....I did have issues getting the commands to run.
I ended up typing them in rather than cut and pasting.
 
Joined
Aug 17, 2018
Messages
141
Motherboard
Lenovo Legion Y540-15IRH-Clover
CPU
i7-9750H
Graphics
UHD 630, 1920 x 1080
Mac
  1. Mac mini
Mobile Phone
  1. Android
I have a 9650 and the version from post 136 worked for me....I did have issues getting the commands to run.
I ended up typing them in rather than cut and pasting.

I have the same card. When you say it worked, you mean without any issues? (kernel panics etc)
 
Top