Contribute
Register

[Success] WORKING Intel Wifi Drivers for 7265AC on Catalina

Joined
Oct 27, 2012
Messages
141
Motherboard
Lenovo W510 4319RU
CPU
i7
Graphics
FX 880M, 1972X1080
I got it to load one time my new desktop machine. I logged into my WIFI network, browsed the internet and everything seemed fairly stable. After reboot, it will not load. I run the commands in terminal and get an error from the kextload step. It seems now it cannot find all of the needed libraries.
MSI Z270i Gaming Pro Carbon, Core i7, Intel 8265 WIFI.
 
Joined
Feb 19, 2018
Messages
795
Motherboard
Gigabyte TRX40 Aorus Xtreme
CPU
Ryzen 3970X
Graphics
RX 6900 XT
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. Xserve
Mobile Phone
  1. iOS
I got it to load one time my new desktop machine. I logged into my WIFI network, browsed the internet and everything seemed fairly stable. After reboot, it will not load. I run the commands in terminal and get an error from the kextload step. It seems now it cannot find all of the needed libraries.
MSI Z270i Gaming Pro Carbon, Core i7, Intel 8265 WIFI.

The same happened to me. The only way I can get it to load now is to run the kextload command from the same folder that the kext is in. Just having the path to the kext doesn't work.
 
Joined
Jan 2, 2014
Messages
4
Motherboard
Samsung > Need Model # > See Rules!
CPU
i7 > need model # > See Rules!
Graphics
HD 4000
wow, it cool, it will try it for my gigabyte b360n wifi motherboard tonight.
 
Joined
May 9, 2020
Messages
1
Motherboard
Lenovo 04Y1406
CPU
Intel Core i5 3320M
Graphics
Intel HD 4000 (lol)
Is this supposed to work on 6 series cards?
 
Joined
Aug 23, 2016
Messages
12
Motherboard
Lenovo Ideapad 520 15-IKB
CPU
i5-8250U
Graphics
MX150
Mobile Phone
  1. iOS
It works on 8265. 5g is slow, 2g works with hiccups. It’s proof that it can work, but not something I could recommend enough for daily use. Just to mention that I had KP until kext for wn823n was removed. Also, sometimes sound on headphones is weird when kext is loaded. Anyhow great job.
 
Last edited:
Joined
Oct 27, 2012
Messages
141
Motherboard
Lenovo W510 4319RU
CPU
i7
Graphics
FX 880M, 1972X1080
The same happened to me. The only way I can get it to load now is to run the kextload command from the same folder that the kext is in. Just having the path to the kext doesn't work.
So are you saying in terminal you need to CD to the folder where the kext is first then run kextload?

EDIT:
I'm still getting the following error from kextload.
Code:
sneitzel@iMac tmp % sudo kextload *.kext

/private/tmp/AppleIntelWifi.kext failed to load - (libkern/kext) link error; check the system/kernel logs for errors or try kextutil(8).
sneitzel@iMac tmp % sudo kextutil *.kext

Kext with invalid signature (-67030) allowed: <OSKext 0x7fa767c1e7a0 [0x7fff915f68c0]> { URL = "file:///private/tmp/AppleIntelWifi.kext/", ID = "com.zhong.AppleIntelWiFi" }
Code Signing Failure: code signature is invalid
Disabling KextAudit: SIP is off
(kernel) kxld[com.zhong.AppleIntelWiFi]: The super class vtable '__ZTV17IO80211Controller' for vtable '__ZTV14AppleIntelWiFi' is out of date. Make sure your kext has been built against the correct headers.
(kernel) kxld[com.zhong.AppleIntelWiFi]: The super class vtable '__ZTV17IO80211Controller' for vtable '__ZTV14AppleIntelWiFi' is out of date. Make sure your kext has been built against the correct headers.
(kernel) Can't load kext com.zhong.AppleIntelWiFi - link failed.
(kernel) Failed to load executable for kext com.zhong.AppleIntelWiFi.
(kernel) Kext com.zhong.AppleIntelWiFi failed to load (0xdc008016).
(kernel) Failed to load kext com.zhong.AppleIntelWiFi (error 0xdc008016).
Failed to load /private/tmp/AppleIntelWifi.kext - (libkern/kext) link error.
Check library declarations for your kext with kextlibs(8).
sneitzel@iMac tmp % sudo kextlibs *.kext             

For all architectures:
    com.apple.iokit.IO80211Family = 1200.12.2
    com.apple.iokit.IO80211FamilyV2 = 1200.12.2b1
    com.apple.iokit.IONetworkingFamily = 3.4
    com.apple.iokit.IOPCIFamily = 2.9
    com.apple.kpi.bsd = 19.4
    com.apple.kpi.iokit = 19.4
    com.apple.kpi.libkern = 19.4
    com.apple.kpi.mach = 19.4

For x86_64:
    1 symbol not found in any library kext.
    Multiple symbols found among 1 libraries:
    com.apple.iokit.IO80211FamilyV2

sneitzel@iMac tmp %
Should the kext in post 1 be referencing com.apple.iokit.IO80211FamilyV2 ???
Specifically, the V2 part?
I did at one point try to load the V2 version of the kext.
 
Last edited:
Joined
Oct 26, 2013
Messages
1,054
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
Should the kext in post 1 be referencing com.apple.iokit.IO80211FamilyV2 ???

No

Specifically, the V2 part?
I did at one point try to load the V2 version of the kext.

Because your IO80211Family.kext is not for 10.15.x, version 1200.12.2 is bundled with 10.14.x

Restore 10.15.x stock IO80211Family.kext (1200.12.2b1) first.
 

Attachments

  • IO80211Family 10154 stock kext.zip
    6.8 MB · Views: 152
Joined
Feb 19, 2018
Messages
795
Motherboard
Gigabyte TRX40 Aorus Xtreme
CPU
Ryzen 3970X
Graphics
RX 6900 XT
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. Xserve
Mobile Phone
  1. iOS
So are you saying in terminal you need to CD to the folder where the kext is first then run kextload?

EDIT:
I'm still getting the following error from kextload.

Should the kext in post 1 be referencing com.apple.iokit.IO80211FamilyV2 ???
Specifically, the V2 part?
I did at one point try to load the V2 version of the kext.

You are running macOS 10.15 - Catalina? This is only for Catalina, not Mojave or earlier.
 
Joined
Jan 31, 2020
Messages
3
Motherboard
Asus Notebook K501UXM
CPU
i7-6500U
Graphics
GTX 950M
My laptop gets blackout and restarts after installation for a few seconds.
I'm using Asus Notebook K501UXM, GTX 950M, i7-6500U
Send help!
 
Top