Contribute
Register

Success with Gigabyte H370M DS3H +i5-8400 coffee lake

Joined
Aug 11, 2015
Messages
28
Motherboard
Gigabyte H370M-DS3H
CPU
i5-8400
Graphics
UHD 630 + GT 740
Mac
iMac, MacBook, MacBook Pro, Mac mini
Classic Mac
iMac, SE/30
Mobile Phone
iOS
Hi every body, this is my first thread here so if I missed something, just tell me..
I start this thread because I encounter lot of issue to build an hackintosh with the H370M DS3H so it may help someone

The builds :
OS : High Sierra 10.13.5
Case : Powermac G5
MB : Gigabyte H370M DS3H
CPU : Intel Coffee Lake I8400
GPU : EVGA GT 740SC Single Slot + intel UHD 630
Firewire : PCI Express car with 2x1394b + 1x1394a + 1 header :
Wifi : Broadcom BCM943602CS by PCI Express
SSD : Samsung EVO 860
BIOS vs : F2

Working :
USB 2 and 3/3.1
Sleep/wake
Firewire
reboot/shutdown
Audio with VOODOO

Not working :
Wake by USB

Didn't test yet :
iMessage
Display port

  • I had long delay to shutting down with the last version of multibeast, so I used the clover installer and it works fine.
  • For Usb you need to use the USBInjectAll Kext
  • For ethernet, need to keep the intelmausi kext
  • I also use the XHCI-300-series-injector.kext and AHCI-300-Series.kext.
  • For IGPU working accelerated : need IntelGraphicsFixup.kext, 0x59120000 IG-Platform-ID, 0x59128086 IntelGFX FakeID And some patches in config.plist
  • I also add an .aml in ACPI/Patched
I'm not sure if my settings are perfect, but it working pretty well. So again, it can be a good starting point for other.
If you see something seems to be wrong please tell me and I will try.

I add all my Clover File in attachment

Finally, a big THANK YOU to all people in this website (and others), It's the 2nd Hackintosh I made thanks to you, and me and my brother are doing a third one with a nuc in an iMac G4 20 inche..


EDIT : Success With same Mobo/Cpu/iGPU/eGPU on MOJAVE

Hello everybody and first of all, thank's a lot for your support. I'm really glad that this thread can help some of you.

So now here is the second shot for this config with Mojave. And I can tell you, that's rocks!! especially for sleep..

Some point to know :
  • Mojave and 10.13.6 support UHD 630 and coffeeLake really better because of new coffelake Framebuffer
  • For all graphics setting, you just need Whatevergreen.kext and lilu.kext in there last version and maybe some setting in config.plist. No more intelgrapghicsfixup or IntelGFX fake id.
  • There is 3 new IG Plateform for UHD 630 :
    • (0x3E910003 Compute only)
    • (0x3E920003 Compute only)
    • (0x3E9B0007 when screen connected to it) the one I use.
  • You absolutely need to use the latest vs of clover as there there is news from aptiomemoryfix and emuvariable
  • About aptiomemoryfix, this one not work well with sleep on my Mobo, so I'm using the combination of osxaptiofix3drv and emuvariable which is kind of deprecated. but work well for me.

I give you the clover file (v2), it is based on the first one I just made some change :
  • I'm using clover vs 4769
  • In device/property in config.plist to change all port type of the UHD 630
  • In the DSDT patch to make the UHD 630 appear as built in.
  • For sleep working well I use the "sudo pmset -a standby 0" command in terminal and ERP need to be activate in bios.
  • AGDP Patch is mandatory in kernel patch
  • I deleted the serial number in SMBIOS, you need to add one.
All working fine except the audio.. I'm using an USB plug for audio instead so if you have idea or feedback to give me.. I will try.

Have fun guys!!!!!
 

Attachments

Last edited:
Joined
Jan 8, 2013
Messages
4
Motherboard
PC
CPU
i7
Graphics
AMD
Mac
Classic Mac
Mobile Phone
hi backwardmac,

I also try to install a mackintosh an the same mainboard as you, but with another cpu. I use the i7-8700k.
So I tried your Clover settings and try to boot. But it crashes before I can install OSX. I saw too lat that you use not the built in graphics card.

So I tried to do my own setup. With standard created by UniBeast I have no mouse and keyboard at the Screen where I should choose the install language (OSX Setup).

After the injection of two kext files (USBInjectAll.kext and XHCI-300-series-injector.kext) I could start the installation with mouse and keyboard.

But now the system crashes while it will be installed without any message.

Maybe you can tell me what I have to remove from your configuration and activate for the internal graphics card.

Thanks

Sigma99
 
Joined
Aug 11, 2015
Messages
28
Motherboard
Gigabyte H370M-DS3H
CPU
i5-8400
Graphics
UHD 630 + GT 740
Mac
iMac, MacBook, MacBook Pro, Mac mini
Classic Mac
iMac, SE/30
Mobile Phone
iOS
Hi Sigma, I had lot of issue with the igpu.
For now, i suggest you to use the fake intelGFX 12345678 in the config.plist it will not give you the accelerated graphics but you should be able to start.
Don't forget the inject intel too in kernel

For accelerated graphics :
  • you absolutely need the intelgraphicsfixup.kext
  • you can try to use the fake intelgfx 59128086 (if your IGPU is an UHD 630)
  • you should also activate the in "useIntelHDMI" and "HDMIInjection" on your config.plist (if your screen is connected by HDMI)
I give you my new clover file which I use actually. I also give you the profile for the BIOS (f2 version)
  • this new clover file have an ssdt patch for this mother board which can give you the ability to wake up after sleep with usb keyboard
  • it also have a patch to activate only the USB port of this MB.
  • it allow to shutdown the computer without restart loop (ERP enable on bios is mandatory)
Keep me in touch !!
 

Attachments

Joined
Jun 4, 2018
Messages
3
Motherboard
Gigabyte H370M DS3H
CPU
Intel core i5 8400
Graphics
UHD 630
Mac
iMac
Mobile Phone
Android
Hi, Just to add that I have had success with the Gigabyte H370M DS3H board, latest USBInjectAll.kext is a must. I made a fresh install of High Sierra onto a fusion drive (120G SSD & 1TB HDD) - initially it failed with APFS related messages but after following the guide here https://www.tonymacx86.com/threads/guide-avoid-apfs-conversion-on-high-sierra-update-or-fresh-install.232855/ things went well.

Setting up the fusion drive was done from the installation terminal using diskutil and gpt to mimic the setup in my iMac and then creating the core storage volume from the partition slices only (most other information I found used the whole disks).

If anyone's interested or has specific queries I can post more detailed information.

It's been a steep learning curve, but thanks to all who have worked hard to make this possible :)
 
Joined
Aug 11, 2015
Messages
28
Motherboard
Gigabyte H370M-DS3H
CPU
i5-8400
Graphics
UHD 630 + GT 740
Mac
iMac, MacBook, MacBook Pro, Mac mini
Classic Mac
iMac, SE/30
Mobile Phone
iOS
Hi Ximony, thank you for sharing your experience with this board.

I'm interrested to see your clover files, because I was not able to use the UHD 630 for screening with acceleration.
I can use it for airplay monitoring, but actually, my screen are on the EVGA GT 740 graphics card.
I have a black screen on the UHD 630

so maybe your clover file can help me.

Thanks in advance.
 
Joined
Jun 4, 2018
Messages
3
Motherboard
Gigabyte H370M DS3H
CPU
Intel core i5 8400
Graphics
UHD 630
Mac
iMac
Mobile Phone
Android
Hi backwardmac, I have only just installed the OS and don't have a graphics card in my system and have no plans to install one. I used unibeast 8.3.2 to generate the USB installation stick and did not select any graphics options. The only kext i added was the latest USBInjectAll. My graphics needs are quite modest, 1280x1920 on an old LCD monitor, although I do plan on adding a 4K monitor to the displayport connector at some point. I chose this motherboard mostly because of the DisplayPort option and the form factor.

Sorry I can't be of much help.
 
Joined
Jun 25, 2018
Messages
7
Motherboard
Gigabyte H370M DS3H
CPU
Intel I3-8100
Graphics
onboard
Hi all,

Tried installing High Sierra on a new rig with the following:

CPU: Coffee Lake I3-8100
MB: Gigabyte H370M DS3H (updated BIOS to ver. F2)
RAM: 16GB Ballistic Sport LT (8GB x 2)
Graphics & Sound : Onboard Graphics & Sound
SSD: Crucial MX500 M.2 SATA 500GB

After downloading High Sierra from App Store and creating boot USB with the latest Unibeast, the install gets to the point with the screen with 4 options. After formatting the SSD with the Disk Utility, the install OS option shows: "Reinstall Mac OS" instead of "Install Mac OS". When I choose that option a box opens which says "Unable to contact recovery Server"

What have I done wrong? How do I progress the install beyond this point?

Any help will be appreciated since this is my first Hackintosh install and trying to find my way around.

Thanks

Randall
 
Joined
May 22, 2018
Messages
17
Motherboard
Gigabyte H370M D3H
CPU
Intel I5 8400
Graphics
Intel UHD 630
Hi there, sorry to be an absolute pain this is my first Hackintosh build I'm using the H370M D3H motherboard with I5 8400, with no GPU as I intend to use the integrated gpu, however after multi beast install I'm unable to use HDMI on my monitor and can only use VGA & also the ALC892 multibeast setting doesn't work, would appreciate some advice (Apologies I'm a noob with all of this)
 
Joined
Aug 11, 2015
Messages
28
Motherboard
Gigabyte H370M-DS3H
CPU
i5-8400
Graphics
UHD 630 + GT 740
Mac
iMac, MacBook, MacBook Pro, Mac mini
Classic Mac
iMac, SE/30
Mobile Phone
iOS
Hi all,

Tried installing High Sierra on a new rig with the following:

CPU: Coffee Lake I3-8100
MB: Gigabyte H370M DS3H (updated BIOS to ver. F2)
RAM: 16GB Ballistic Sport LT (8GB x 2)
Graphics & Sound : Onboard Graphics & Sound
SSD: Crucial MX500 M.2 SATA 500GB

After downloading High Sierra from App Store and creating boot USB with the latest Unibeast, the install gets to the point with the screen with 4 options. After formatting the SSD with the Disk Utility, the install OS option shows: "Reinstall Mac OS" instead of "Install Mac OS". When I choose that option a box opens which says "Unable to contact recovery Server"

What have I done wrong? How do I progress the install beyond this point?

Any help will be appreciated since this is my first Hackintosh install and trying to find my way around.

Thanks

Randall
Hi rbrooker,

your issue is not really the "reinstall OS X" it's mandatory to have your hackintosh connect to internet. best by ethernet. for that check that intelmausi kext is in your kext file on the USB key. then try again.
 
Joined
Aug 11, 2015
Messages
28
Motherboard
Gigabyte H370M-DS3H
CPU
i5-8400
Graphics
UHD 630 + GT 740
Mac
iMac, MacBook, MacBook Pro, Mac mini
Classic Mac
iMac, SE/30
Mobile Phone
iOS
Hi there, sorry to be an absolute pain this is my first Hackintosh build I'm using the H370M D3H motherboard with I5 8400, with no GPU as I intend to use the integrated gpu, however after multi beast install I'm unable to use HDMI on my monitor and can only use VGA & also the ALC892 multibeast setting doesn't work, would appreciate some advice (Apologies I'm a noob with all of this)
Hi Hussain,

Can you upload your clover file?

for HDMI you can try the HDMIinjection option n your clover file.
but you need to have the correct fake intel gfx ID in your clover file too.
how much graphics memory do you have when connected to VGA?
 
Top