Contribute
Register

[SUCCESS] Suney's Mini Cube ASRock Z370M-ITX/ac - i5-8400 - UHD 630 Graphics - High Sierra

Joined
Mar 12, 2018
Messages
11
Motherboard
Asrock Z370M-itx
CPU
i5 8400
Graphics
UHD630 / RX560
Mac
MacBook Pro
Mobile Phone
Android
Suney's Build: ASRock Z370M-ITX/ac - i5-8400 - UHD 630 Graphics
20180318_115159.jpg
Components

Asrock Z370M-ITX/AC Motherboard with dual HDMI and Display Port 1.2
https://www.amazon.com/dp/B07638L88W/?tag=tonymacx86com-20
https://www.newegg.com/Product/Product.aspx?Item=N82E16813157795

Intel Core i5 8400 Coffee Lake 6-core 2.8 Ghz (4.0 Ghz Turbo)
https://www.amazon.com/dp/B0759FGJ3Q/?tag=tonymacx86com-20
https://www.newegg.com/Product/Product.aspx?Item=N82E16819117824

G.Skil Ripjaws V Series 16GB (2 x 8GB) DDR4 -2400 SDRAM
https://www.amazon.com/dp/B013J7T5K6/?tag=tonymacx86com-20
https://www.newegg.com/Product/Product.aspx?Item=N82E16820231888

Cryorig M9i CPU Cooler
https://www.amazon.com/dp/B0177GTTB0/?tag=tonymacx86com-20
https://www.newegg.com/Product/Product.aspx?Item=9SIA4UF39E2338

Cube 2 Case
https://www.aliexpress.com/item/QUEENWAY-Breeze-Audio-CUBE-2-new-design-Chassis-SFX-power-ITX-air-cooled-computer-Case-improved/32811365353.html

Broadcom BCM94352Z
https://www.ebay.com/itm/Broadcom-BCM94352Z-DW1560-6XRYC-802-11-AC-867-Mbps-Bluetooth-4-0-WIFI-WLAN-Card/263529608472

20180318_115547.jpg

Samsung EVO 860 500GB SSD
https://www.amazon.com/dp/B01M20VBU7/?tag=tonymacx86com-20
https://www.newegg.com/Product/Product.aspx?Item=N82E16820147674

SanDisk SSD Plus 120BG (SDSSDA-120G-G26)
https://www.amazon.com/dp/B01F9G414U/?tag=tonymacx86com-20
https://www.newegg.com/Product/Product.aspx?Item=N82E16820173150



Comments

This is my first Hackintosh build. I also own a MacBook Pro Retina (2012) which mainly sits on my desktop and outputs to my Dell 3415W monitor which seems a bit of a waste. I've decided to donate the MacBook Pro to my wife and have this Hackintosh as my desktop PC. I plan to buy a dedicated GPU in the coming months but haven't decided whether to go for a RX560 or 1050ti. I've got Windows 10 install on the 120gb SanDisk SSD and High Sierra installed on the Samsung EVO. Dual boot works fine with no issues.

Installation

BIOS Settings
  1. OC Tweaker \ DRAM Configuration → Load XMP Setting : XMP 2.0 Profile 1
  2. Advanced \ CPU Configuration → Intel Virtualization Technology : Enabled
  3. Advanced \ Chipset Configuration → Vt-d : Disabled
  4. Advanced \ Chipset Configuration → IOAPIC 24-119 Entries: Enabled
  5. Advanced \ Storage Configuration → Sata Mode Selection: AHCI
  6. Advanced \ Super IO Configuration → Serial Port: Disabled
  7. Advanced \ USB Configuration → Legacy USB Support : Enabled
  8. Advanced \ USB Configuration → PS/2 Simulator : Disabled
  9. Advanced \ USB Configuration → XHCI Hand-off : Enabled
  10. Security \ Secure Boot → Secure Boot: Disabled
  11. Boot → Fast Boot: Disabled
  12. Boot → Boot From Onboard LAN: Disabled
    • Advanced \ Chipset Configuration → Primary Graphics Adapter : Onboard
    • Advanced \ Chipset Configuration → Share Memory : 128MB
    • Advanced \ Chipset Configuration → IGPU Multi-Monitor : Enabled
On my MacBook Pro, I downloaded the latest copy of High Sierra 10.13.3. I used Unibeast to create a USB boot disk.
Installation was very straight forward, it restarted a couple times but after 15minutes or so I had High Sierra loaded
I used Multibeast to install my drivers and SMBIOS iMac18,3 initially but the graphics kept getting jumbled up and there was intermittent freezes. I have gone to iMac14,2 and has been good so far.
Kexts
Rehabman's FakePCIID + FakePCIID_Broadcom_Wifi kexts
RehabMan's Broadcom Kexts (BcrmFirmwareRepo, BcrmPatchRAM2)
RehabMan's FakeSMC kexts 14,2

What Works
Graphics - works
Audio - works
Sleep - works (wakes and sleeps fine, but sometimes after waking, google chrome and spotify seems to crash and requires a restart to get working again, any suggestions??)
Network - ethernet works
WiFI - works
Power/Thermals - idles at 29'C

What Doesn't Work
Bluetooth - it seems to work intermittently. Drivers are installed but I can only pair my Logitech MX Master 2S sometimes so I have gone with the Logitech Unifiying USB device instead.

Performance
Screen Shot 2018-03-18 at 10.15.06 PM.png
 
Last edited:
Joined
Jan 8, 2018
Messages
2
good job! Thanks for your sharing.
Here is what I got for the this issue
Sleep - works (wakes and sleeps fine, but sometimes after waking, google chrome and spotify seems to crash and requires a restart to get working again, any suggestions??)

Add DSDT Patches:

  1. Open config.plist with Clover Configurator
  2. Select Acpi
  3. Verify you have the following under DSDT -> Patches in this exact order.
  4. HECI -> IMEI Patch
    1. Comment: change HECI to IMEI
    2. Find* [Hex]: 48454349
    3. Replace [Hex]: 494d4549
  5. GFX0 -> IGPU Patch
    1. Comment: change GFX0 to IGPU
    2. Find* [Hex]: 47465830
    3. Replace* [Hex] : 49475055
  6. PEGP -> GFX0 Patch
    1. Comment: change PEGP to GFX0
    2. Find* [Hex]: 50454750
    3. Replace [Hex]: 47465830
  7. Save config.plist
I got this method from user 'macbookair' in this Forum , here is the link, I am really appreciated to this guy, thank you again @macbookair

Here is the link to the post

https://www.tonymacx86.com/threads/success-ga-z370n-wifi-i7-8700k-vega-64.242014/page-3

hope this could work for you too.
 
Joined
Jan 17, 2018
Messages
8
Motherboard
Gigabyte Z370N-WiFI
CPU
i5-8400
Graphics
ASUS RX 560 STRIX
Mac
MacBook Pro
Mobile Phone
iOS
Dude, please, help me, I can't get my WiFi and BT work (with the same card as you have). And my CPU cooler is non-stoppable, 100% all the time.
 
Joined
Apr 21, 2018
Messages
35
Motherboard
Gigabyte Z370m-D3H
CPU
I5-8400
Graphics
Galax GeForce GTX 1060 3Gb
Mobile Phone
iOS
Suney's Build: ASRock Z370M-ITX/ac - i5-8400 - UHD 630 Graphics
View attachment 319588
...
Hi, mate! Could i ask... how did you enable dual boot?

I currently have a PC setup running Windows 10 which I intend to use to build a hackintosh. But it would be nice to just get an extra SSD for the hackintosh as opposed to having to wipe my current SSD with Windows and all the rest of the installed software on it. I, too, have an ASROCK motherboard (ASRock B250m-Pro4).

Cheers.
 
Joined
Mar 12, 2018
Messages
11
Motherboard
Asrock Z370M-itx
CPU
i5 8400
Graphics
UHD630 / RX560
Mac
MacBook Pro
Mobile Phone
Android
Hi, mate! Could i ask... how did you enable dual boot?

I currently have a PC setup running Windows 10 which I intend to use to build a hackintosh. But it would be nice to just get an extra SSD for the hackintosh as opposed to having to wipe my current SSD with Windows and all the rest of the installed software on it. I, too, have an ASROCK motherboard (ASRock B250m-Pro4).

Cheers.
It was really easy. You need two seperate SSD one for each OS
I had windows 10 already installed on one SSD, I unplugged that one, then I installed macos onto my second SSD got everything running, then I plugged my windows 10 SSD back, but I made sure the primary boot was from the SSD with mac installed

Let me know if you need any more help!
 
Joined
Mar 12, 2018
Messages
11
Motherboard
Asrock Z370M-itx
CPU
i5 8400
Graphics
UHD630 / RX560
Mac
MacBook Pro
Mobile Phone
Android
Dude, please, help me, I can't get my WiFi and BT work (with the same card as you have). And my CPU cooler is non-stoppable, 100% all the time.
Did you install the rehabman kexts that I listed above?
Thats what I installed to get mine working
Rehabman's FakePCIID + FakePCIID_Broadcom_Wifi kexts
RehabMan's Broadcom Kexts (BcrmFirmwareRepo, BcrmPatchRAM2)


Have a read of this thread, theres other methods of making it work
https://www.tonymacx86.com/threads/broadcom-wifi-bluetooth-guide.242423/
 
Joined
Apr 21, 2018
Messages
35
Motherboard
Gigabyte Z370m-D3H
CPU
I5-8400
Graphics
Galax GeForce GTX 1060 3Gb
Mobile Phone
iOS
It was really easy. You need two seperate SSD one for each OS
I had windows 10 already installed on one SSD, I unplugged that one, then I installed macos onto my second SSD got everything running, then I plugged my windows 10 SSD back, but I made sure the primary boot was from the SSD with mac installed

Let me know if you need any more help!
holy heck, you just saved me quite a bit of dosh mate! i was about to splash out on a whole new separate setup but this will do! that means i will just have to get myself another SSD and i should be all set to embark on my first Hackintosh venture.

but lemme get this right though... every time i boot the hackintosh, i’ll have to change the settings in the bios then is that right? and when booting into windows gotta change the BIOS settings again each and every time?
 
Joined
Mar 16, 2017
Messages
2
Nice build! And I wonder that have you solved the Bluetooth problem? I have the same problem.
 
Joined
May 9, 2018
Messages
37
Motherboard
ASRock Z370M-ITX/ac
CPU
i5
Dear Suney,

Can you upload your EFI folder?
I bought the same PC. :)
 
Joined
Sep 24, 2011
Messages
19
CPU
i5 8400
Graphics
UHD 630
Mac
MacBook Pro
Mobile Phone
iOS
no patch to make HD630 working? I does lots like using fake id 0x3E92, modify AppleIntelKBLGraphics.kext and AppleIntelKBLGraphicsFramebuffer.kext.....
 
Top