Contribute
Register

[SUCCESS] Skylake, MSI Z170-A PRO, Intel i5 6600k, MSI GTX 970

Joined
Dec 10, 2012
Messages
3
Motherboard
MSI Z170-A PRO
CPU
i5 6600k
Graphics
MSI GTX 970
Mac
Classic Mac
Mobile Phone
Components:

Intel Boxed Core I5-6600K 3.50 GHz Processor
http://www.amazon.com/Intel-Boxed-I5-6600K-Processor-BX80662I56600K/dp/B012M8M7TY/

MSI Z170-A PRO
http://www.amazon.com/MSI-Computer-Motherboard-Z170--PRO/dp/B016I0X13I/

MSI GTX 970 Overclocked 4GB GDDR5
http://www.amazon.com/MSI-GAMING-GTX-970-4G/dp/B00NN0GEXQ/

Corsair Vengeance LPX 16GB DDR$ 2133MHz
http://www.amazon.com/Corsair-Vengeance-2133MHz-PC4-17000-Memory/dp/B0123ZCD36/

Samsung SSD 850 EVO


The Following Guide is ONLY FOR THIS HARDWARE combo, but might work for other builds. Attached file includes all files needed for successful install.


Comments


First of all BIG THANX to RehabMan, Pike R Alpha, and Tonymac. And to ammulder for his guide here and pbryanw for his guide here.

I will not go too deep indo describing the installation process, as it should be known by now.
Very important! Get the latest Clover version for a smooth boot. I am using Clover 3389. Get It.

Install works as regular iMac 14.2 up to iMac 17.1. Tried both, but use the 14.2 definition.

What Works

  • SATA and m.2 SATA and m.2 PCIe x4 system drives
  • Audio (HDMI audio working as well on an Nvidia card)(Realtek ALC 892; ID=2)
  • USB, including USB3 speed
  • Wireless networking via the Broadcom BCM4360
  • Onboard Ethernet (Realtek RLT8111H)
  • iMessage, Facetime, iCloud, etc.
  • All high-resolution modes when using a 4K monitor (I guess, can't test, but MSI GTX 970 shows up as PCI divice in system info)

What still isn't reeeally working

  • speed stepping for Skylake still not 100% correct for 110 Intel chip set.
  • Needs some more tweaking with SSDT and DSDT


Set Up


INSTALL USB:
- Create Install USB including latest Clover 3389 and install OSX 10.11.4. Use latest FakeSMC (included in my zip)

- Copy all the included SSDT files for working speedstep, audio, USB and HDMI audio to EFI/CLOVER/ACPI/patched/

- Copy all included kexts to EFI/CLOVER/kexts/10.11/

- IMPORTANT: OsxAptioFixDrv-64.efi & HFSPlus.efi must be installed in Clover drivers.

- Use bootflag nv_disable=1 during install.



POST INSTALL:


- Install Clover on system drive and copy the same files as mentioned above to the EFI folders on your System Drive

- Install the NVIDIA Web drivers and set the bootflag to nvda_drv=1 and remove nv_disable=1.

- For Audio: use MultiBeast and install the AudioDrivers for Realtek ALC 892.
(Tried to use toledas patch this time but it just produced errors).

- Use KextBeast to install the included kext files to S/L/E. Fist FakeSMC... just afterwards the SMC Plugins.

- IMPORTANT search for audio-MIDI-setup in Launchpad, and set the Audioformat to 48000,0 Hz for each audio device, otherwise the audio will start to mess up after 30 seconds or so.

- IF YOU ARE USING A SYSTEM DEFINITION OTHER THAN iMac 14.2 Install the pre-patched file AppleGraphicsControl.kext to S/L/E or your NVIDIA Web drivers will not start.

- SEE MY PRE CONFIGURED config.plist and merge with yours.
especially these sections:


<key>Name</key>
<string>DSDT.aml</string>
<key>Patches</key>


<key>Boot</key>
<dict>
<key>Arguments</key>

<key>KextsToPatch</key>


USE YOUR OWN SERIAL NUMBER, MLB AND ROM.

If you need more info, or do not understand the config.plist edits, check the Guides from ammulder here and pbryanw here.


Enjoy Building. It's a smooth running system.
It took me about 3 days to set it up like this.
If something doesn't work as it should, check all steps again, and use Google in case.

 

Attachments

Joined
Jun 16, 2014
Messages
7
Motherboard
MSI H170 Gaming M3
CPU
GTX 970
Mac
Classic Mac
Mobile Phone
Android
hi, can this guide works for me? msi h170 gamimg m3 i5 6600 gtx 970
i tried to follow another guide but i couldn't install kext from multibeats because it gave me an error (i managed to boot only in safe mode, that's why). please text back :)

sorry for my english i'm an italian student:D
 
Joined
Dec 10, 2012
Messages
3
Motherboard
MSI Z170-A PRO
CPU
i5 6600k
Graphics
MSI GTX 970
Mac
Classic Mac
Mobile Phone
Hi!
This guide can work for you. BUT!
You have different hardware, especially Audio (ALC1150) and LAN (Killer E2400LAN)

Attached is a config.plist, you can try to use for booting and modifying yours.

Remove the nv_disable=1 after installing NVIDIA WEB drivers from config.plist.
Do not use the following files from my uploaded Zip file in first post.

SSDT-HDEF-HDAS-2.aml (I dont know your dievice id)
SSDT-HDMI-NVIDIA-PEG0.aml (you have to check with IORegistryExplorer for your definition)
RealtekRTL8111.kext

You Can use AppleGraphicsControl.kext (Depends on your SMBIOS System Definition)

Use all the other files, your system should boot without -v.
Good Luck!



[FONT=Arial, Verdana, Geneva, sans-serif]
[/FONT]
 

Attachments

Joined
May 7, 2016
Messages
1
Motherboard
MSI Z170-A PRO
CPU
Core I5-6600K
Graphics
GeForce 9800 GT
Hi bob3000, I have a very similar desktop:
MSI Z170-A pro, Core I5-6600K, GeForce 9800 GT, 16Gb DDR4 2666MHz Kingston HyperX Savage
I am trying to install OS X El Capitan 10.11.4, usb but for some reason does not start, a black screen. BIOS settings as described here did http://www.tonymacx86.com/threads/msi-9-series-motherboards-os-x-setup-and-configuration.143167/. The only thing what I think is the reason, it does not cut off the embedded video in the BIOS. Please tell me what could be the problem. Thank you.
 
Joined
Mar 17, 2016
Messages
21
Motherboard
MSI Gaming M5
CPU
i5-6600
Graphics
GTX 1050 Ti
Mac
MacBook Air
Classic Mac
iBook, iMac, Xserve
Mobile Phone
Android, iOS,
I'm also having trouble, hope your config works. not using your .aml files though. whould I be?
 
Joined
Jan 16, 2013
Messages
1
Motherboard
HP 4530s
CPU
I3
Graphics
HD3000
Mac
Classic Mac
Mobile Phone
hi, can this guide works for me? msi h170 gamimg m3 i5 6600 gtx 970
i tried to follow another guide but i couldn't install kext from multibeats because it gave me an error (i managed to boot only in safe mode, that's why). please text back :)

sorry for my english i'm an italian student:D
Sorry I have the same main board like you.
I installed successful, but I don't know what kext I should install in MultiBeast. Help me, please
 
Joined
Jul 19, 2014
Messages
2
Mac
Classic Mac
Mobile Phone
Hey i got the same Mainboard and CPU tried to follow your steps but i am Stuck now
Error says: OsxAptioFixDrv: starting overrides for IABootFiles/boot.efi
using reloc block: no, hibernate wake: no
error allocating 0x11626 ... alloc type 2

Please help me
only one i could find with almost same specs who got the machine to work
 
Joined
Aug 8, 2019
Messages
172
Motherboard
MSI Z170-A PRO-U3E1
CPU
i7-6700
Graphics
HD 530
Mac
iMac
Mobile Phone
iOS
Hello @ bob3000,
I would like to know if you could help me set up the MultiBeast 11.3.0 - Mojave ?
Here are the details of the PC:
Processor: Intel Core i7 6700 @ 3.40GHz Skylake Technology 14nm
RAM: 16.0 GB Channel-Double Unknown @ 1066 MHz (15-15-15-35)
Motherboard: MSI Z170-A PRO (MS-7971) (U3E1)
Graphics: Intel HD Graphics 530 (MSI)
Optical Disks: ATAPI iHAS124 F
Audio: Realtek High Definition Audio
Network: REALTEK PCIe GBE Family Contoller

Please thank you in advance.
 
Top