Contribute
Register

[SUCCESS] SKYLAKE El Capitan 10.11.3 ASUS B150M-A 6700K GTX950

Joined
Mar 13, 2015
Messages
1
Motherboard
Asus B150M-A
CPU
skylake i7 6700k
Graphics
evga GTX950 SC+
Mac
  1. Mac mini
Classic Mac
Mobile Phone
ASUS B150M-A was chosen as it has no issues with USB ports. USB port count is 14 (back 1xUSB type c, 2xUSB3.0, 2xUSB2.0, internal USB3.0 connector (2 ports), USB2.0 connector (2ports). installation does not require USBinjectAll.kext.

Acknowledgements to:
ammulder Skylake starter guide:
http://www.tonymacx86.com/el-capitan-desktop-guides/179221-skylake-starter-guide.html

Pike R Alpha: Skylake APIC fix: https://pikeralpha.wordpress.com/2015/11/06/appleapic-kext-binary-patch-for-skylake/

Slim Jim: http://www.tonymacx86.com/graphics/161256-solving-nvidia-driver-install-loading-problems.html

?Devzone/Mieze: New Driver for Realtek RTL8111: http://www.insanelymac.com/forum/topic/287161-new-driver-for-realtek-rtl8111/page-43

Installation:

1. make and alter unibeast drive: IOAPIC in config.plist fix as per Pike R Alpha in the unibeast usb drive EFI partition

2. bios settings as per ammulder skylake starter guide. also disabled parallel port just in case.
initial boot without graphics card (removed from system). Otherwise boot with bootflag: nv_disable=1

3. before booting with unibeast USB unplug all unneccesary cables like extra monitors and LAN cables and USB. A connected LAN cable at initial start up caused kernel panic.

when booted into El Capitan:
1. multibeast
install bootloader, voodoohda 2.8.8 (realtek 887 audio did not work)

2. LAN realtek RTL8111 driver from: http://www.insanelymac.com/forum/topic/287161-new-driver-for-realtek-rtl8111/page-43. multibeast realtek driver does not work. install using kext beast and rebuild cache

3. alter the following in config.plist in EFI partition of installed hard drive (not the USB drive) as per ammulder skylake starter guide:
IOAPIC fix
SMBIOS to iMac 17.1
memory settings
nvidia card fix

4. install nvidia web driver. there are links floating around. I went to nvidia website and the only drivers for el capitan available is found if you search for quadro driver. after install highlight the nvidia driver.

5. shut down computer and install graphics card. reboot

Working:
2x 4K monitors 60Hz via display ports
audio via headphone jack front and back. there is noise with voodoohda, to fix this turn down the input gain in system preferences
audio via hdmi not tested
sleep
LAN
USB 3 and 2. type c not tested.
 
Joined
May 2, 2016
Messages
6
Motherboard
Asus B150M-A
CPU
i5-6400
Graphics
N/A
Hi eddythien:
I followed your instructions and success, except for no sound, any advice?

EDIT: Voodoo works but not the one included Multibeast
 
Last edited:
Joined
Feb 14, 2016
Messages
1
Motherboard
Asus B150M-A
CPU
Intel Core i3 6100
Graphics
GTX 960
Mac
Classic Mac
Mobile Phone
Nice going to try with my B150M-A now that intel graphics 530 is fully supported
 
Joined
Oct 15, 2015
Messages
4
Motherboard
Biostar Z270
CPU
Intel G4560
Graphics
RX570
Mac
  1. MacBook Pro
Classic Mac
  1. Apple
Mobile Phone
  1. Android
  2. iOS
Can u share your config.plist?
 
Joined
May 21, 2016
Messages
4
CPU
intel i5-6400
Graphics
intel hd 530
Hi, I have the same motherboard with audio ALC 887, but my audio device not work with multibeast OS X Captian , please help
 
Joined
May 21, 2016
Messages
4
CPU
intel i5-6400
Graphics
intel hd 530
Joined
May 2, 2016
Messages
6
Motherboard
Asus B150M-A
CPU
i5-6400
Graphics
N/A
Thanks, I've also found this is work perfectly, but give me some noise, I've find out zero the input volume in Sound solve the problem.
But now I have another problem as described here:http://www.tonymacx86.com/threads/apple-icon-and-top-menu-text-blurry.193603/
:(
The noise comes when input gain is enabled while voodoohda setting doesn't work properly, the guide below may helps you:
http://www.tonymacx86.com/threads/voodoohda-system-preferences-not-saved-on-reboot.32909/
 
Top