Contribute
Register

[Success] Skylake Asus Maximus VIII Ranger, i5-6600, GTX 1070 (Clover/High Sierra)

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,492
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
@taku1995, please update your profile (personal details) with your Motherboard, CPU and Graphics Card.
If you have a prebuilt computer enter make and model instead of motherboard (Mobo).
The Rules said:
Profiles need to contain at least your primary system to assist others with helping you.
 
Joined
May 9, 2010
Messages
220
Motherboard
Gigabyte Z390 Aorus Pro WiFi
CPU
Intel i5-9600K
Graphics
MSI RX 5700 XT Gaming X
Mobile Phone
  1. Android
@taku1995 - Apologies for the delay in replying to you. I'm away from home for a week, and home is where my hackintosh is :)

Regarding your Nvidia driver panic - how have you enabled the drivers on your system? Please read this:
https://www.tonymacx86.com/threads/new-method-for-enabling-nvidia-web-drivers-in-clover.202341/

You might also need to have NvidiaGraphicsFixup.kext installed. You can get it from here, then please put in Clover/kexts:
https://github.com/lvs1974/NvidiaGraphicsFixup/releases

How have you installed the Nvidia Graphics Drivers? Make sure you have the latest ones available from here

If you manage to get them working and get lag with your system, uninstall current Nvidia drivers, then use the nVidia-Update script: https://github.com/Benjamin-Dobell/nvidia-update

Would be useful if we knew your exact configuration too - you can add this to your profile, so we can see it beneath your avatar in the forum. Also, SMBIOS info (which Mac you're using) and which version of macOS you have installed, would be useful too. Thanks.
@taku1995, please update your profile (personal details) with your Motherboard, CPU and Graphics Card.
If you have a prebuilt computer enter make and model instead of motherboard (Mobo).
Thanks for adding this @BreBo :thumbup: Didn't see this at first, but thread has just updated for me.
 
Joined
Jun 23, 2016
Messages
5
Motherboard
Asus Maximus VIII Ranger
CPU
i7-6700
Graphics
Nvidia 980Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
@taku1995 - Apologies for the delay in replying to you. I'm away from home for a week, and home is where my hackintosh is :)

Regarding your Nvidia driver panic - how have you enabled the drivers on your system? Please read this:
https://www.tonymacx86.com/threads/new-method-for-enabling-nvidia-web-drivers-in-clover.202341/

You might also need to have NvidiaGraphicsFixup.kext installed. You can get it from here, then please put in Clover/kexts:
https://github.com/lvs1974/NvidiaGraphicsFixup/releases

How have you installed the Nvidia Graphics Drivers? Make sure you have the latest ones available from here

If you manage to get them working and get lag with your system, uninstall current Nvidia drivers, then use the nVidia-Update script: https://github.com/Benjamin-Dobell/nvidia-update

Would be useful if we knew your exact configuration too - you can add this to your profile, so we can see it beneath your avatar in the forum. Also, SMBIOS info (which Mac you're using) and which version of macOS you have installed, would be useful too. Thanks.

Thanks for adding this @BreBo :thumbup: Didn't see this at first, but thread has just updated for me.
ok i'll try, thanks

update:
unfortunately, it doesn't works for me, let say this is not quite the problem I'm facing
I'm rocking mac os 10.11.6 with maximus VIII ranger, using clover r4012. SMBIOS is iMac14,2
My system is up-to-date, as well as nvidia driver.
Everything works fine when clover bootloader was on r4012, but once I update clover(only clover, nothing changed with the system, no update upgrade what so ever), it starts panicking
thank you
2018-03-31 02.04.51.jpg
 
Last edited:
Joined
May 9, 2010
Messages
220
Motherboard
Gigabyte Z390 Aorus Pro WiFi
CPU
Intel i5-9600K
Graphics
MSI RX 5700 XT Gaming X
Mobile Phone
  1. Android
Just a heads-up for owners of the Asus Ranger VIII Ranger Motherboard - BIOS version 3802 was released on the 26th April.

This update's release notes include another "Updated Intel CPU microcode" fix, which I'm guessing is newer code for Spectre mitigations. The previous fix in the BIOS 3703 update, may have caused reboots on some PCs:
https://www.zdnet.com/article/spect...intel-replaces-its-buggy-fix-for-skylake-pcs/
(This is based on some speculation on my part, so may not be entirely correct).

With Clover now enabling native NVRAM with the latest BIOSes on this motherboard - it's probably worth upgrading to this new BIOS. It also comes with "Improved system performance" & "Improved DRAM compatibility" fixes:
https://www.asus.com/uk/Motherboards/MAXIMUS-VIII-RANGER/HelpDesk_BIOS/

It's also good to see ASUS still releasing new BIOSes for this motherboard, some two and a half years after it's release.
 
Joined
Apr 1, 2014
Messages
2
Motherboard
Asus Maximus VIII Ranger Z170
CPU
i7-6700K
Graphics
GTX 970
Hello it seems that my SSDT for proper USB is not working. All my ports function properly but my desktop cannot go into proper sleep with the same settings as you. Would you mind sharing the SSDT please?

Thanks

Edit: My build is an 6700k w/Ranger VIII + GTX 970. I am not using iGPU if it matters.
 
Joined
Jul 15, 2012
Messages
122
Motherboard
ASUS Maximus VIII Ranger
CPU
I7-6700K
Graphics
GTX 960
Mobile Phone
  1. iOS
Just a heads-up for owners of the Asus Ranger VIII Ranger Motherboard - BIOS version 3802 was released on the 26th April.

With Clover now enabling native NVRAM with the latest BIOSes on this motherboard - it's probably worth upgrading to this new BIOS.

Hello pbryanw,

Thanks for this update. Sorry for being a noob, could you please tell me, in a nutshell, the use and advantage of 'Clover enabling NVRAM' ? I am not sure to understand what this implies in the hackintosh context.
Thanks again for your time in sharing information with us !
 
Joined
May 9, 2010
Messages
220
Motherboard
Gigabyte Z390 Aorus Pro WiFi
CPU
Intel i5-9600K
Graphics
MSI RX 5700 XT Gaming X
Mobile Phone
  1. Android
Hello it seems that my SSDT for proper USB is not working. All my ports function properly but my desktop cannot go into proper sleep with the same settings as you. Would you mind sharing the SSDT please?
Edit: My build is an 6700k w/Ranger VIII + GTX 970. I am not using iGPU if it matters.
@thebeestodcurry - (Edited: for not reading your post in full :) )
Hi, that sounds similar to my system, and sleep is definitely working for me under High Sierra. I'm not using a generated SSDT for power management, and am using the USBInjectAll.kext to enable a selection of my USB ports. No DSDT.aml is being used.

These are the kexts in my kexts -> Other folder:
  • AppleALC.kext
  • FakeSMC_ACPISensors.kext
  • FakeSMC_CPUSensors.kext
  • FakeSMC.kext
  • IntelMausiEthernet.kext
  • Lilu.kext
  • NvidiaGraphicsFixup.kext
  • USBInjectAll.kext
And this is what's in my drivers64UEFI folder:
  • ApfsDriverLoader.efi
  • AptioMemoryFix.efi
  • FSInject-64.efi
  • VBoxHfs-64.efi
I'm using Clover 4558. I've attached my SSDT-UIAC.dsl (you will need to edit for your system, then compile as .aml) if this might help you. I've also attached my config.plist (with identifying information removed). Let me know how you get on :thumbup:
 

Attachments

  • SSDT-UIAC.dsl
    5.7 KB · Views: 137
  • config.plist
    3.1 KB · Views: 180
Last edited:
Joined
May 9, 2010
Messages
220
Motherboard
Gigabyte Z390 Aorus Pro WiFi
CPU
Intel i5-9600K
Graphics
MSI RX 5700 XT Gaming X
Mobile Phone
  1. Android
Thanks for this update. Sorry for being a noob, could you please tell me, in a nutshell, the use and advantage of 'Clover enabling NVRAM' ? I am not sure to understand what this implies in the hackintosh context.
Thanks again for your time in sharing information with us !
@HacKDo - Tonymacx86 has a good thread explaining what native NVRAM is - here: Native NVRAM Available?

If native NVRAM is available with your motherboard, macOS can use it to store information like NVIDIA Web Driver variables, and values related to iMessage. Clover can also use it to store values, like what theme to use on boot, and NVRAM Variables (found in Clover's Preference Pane).

Without this ability, this information isn't saved after each reboot and shutdown/startup cycle. In the case of non-native NVRAM, emulated NVRAM can be used instead. This is done by installing the EmuVariableUefi-64.efi driver. But this has drawbacks - when using emulated NVRAM, on startup, my last booted drive wasn't remembered.

With the ASUS VIII Ranger motherboard I'm currently using: when it was first released in 2015, native NVRAM could be enabled by using OsxAptioFix2Drv-64.efi (I think). After a previous BIOS update, this stopped working, and emulated NVRAM had to be used.

Then, just recently - AptioMemoryFix.efi was added to Clover - which enabled native NVRAM on this motherboard again, and continues to work with the latest BIOSes for the VIII Ranger.

(Edited: for clarity & brevity)
 
Last edited:
Joined
Jun 23, 2016
Messages
5
Motherboard
Asus Maximus VIII Ranger
CPU
i7-6700
Graphics
Nvidia 980Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
do usb ports not working on mojave yet?
only internal disk appears, all usb drives not working, can't mount efi on clover configurator either
 
Joined
May 9, 2010
Messages
220
Motherboard
Gigabyte Z390 Aorus Pro WiFi
CPU
Intel i5-9600K
Graphics
MSI RX 5700 XT Gaming X
Mobile Phone
  1. Android
@taku1995 - Hi, sorry for the late reply (I think my first reply was eaten because it included external links).

Have you tried the new Port Limit patch for Mojave:

Comment: USB Port limit patch 10.14 (credits FredWst)
Name: com.apple.driver.usb.AppleUSBXHCI
Find: 83 FB 0F 0F 83 03 05 00 00
Replace: 83 FB 0F 90 90 90 90 90 90

You'll need to use PlistEdit Pro, Xcode or Clover Configurator to make these changes. I'm also not sure if you'll need RehabMan's USBInjectAll.kext in order for this to work.

This thread on Tonymacx86 might be useful too: [README] Common Problems/Changes/Fixes on Mojave
 
Top