Contribute
Register

[SUCCESS] Sapphire NITRO+ RX 5500 XT 8G GDDR6 SE

Joined
Jul 6, 2019
Messages
5
Motherboard
Asus B365M-C/CSM
CPU
i5-8400
Graphics
RX 5500 XT
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. Android
  2. iOS
I have Sapphire RX 5500 XT 8GB card. Right now i'm using Catalina 10.15.6 but one thing i'm facing is lag on mouse. That was not there previously when i use GTX 1050 ti with High Sierra. Can any one tell me what is the problem?

I'm using LG 4k 24 inch Monitor
 
Joined
Mar 16, 2019
Messages
1
Motherboard
Intel desktop dh61ww
CPU
I3-2100
Graphics
amd hd 4000
View attachment 446692

I was stuck on High Sierra with my GTX 1060 and purchased an RX 5500 XT to be able to upgrade.

I first updated directly to Catalina with the 1060 still in.

I then swapped the card, but the system didn't boot anymore.
I restarted with a fresh Clover config and was able to boot with latest FakeSMC, Lilu and WhateverGreen. The only thing needed is the "agdpmod=pikera" boot argument. (My clover config is absolutely empty otherwise!)

I had a lot issues with USB audio (cutting all the time), and the computer not waking up from sleep.
After a lot of trials, disabling Legacy USB Support and the Serial Port in the BIOS solved both issues!

It is now 100% functionnal, sleep working, two monitors ( 1 Displayport + 1 HDMI ) working at the same time.

I also fixed one of the last issue I had - low graphic resolution in Clover - by disabling CSM in the BIOS.



can yougive your efi folder
 
Joined
Dec 25, 2013
Messages
4
Motherboard
ML
CPU
P Dual core
Graphics
GF7300
Mac
Classic Mac
Mobile Phone
View attachment 446692

I was stuck on High Sierra with my GTX 1060 and purchased an RX 5500 XT to be able to upgrade.

I first updated directly to Catalina with the 1060 still in.

I then swapped the card, but the system didn't boot anymore.
I restarted with a fresh Clover config and was able to boot with latest FakeSMC, Lilu and WhateverGreen. The only thing needed is the "agdpmod=pikera" boot argument. (My clover config is absolutely empty otherwise!)

I had a lot issues with USB audio (cutting all the time), and the computer not waking up from sleep.
After a lot of trials, disabling Legacy USB Support and the Serial Port in the BIOS solved both issues!

It is now 100% functionnal, sleep working, two monitors ( 1 Displayport + 1 HDMI ) working at the same time.

I also fixed one of the last issue I had - low graphic resolution in Clover - by disabling CSM in the BIOS.
I have the same graphics. Everythingworks fine. But FCP X quit on start-up with a message contents prographics not found. What can I do.
 
Joined
Nov 18, 2020
Messages
1
Motherboard
Gigabyte Z390 I Aorus Pro WIFI
CPU
Intel i7 9700K
Graphics
AMD Radeon RX5500 XT
I'm about to install Catalina. I also have a Rx 5500 XT / i7 9700K / Z390 I Aorus WIFI Pro / ... and I need help with the Clover Configuration .. Does anyone have anything that I can use with Unibeast? The Config i have used is not working. It stuck at the apple logo..
 
Joined
Nov 25, 2020
Messages
15
Motherboard
Asus Prime B360M-A
CPU
i5 9400F
Graphics
Sapphire RX 5500 XT Nitro+
Hello!
I am about to receive my Sapphire RX 5500 XT Nitro+ and have a similar configuration than you (i5 9400f + Asus B360M-A) and I am preparing by pendrive.

I was under the impression that with the default Clover configuration built with Unibeast it will work but now I am thinking that maybe things need to be tweaked...?

Is there any specific thing to modify in the config.plist prior to install?

  • I was trying to find the system definition mentionned by @spudds96 and @phoenixAL but was unable to find it... only similar thing mentionned in the config.plist is "ProductName" which susprised me as it is by default:

<dict>
<key>ProductName</key>
<string>iMac14,2</string>
<key>Trust</key>
<false/>
</dict>
Should I change that?​


  • Concerning the things mentionned by @jpierlon123 refering to: FakeSMC, Lilu and WhateverGreen, this is not required for a fresh install of Catalina right? I had a look on the /EFI/CLOVER/kexts/Other and they are all there except for FakeSMC ... should I add this one?

  • Last thing mentionned is around "boot arguments", as he also mentionned, mine doesn't have it either...

<key>Boot</key>
<dict>
<key>Arguments</key>
<string>dart=0 nv_disable=1</string>
<key>Debug</key>
<true/>
<key>DefaultVolume</key>
<string>MacHDD</string>
<key>Legacy</key>
<string>PBR</string>
<key>Secure</key>
<false/>
<key>Timeout</key>
<integer>3</integer>
<key>XMPDetection</key>
<string>NO</string>
</dict>
Should I add this... "agdpmod=pikera" ? how would that be? Is it "inside arguments Key"?​
<key>Boot</key>
<dict>
<key>Arguments</key>
<string>dart=0 nv_disable=1 agdpmod=pikera</string>
<key>Debug</key>
<true/>
<key>DefaultVolume</key>
<string>MacHDD</string>
<key>Legacy</key>
<string>PBR</string>
<key>Secure</key>
<false/>
<key>Timeout</key>
<integer>3</integer>
<key>XMPDetection</key>
<string>NO</string>
</dict>


Thank you all in advance for your answers.
 
Last edited:
Top