Contribute
Register

[Success] Radeon RX 6800 XT - Big Sur

Joined
Jun 1, 2013
Messages
240
Motherboard
Gigabyte Z490 Vision D
CPU
I7-10700K
Graphics
5600XT & 6800 XT
Mac
  1. iMac
Mobile Phone
  1. iOS
Have you tried enabling CSM Support in BIOS?
@CaseySJ I did try with CSM enabled but did not make any difference. Same problem. However one thing I tried was to disable the IGPU and connect the 6800 XT to the monitor via DP-DP. The system did not boot at all and kept beeping continuously (according to the meaning of the beeps it seems that it is either a video card error or an AGP error). After investigation I concluded that the system when IGPU is disabled and the 6800XT is connected to the monitor via DP-DP thinks that there is either no video card installed in the system or the system is not connected to any display. But if IGPU is disabled and I connect the 6800 XT to the monitor via HDMI cable, then the system boots fine.I am really starting to think that it is the monitor that is the culprit, at least when using DP to DP cable. The last thing I can try to eliminate any potential issues with the BIOS, the overall system or the 6800 XT is to connect my other more recent monitor if I can get hold of it. If that works then I'll know it is the monitor. If that fails then I don't know what else I can do.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,924
Motherboard
Asus Z690 ProArt Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Now that new public beta is out, we can now talk about it.

What's the word? any new device Ids, for 6700 or 6900?
No support for 6700 XT yet. It is unlikely to be added in 11.5.x. May need to wait for 11.6 or 12.0. Of course, there is no guarantee that Navi 22 and 23 will be supported in macOS even though these device IDs are present in Big Sur.
 
Joined
Jun 15, 2012
Messages
479
Motherboard
Gigabyte Z370 AORUS Gaming 7-F13
CPU
i7-8700K OC @ 5.1Ghz
Graphics
RX 6900 XT
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. Performa
Mobile Phone
  1. iOS
No support for 6700 XT yet. It is unlikely to be added in 11.5.x. May need to wait for 11.6 or 12.0. Of course, there is no guarantee that Navi 22 and 23 will be supported in macOS even though these device IDs are present in Big Sur.
I suppose that means no changes to 6900XT for 73AF support either. :\.
 
Joined
Jul 10, 2019
Messages
18
Motherboard
Gigabyte B550 vision D
CPU
Ryzen 9 5900x
Graphics
RX 6900 XT
Has anyone tested the 11.5.2 beta with 6800/6900 xt ?
The amd driver changed but I'd rather make sure before updating !

Thanks
 
Joined
Oct 24, 2013
Messages
840
Motherboard
Gigabyte Z590 Vision D
CPU
i7-11700K OC @ 5.2GHz
Graphics
RX 6800 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
Has anyone tested the 11.5.2 beta with 6800/6900 xt ?
The amd driver changed but I'd rather make sure before updating !

Thanks
It's working with the stock 6800XT.
 
Joined
Jul 19, 2011
Messages
13
Motherboard
Asus Prime Z490-A
CPU
i7 10700K
Graphics
Asus ROG Strix RX 5700XT
Mobile Phone
  1. Android
  2. iOS
@CaseySJ I did try with CSM enabled but did not make any difference. Same problem. However one thing I tried was to disable the IGPU and connect the 6800 XT to the monitor via DP-DP. The system did not boot at all and kept beeping continuously (according to the meaning of the beeps it seems that it is either a video card error or an AGP error). After investigation I concluded that the system when IGPU is disabled and the 6800XT is connected to the monitor via DP-DP thinks that there is either no video card installed in the system or the system is not connected to any display. But if IGPU is disabled and I connect the 6800 XT to the monitor via HDMI cable, then the system boots fine.I am really starting to think that it is the monitor that is the culprit, at least when using DP to DP cable. The last thing I can try to eliminate any potential issues with the BIOS, the overall system or the 6800 XT is to connect my other more recent monitor if I can get hold of it. If that works then I'll know it is the monitor. If that fails then I don't know what else I can do.
Hi! I had the same problem with an Asus z490 and RX580. Even sent the board (z490) to RMA twice, they sent it right back, twice :) I remember CSM solving the issue. But it was not the only thing I messed up with so I'm not totally sure. The issue was more about the BIOS of the graphics card. Something to do with UEFI/Legacy stuff. I would check the GPUs firmware update, and the boards if there is any. Update both. Then try CSM again. I don't know if your boards BIOS has any options around it, if there is, check them also. When I upgraded to a 5700XT, CSM didn't matter. but I couldn't make RX580 work without it, I mean accessing the BIOS and boot options etc., system was working otherwise. I remember being frustrated a lot, hope you won't. Good luck!
 
Joined
Oct 24, 2013
Messages
840
Motherboard
Gigabyte Z590 Vision D
CPU
i7-11700K OC @ 5.2GHz
Graphics
RX 6800 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
@CaseySJ I did try with CSM enabled but did not make any difference. Same problem. However one thing I tried was to disable the IGPU and connect the 6800 XT to the monitor via DP-DP. The system did not boot at all and kept beeping continuously (according to the meaning of the beeps it seems that it is either a video card error or an AGP error). After investigation I concluded that the system when IGPU is disabled and the 6800XT is connected to the monitor via DP-DP thinks that there is either no video card installed in the system or the system is not connected to any display. But if IGPU is disabled and I connect the 6800 XT to the monitor via HDMI cable, then the system boots fine.I am really starting to think that it is the monitor that is the culprit, at least when using DP to DP cable. The last thing I can try to eliminate any potential issues with the BIOS, the overall system or the 6800 XT is to connect my other more recent monitor if I can get hold of it. If that works then I'll know it is the monitor. If that fails then I don't know what else I can do.
Have you tried a different monitor? Some monitors act weird with certain video cards. De8auer just reported that the 3080ti founder’s edition was having vga not detected issues, causing motherboards to not post if it was connected to a certain Acer monitor.

 
Joined
Nov 6, 2019
Messages
15
Motherboard
Gigabyte Designare Z390
CPU
i9-9900K
Graphics
RX 6800XT
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Can Confirm!

Just updated my GigaByte Designiare 9900K Golden build to 11.4 and a little more than half way through my RX 470 stopped being the primary monitor and it switched to my Asus RX 6800 XT. Post update I removed the RX 470 and tested acceleration and was getting 120+ fps in Valley Ultra benchmark. I didn't do anything really since my initial Big Sur install except maybe update Open Core a month or so ago. I never bothered updating kexts or BIOSs or anything. Just normal Apple Update and Bingo! RX 6800 XT works with full acceleration.
 
Top