Contribute
Register

[Success] PYNTy-Mac i7 8700 - Z390 I AORUS PRO WIFI - 16GB RAM - Sapphire RX 580 - Mojave 10.14.3

Status
Not open for further replies.
Joined
Jun 4, 2016
Messages
135
Motherboard
Gigabyte Z370N-WiFi-F10-Clover
CPU
i5-8600
Graphics
HD 630
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
Download the latest version of AppleALC from the Releases page. Mount your EFI partition, and copy it to Clover/kexts/Other.

Edit the Inject key under Devices/Audio in your config.plist. I advise you to use the Clover Configurator. Replace 1 with the layout ID you wish to use. Look at the AppleALC wiki for the supported layout IDs for our codec Realtek® ALC1220.

I used 1, The audio works perfectly.

Nice build and helpful information.

Regarding sound, have you tried the S/PDIF output from the m/b? I'm interested to know if it might work.
 
Joined
Dec 28, 2013
Messages
134
Motherboard
Z390 I AORUS PRO WIFI
CPU
i7-8700
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Nice build and helpful information.

Regarding sound, have you tried the S/PDIF output from the m/b? I'm interested to know if it might work.
Hi! I don't have a device to test the s/PDIF output from the m/b. I'm sorry I couldn't help you.
 
Joined
Dec 28, 2013
Messages
134
Motherboard
Z390 I AORUS PRO WIFI
CPU
i7-8700
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Quick question, with XMP enabled in your BIOS, do you get USB not ejected properly error after sleep, with an external USB drive?
Hi! You mean, when you sleep your hackintosh with the USB devices connected and when you wake up, you get automatically dismissed and you have to reconnect them? You have enable -Power Nap- in Energy Saving Settings?

Also, I have very slow wake from sleep, like 17 seconds (same as regular boot time), I wonder if there is something in the BIOS affecting it.

I think your system directly goes out, since those 17 seconds to start after sleep is a lot, or do you have a HDD? My hackintosh starts in 2-3 seconds after the dream, but I have to press a key or click, move the mouse don't wake him.

There's a setup in the bios that I disabled, and I was left with little freezes that were performed every once in a while, but i don't know if exactly what it s about.

Chipset → Above 4G Decoding : Disabled

When enabled, the motherboard has a specific "path" mapped to 64-bit memory. In order to make the necessary memory reservations for your graphics cards (and other PCIe devices).

Generally, people enable it when they have many PCIe cards installed, such as with triple and quad SLI and using GPU compute modules. It's more commonly used in servers or workstations.

I'm just a GPU (RX 580), then disable it, but I know users who have it enabled and their system works well.
 
Joined
Jan 26, 2019
Messages
6
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i7 9700k
Graphics
Sapphire RX580
Hi! You mean, when you sleep your hackintosh with the USB devices connected and when you wake up, you get automatically dismissed and you have to reconnect them? You have enable -Power Nap- in Energy Saving Settings?





Chipset → Above 4G Decoding : Disabled

When enabled, the motherboard has a specific "path" mapped to 64-bit memory. In order to make the necessary memory reservations for your graphics cards (and other PCIe devices).

Generally, people enable it when they have many PCIe cards installed, such as with triple and quad SLI and using GPU compute modules. It's more commonly used in servers or workstations.

I'm just a GPU (RX 580), then disable it, but I know users who have it enabled and their system works well.

I tried with Power Nap and without. Anytime my computer wakes from sleep with USB drive or USB audio interface, I get an error that "This disk was not ejected properly". The disk is remounted, so it's just annoying. I disabled XMP, which I really can't tell the difference, and error is gone. Thanks for the reply.
 
Joined
Dec 28, 2013
Messages
134
Motherboard
Z390 I AORUS PRO WIFI
CPU
i7-8700
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
I tried with Power Nap and without. Anytime my computer wakes from sleep with USB drive or USB audio interface, I get an error that "This disk was not ejected properly". The disk is remounted, so it's just annoying. I disabled XMP, which I really can't tell the difference, and error is gone. Thanks for the reply.

So it's because of the Xmp configuration, in my case I have no problem with him, I just tried to check it out, and the Usb unit doesn t get expelled after I wake up from sleep.

Will it be for the selected Ram? I have two different:
- Corsair Vengeance 8GB 2400Mhz
- Corsair Vengeance 16GB 3000Mhz

In "About of this Mac" show "24 GB 2400 MHz DDR4", in Bios XMP, i have select Profile 1.
 
Joined
Jan 26, 2019
Messages
6
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i7 9700k
Graphics
Sapphire RX580
So it's because of the Xmp configuration, in my case I have no problem with him, I just tried to check it out, and the Usb unit doesn t get expelled after I wake up from sleep.

Will it be for the selected Ram? I have two different:
- Corsair Vengeance 8GB 2400Mhz
- Corsair Vengeance 16GB 3000Mhz

In "About of this Mac" show "24 GB 2400 MHz DDR4", in Bios XMP, i have select Profile 1.


That was it. In another thread they said the error was related to memory speed over 2666Mhz (my memory is 3200). I set it to 2666 and it no longer has error. Thanks.
 
Joined
Dec 28, 2013
Messages
134
Motherboard
Z390 I AORUS PRO WIFI
CPU
i7-8700
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
That was it. In another thread they said the error was related to memory speed over 2666Mhz (my memory is 3200). I set it to 2666 and it no longer has error. Thanks.
Hi, Thank you so much for remarking, I will also consider it when I change the 8GB, because I was thinking of buying another from 16 to 3000MHz.

Greetings
 
Joined
Apr 16, 2016
Messages
52
Motherboard
Asrock Z370M
CPU
i7-8700
Graphics
none
Mobile Phone
  1. iOS
Hi, I was looking for SSDT patch CPU Coffee Lake when I found your build. You didn't but you seems to use 2 GPUs. Can you please tell me why ?

My build is Z370M itx ac + 56 Vega + i7-8700.
 
Joined
Dec 28, 2013
Messages
134
Motherboard
Z390 I AORUS PRO WIFI
CPU
i7-8700
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi, I was looking for SSDT patch CPU Coffee Lake when I found your build. You didn't but you seems to use 2 GPUs. Can you please tell me why ?

My build is Z370M itx ac + 56 Vega + i7-8700.

Hi, @RehabMan mentioned that it is not necessary for the new cpu, in this post. Only config.plist/ACPI/SSDT/Generate/PluginType=true.

PluginType - this injects some DSDT data to get X86PlatformPlugin to load - giving us a leg-up on native CPU power management. This setting only works on Haswell and newer CPUs though.

You can see more information here
https://www.tonymacx86.com/threads/macos-native-cpu-igpu-power-management.222982/
 
Joined
Apr 16, 2016
Messages
52
Motherboard
Asrock Z370M
CPU
i7-8700
Graphics
none
Mobile Phone
  1. iOS
@markoskz, Nice, thx. Yes, thanks I finished my long night to install HWmonitor & plugins. :) Next time I will do first. I saw that all is well indeed.
But I dont understand why that build explain the part of the internal GPU. It is just to have common build, without PCIe GPU ? What is the advantage? I work on After Effects but I don't care about my renders.
Can we dissociate, the desktop running of the works of after running. Its seems weird and hard to do, no ? Sorry for my bad question. I am newbie. But I will try to get native discrete GPU before.
 
Last edited:
Status
Not open for further replies.
Top