Contribute
Register

[SUCCESS] Perfect Sierra build Asus Z170 Premium

Joined
Dec 25, 2015
Messages
162
Motherboard
Asus Maximus X Code Z-370
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook Pro, Mac mini, Mac Pro
Mobile Phone
iOS
sixth: Using VoodooHDA 2.8.8 the Audio Inputs are not working. So, no microphone support.
Did you get the ALC 1150 Driver running?
Yes, the ALC 1150 is functioning properly. I never tested the mic input because I have an external interface which is connected at all times.
 
Joined
Dec 25, 2015
Messages
162
Motherboard
Asus Maximus X Code Z-370
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook Pro, Mac mini, Mac Pro
Mobile Phone
iOS
eighth: If I boot with TWO Monitors connected to my GTX1080 (One projector on HDMI and one Monitor on DisplayPort) I get a black screen after the apple boot screen. If I boot with the Projector- HDMI disconnected it boots fine.
Can I somehow disable one monitor during Boot in Clover? Or is there another Fix? AGDPfix.app Does not help... So I have no clue why I get a black screen....
You have almost the exact same problems as mine! Ha ha..

Yes, this happens to me some times. But its not consistently reproducible. I searched for a similar fix but didn't find any. I am no longer spending time on fixing Sierra as High Sierra is almost here. :D
 
Joined
Dec 25, 2015
Messages
162
Motherboard
Asus Maximus X Code Z-370
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook Pro, Mac mini, Mac Pro
Mobile Phone
iOS
@wise-rice
I have a different problem though. I got a bcm94360cs PCIE card from Ebay which should have worked out of the box. However, I am getting stuck at HID Legacy Shim 2. From what I understood by reading online is that, this card is treated like any other USB device while booting up. What I don't get is why my hackintosh isn't liking it.

The reason I got this card is because it supposedly allows bluetooth keyboards to work in clover mode and is more reliable for hand off and continuity.

http://www.ebay.com/itm/Broadcom-BCM94360CS-867Mbps-802-11AC-WLAN-BT-4-0-PCI-E-PC-Desktop-Card-for-MAC-/252196295903?epid=1750426322&hash=item3ab81214df:g:6BEAAOSwfZ1WX0eA
 
Joined
Sep 26, 2012
Messages
5
Motherboard
Asus Z-170 Premium
CPU
i7 6770k
Graphics
GeForce 970 GTX (Gigabyte Windforce)
Mac
Mac mini
Hi folks,

I'm still with Sierra 10.1, did any of you try to update to latest Sierra version with this config (not to High Sierra) ? Did they succeed ? What do I have to be careful to ?

Thanks
 
Joined
Dec 25, 2015
Messages
162
Motherboard
Asus Maximus X Code Z-370
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook Pro, Mac mini, Mac Pro
Mobile Phone
iOS
Hi folks,

I'm still with Sierra 10.1, did any of you try to update to latest Sierra version with this config (not to High Sierra) ? Did they succeed ? What do I have to be careful to ?

Thanks
I have upgraded to High Sierra. BUT.....

I changed my GPU to Radeon RX Vega because I am getting native support. So no more fiddling with webdrivers or GPU patches. (well there is one small patch). I am writing the guide and should be done by tomorrow night. You can wait if you want and see what all you need for High S . haha.
 
Joined
Sep 26, 2012
Messages
5
Motherboard
Asus Z-170 Premium
CPU
i7 6770k
Graphics
GeForce 970 GTX (Gigabyte Windforce)
Mac
Mac mini
I have upgraded to High Sierra. BUT.....

I changed my GPU to Radeon RX Vega because I am getting native support. So no more fiddling with webdrivers or GPU patches. (well there is one small patch). I am writing the guide and should be done by tomorrow night. You can wait if you want and see what all you need for High S . haha.
Thanks, I will wait for High Sierra...

For the moment I just want to update to Sierra last version .. can I do that without fear ?
 
Joined
Dec 25, 2015
Messages
162
Motherboard
Asus Maximus X Code Z-370
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook Pro, Mac mini, Mac Pro
Mobile Phone
iOS
Thanks, I will wait for High Sierra...

For the moment I just want to update to Sierra last version .. can I do that without fear ?
Since the Nvidia Web drivers are already out for High Sierra, I think its good to just upgrade to High Sierra unless you don't wanna do it for other reasons. The OS is quite stable and the web drivers are getting better too. You can also upgrade to High Sierra without changing the file system to APFS if that worries you.

Note that on High Sierra, NVMe support is native as well. Overall, its the most painless experience I have ever had with a hackintosh.
 
Joined
Sep 26, 2012
Messages
5
Motherboard
Asus Z-170 Premium
CPU
i7 6770k
Graphics
GeForce 970 GTX (Gigabyte Windforce)
Mac
Mac mini
I just made the update to 10.12.6 ! I took the pain of making a disk clone before on a new 1Tb SSD... but it was flowless. I just had to update nvidia drivers on reboot and that's it.

As it's my production machine, I'm very cautious with it and will think about going to High Sierra now after checking if it really brings something to me (I don't use NVMe drives yet)
 
Joined
Aug 10, 2017
Messages
314
Motherboard
Gigabyte GA-Z170mx Gaming 5
CPU
i7-6700K
Graphics
GTX 1080
Mac
iMac, Mac mini
Mobile Phone
iOS
I am not sure about the GPU because it just worked oob for me. I removed the Nvidia before installing and it worked smoothly. It was not the case in El Capitan.

For USB type C, I just check with my USB 3.0 drive which has type c connector and its working. I did not anything for this as well.
Have you actually plugged a type c usb 3.1 drive in? I have a z170mx and my usb 3.1 drive appears on the desktop, appears on disk utility, is formidable, and also appears in system report. However, when trying to transfer files to it, or doing a Blackmagic disk test, I get 0mbps transfer rates. Any suggestions?
 
Top