Contribute
Register

[SUCCESS] OS X ML 10.8.2 on Z77DS3H, i5 2500k, 16GB, HD3000+GTX 660, 480GB OCZ Vertex3, natives UEFI

Joined
Jan 4, 2013
Messages
142
Motherboard
Gigabyte Z370 AORUS Ultra Gaming
CPU
i7-8700K
Graphics
MSI Radeon RX 5700XT Evoke + UHD 630
Mac
iMac, MacBook Air
Mobile Phone
Android, iOS
Einbau der NVIDIA GTX660 (non TI) erst nach der ML Installation und Einbindung der NVIDIA Treiber durchgeführt

- Installation von ML mit UniBeast USB Stick
- Installation von Clover 1.000 (UEFI Boot + Treiber), Konfigurieren und Kopieren auf EFI Systempartition
- Installation von Multibeast ALC887 with DSDT, DSDT editiert für HDMI Output auf der GTX660 und 3-Port Audio (layout ID 2)
- Installation NVIDIA Treiber für 10.8.2 und neuester FakeSMC/HWMonitor von kozlek (wegen Support der 660 non TI)
- Verschieben der Windows 8 EFI Startfiles auf EFI Systempartition und Zuweisung dieser unter Windows mit bcdedit....

Alles läuft! Clover als Bootmanager OS X / Windows 8 .
SSD Layout: GPT
EFI Partition, OSX, Windows, Windows System Reserved, Data.

Z77-DS3H Bootoption UEFI only with CSM, Fastboot, xHCI on, Intel VT und XD Bit on, HPET on.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
190,989
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Einbau der NVIDIA GTX660 (non TI) erst nach der ML Installation und Einbindung der NVIDIA Treiber durchgeführt

- Installation von ML mit UniBeast USB Stick
- Installation von Clover 1.000 (UEFI Boot + Treiber), Konfigurieren und Kopieren auf EFI Systempartition
- Installation von Multibeast ALC887 with DSDT, DSDT editiert für HDMI Output auf der GTX660 und 3-Port Audio (layout ID 2)
- Installation NVIDIA Treiber für 10.8.2 und neuester FakeSMC/HWMonitor von kozlek (wegen Support der 660 non TI)
- Verschieben der Windows 8 EFI Startfiles auf EFI Systempartition und Zuweisung dieser unter Windows mit bcdedit....

Alles läuft! Clover als Bootmanager OS X / Windows 8 .
SSD Layout: GPT
EFI Partition, OSX, Windows, Windows System Reserved, Data.

Z77-DS3H Bootoption UEFI only with CSM, Fastboot, xHCI on, Intel VT und XD Bit on, HPET on.
In english, please. And read the rules: http://www.tonymacx86.com/faq.php
 
Joined
Jan 4, 2013
Messages
142
Motherboard
Gigabyte Z370 AORUS Ultra Gaming
CPU
i7-8700K
Graphics
MSI Radeon RX 5700XT Evoke + UHD 630
Mac
iMac, MacBook Air
Mobile Phone
Android, iOS
IMG_1151.jpgUnbenannt.jpgUnbenannt1.jpg


Harware Configuration


- Gigabyte Z77-DS3H rev1.0 Firmware F10f (Gigabyte best Choice for native Mac Support, but BIOS Dev and Bugs really :banghead:)
- Intel Core i5 2500K @3,3 Turbo 3,7
- 16 GB Corsair Vengeance DDR3-1600 (4x4GB)
-
MSI N660 Twin Frozr III 2GD5/OC 2GB GDDR5
- Enermax Pro87+ 600W Powered
- SSD OCZ Vertex 3 480GB
- HDD 1TB Seagate Barracuda ES
- Samsung T27A300 27" Full HD Screen
- AeroCool Case

Steps

As my GTX wasn't on stock i first of all installed OSX using UniBeast USB and Onboard HD3000


- to install via UniBeast, BIOS Legacy Options have to be temporarely enabled, so set Boot Options to UEFI AND Legacy and Priority / Rom
Support to Legacy First, in Mac Disk Wizard i set up an 2 partition GPT layout for my SSD(for Mac, other for windows later)
- Installing Clover 1.000 (UEFI Boot + Drivers), additional File System Drivers to support HFS and moving Clover to Mac EFI System
Partition (later, Windows 8 creates a second UEFI system partition which has to be integrated in the Clover/MAC one with startup repair)
- Clover Drivers: HFSPlus.efi, NTFS.efi, OsxFatBinaryDrv-64.efi, OsxAptioFixDrv-64.efi (with slide=0 in boot args in config.plist)
EmuVariableRuntimeDxe.efi,
- Clover Config.plist necessary boot options: slide=0 and darkwake=0 (for sleep and hibernate) and to get iMessage working, injection of Serial
Number Fix GraphicsEnabler=1 (ONLY for onboard HD3000, when inserting NVIDIA GTX660 i set to No)

- Installing Multibeast ALC887 without DSDT, SandyBridge SSDT, DSDT extracted and modified to get HDMI display audio AND 3-port audio
(layout ID 2 for NVDIA, 3 for Intel onboard HD3000)
- as my onchip HD3000 with 2500k Sandy Bridge had an device id of 0x112, i had to modify AppleIntelHDGraphicsSNBG.kext plist to get
Graphics support (not so important, as i switched to 660 a day later)
- installation of NVIDIA drivers für 10.8.2 und newest FakeSMC/HWMonitor by kozlek (support for 660 non TI sensors), inserting 660
- Windows 8 UEFI installation on GPT second partition
- After that, only Windows boots up and clover seems to be gone. In fact, windows made a second EFI System Partition, which i deleted
after copying boot files to Mac EFI system partition. Using bcdedit i fixed the new boot files to point to the right location and windows
startup location to correct volume

Everythings working with native UEFI and excellent bootup times. Clover is a great choice for native UEFI systems
SSD Layout: GPT only
EFI System Partition, OSX, Windows, Windows System Reserved
HDD : Data Partition.


Z77-DS3H F10f Bootoptions: UEFI only, no CSM (only if your Graphic Card supports UEFI Bootrom- Kepler does!), Fastboot Fastest, xHCI on, Intel VT und XD Bit on, HPET on, Secure Boot Off, CPU and RAM Options Auto, RAM Profile 1 for Corsair SPD Detection
 
Top