Contribute
Register

[SUCCESS] Opus i9 Build: Gigabyte Gaming X Z390 - i9-9900K - Radeon RX 6900 XT Ultimate

Joined
Jul 30, 2011
Messages
55
Motherboard
Gigabyte Z390 Gaming X
CPU
i7-9700k
Graphics
RX580
@tedyun - thanks, I'm trying to solve the failed Supplemental Update issue which has made the system unbootable. Once I get that ironed out (thinking of just doing a fresh install of Catalina with a new Unibeast install stick that has this update already incorporated) I will try the USB fixes.
 
Joined
Jul 30, 2011
Messages
55
Motherboard
Gigabyte Z390 Gaming X
CPU
i7-9700k
Graphics
RX580
I couldn't solve the issue caused by the 10.15.5 Supplemental Update, so I created a new USB and re-installed Catalina and did the USB port mapping. None of my USB 2.0 ports work, but I can probably live with that. I'm testing other aspects and will report more tomorrow.
 
Joined
May 29, 2012
Messages
581
Motherboard
Gigabyte Z390 Gaming X
CPU
i9-9900K
Graphics
Vega 56
Mac
  1. iMac
Classic Mac
  1. LC
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Not even the USB 2.0 on the motherboard? You can try my USBPorts. Just a warning though, I had to disconnect the USB ports on my case because my BT/WiFi card plugs into that header. Otherwise, they work.
 

Attachments

  • USBPorts.kext.zip
    1.4 KB · Views: 28
Joined
Jul 30, 2020
Messages
20
Motherboard
Gigabyte Z390 GAMING X
CPU
i5-9600k
Graphics
MSI RX Vega 64 Air Boost OC | Intel UHD 630
Mac
  1. iMac
  2. MacBook Pro
Do I need to run MultiBeast after install and after copy your EFI?
@tedyun How can I update BIOS to the new BETA F10G?
I've tried with Q-flash in my actual without success.
 
Last edited:
Joined
May 29, 2012
Messages
581
Motherboard
Gigabyte Z390 Gaming X
CPU
i9-9900K
Graphics
Vega 56
Mac
  1. iMac
Classic Mac
  1. LC
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
No need for MultiBeast after copying the EFI. You should be all set.

Format a USB drive in FAT32 then copy over the BIOS file onto the USB drive.

Reboot the computer then go into the BIOS. Insert the USB drive then go into Q-Flash.

Maybe walk me through the steps you are doing for the Q-Flash. Did you download the correct BIOS from my post #1?

Do I need to run MultiBeast after install and after copy your EFI?
@tedyun How can I update BIOS to the new BETA F10G?
I've tried with Q-flash in my actual without success.
 
Joined
Jul 30, 2020
Messages
20
Motherboard
Gigabyte Z390 GAMING X
CPU
i5-9600k
Graphics
MSI RX Vega 64 Air Boost OC | Intel UHD 630
Mac
  1. iMac
  2. MacBook Pro
No need for MultiBeast after copying the EFI. You should be all set.

Format a USB drive in FAT32 then copy over the BIOS file onto the USB drive.

Reboot the computer then go into the BIOS. Insert the USB drive then go into Q-Flash.

Maybe walk me through the steps you are doing for the Q-Flash. Did you download the correct BIOS from my post #1?
I fount it right now in the first post and works great, Thanks.
 
Joined
May 29, 2012
Messages
581
Motherboard
Gigabyte Z390 Gaming X
CPU
i9-9900K
Graphics
Vega 56
Mac
  1. iMac
Classic Mac
  1. LC
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
You might want to try out the BIOS settings I have there in the first post. My system is super stable. Thanks to pastrychef for figuring all of this stuff out. I’ve never had such a stable and compatible Hackintosh.

If you figure out any other settings in the BIOS or config.plist, be sure to share!

I fount it right now in the first post and works great, Thanks.
 
Joined
Jul 30, 2020
Messages
20
Motherboard
Gigabyte Z390 GAMING X
CPU
i5-9600k
Graphics
MSI RX Vega 64 Air Boost OC | Intel UHD 630
Mac
  1. iMac
  2. MacBook Pro
You might want to try out the BIOS settings I have there in the first post. My system is super stable. Thanks to pastrychef for figuring all of this stuff out. I’ve never had such a stable and compatible Hackintosh.

If you figure out any other settings in the BIOS or config.plist, be sure to share!
Yes, I finished now. Booting with bios F10G, confs from post 1 and your EFI from framebuffer thread that you replied me. Still having problems with fans. Can you help me with that?
 
Joined
Jul 30, 2020
Messages
20
Motherboard
Gigabyte Z390 GAMING X
CPU
i5-9600k
Graphics
MSI RX Vega 64 Air Boost OC | Intel UHD 630
Mac
  1. iMac
  2. MacBook Pro
I've now set all fans to silent in bios, however I believe that the MacOS system could manage the fans.
 
Joined
May 29, 2012
Messages
581
Motherboard
Gigabyte Z390 Gaming X
CPU
i9-9900K
Graphics
Vega 56
Mac
  1. iMac
Classic Mac
  1. LC
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Does that setting work? I have a liquid cooler and the fan is manually set between low, med and high. I don't really have experience with setting the fan speed in MacOS.

What kind of cooler are you using?

Is it the CPU fans or case fans?

I've now set all fans to silent in bios, however I believe that the MacOS system could manage the fans.
 
Top