Contribute
Register

[SUCCESS] Opus i9 Build: Gigabyte Gaming X Z390 - i9-9900K - Radeon RX 6900 XT Ultimate

Joined
Jul 23, 2011
Messages
19
Motherboard
Gigabyte GA-EG43M-S2H
CPU
i5-6600
Graphics
HD 6000 series
Hello @tedyun
Is it possible to enable F_USB 3.0 socket on motherboard in your EFI configuration?
Thank you!
Screen_Shot_2020-02-19_at_2_14_42_PM.jpg
 
Joined
May 29, 2012
Messages
779
Motherboard
Gigabyte Z390 Gaming X
CPU
i9-9900K
Graphics
6900XT
Mac
  1. iMac
Classic Mac
  1. LC
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Hi @Dr.Hofmann -- that's the Z390M Gaming motherboard, not our Z390 Gaming X!

I haven't gotten around to it yet. There is no real need on my system at the moment. To enable that header, as you know, a single USB 3.0 port actually takes up two of the 15 ports, so right now, I am maxed out. In fact in order to enable the internal USB 2.0 header for my Fenvi T919, I think I had to disable an external port. So I'm not sure how I would fit that USB 3.0 header.

It's pretty straightforward! Do you want to give it a go?

 
Joined
Jul 23, 2011
Messages
19
Motherboard
Gigabyte GA-EG43M-S2H
CPU
i5-6600
Graphics
HD 6000 series
Hi @Dr.Hofmann -- that's the Z390M Gaming motherboard, not our Z390 Gaming X!

I haven't gotten around to it yet. There is no real need on my system at the moment. To enable that header, as you know, a single USB 3.0 port actually takes up two of the 15 ports, so right now, I am maxed out. In fact in order to enable the internal USB 2.0 header for my Fenvi T919, I think I had to disable an external port. So I'm not sure how I would fit that USB 3.0 header.

It's pretty straightforward! Do you want to give it a go?

you mean that if enable F_USB30 next fenvi t919 got down cos fenvi's usb20 low power supply?

It's pretty straightforward! Do you want to give it a go?
yes
 
Joined
May 29, 2012
Messages
779
Motherboard
Gigabyte Z390 Gaming X
CPU
i9-9900K
Graphics
6900XT
Mac
  1. iMac
Classic Mac
  1. LC
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
you mean that if enable F_USB30 next fenvi t919 got down cos fenvi's usb20 low power supply?


yes

No -- I meant that because you're limited to 15 ports, and because each USB 3.0 port counts as 2 ports (if you want to be able to plug both USB 2.0 and USB 3.0 devices into the USB 3.0 port), I quickly ran out of ports!

If you look on the back connectors of the mother board, there are 2x USB 2.0 ports and 6x USB 3.0 ports. So just to enable all the back ports, that already takes up 14 of the 15 available ports.

To enable the internal USB 2.0 on the motherboard (to connect the Fenvi) I can't remember if that takes up the last port or if I had to make one of the USB 3.0 ports into a USB 3.0 only.

So to enable the internal USB 3.0 header, you have to probably disable a couple ports from the back or make some of them USB 3.0 only. I'm not sure how to configure them, and I really haven't had the need yet.
 
Joined
Jul 23, 2011
Messages
19
Motherboard
Gigabyte GA-EG43M-S2H
CPU
i5-6600
Graphics
HD 6000 series
Clear. Thanks. 15 this iMac specification quota?
Ii checked that on second M.2 on Windows 11. It's OK.
I understood; thank you for your reply.
 
Joined
May 29, 2012
Messages
779
Motherboard
Gigabyte Z390 Gaming X
CPU
i9-9900K
Graphics
6900XT
Mac
  1. iMac
Classic Mac
  1. LC
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Clear. Thanks. 15 this iMac specification quota?
Ii checked that on second M.2 on Windows 11. It's OK.
I understood; thank you for your reply.

Yes, this is a macOS specific limitation. I forget why they set it like this, but I'm sure it has something to do with Apple being Apple. On their laptops, iMacs and towers, I don't think I've ever seen more than 4 ports. I'm pretty sure they're not too enthusiastic to accommodate us Hackintoshers.

"One Apple Way" isn't their corporate address. Although it should be....
 
Joined
Jun 15, 2010
Messages
28
Motherboard
Gigabyte Z390 Gaming X
CPU
i3 9700k
Graphics
RX570
Mac
  1. Mac Pro
Hi @tedyun , you did a fantastic job there; looks like an amazing build!
I've got similar hardware and I would love to update my software: I just need a little support from your deep knowledge.

Hardware:
Gigabyte Z390 GAMING X, bios F10
Intel 9700k with iGPU
Gigabyte radeon rx 570 4gb
Dual screens, one DP attached to the RX570, other HDMI attached to the iGPU.

The computer is currently running Catalina and Clover; I set it up 2+ years ago and didn't use it much.
Catalina is installed on a SSD, and I've got another SSD laying around to test Monterey + Opencore!
I would like to maximize video rendering performance (like Final cut pro), and have all nice features enable and hardware accelerated..

Questions:
- Do you use the iMac19,1 SMBIOS?
- do you think iMac19,1 what match my build and needs, and is better than MacPro7,1?
- Which elements of your opencore EFI do you suggest changing on my build?

Thanks a lot for your time!!
 
Joined
May 29, 2012
Messages
779
Motherboard
Gigabyte Z390 Gaming X
CPU
i9-9900K
Graphics
6900XT
Mac
  1. iMac
Classic Mac
  1. LC
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Hi @tedyun , you did a fantastic job there; looks like an amazing build!
I've got similar hardware and I would love to update my software: I just need a little support from your deep knowledge.

Hardware:
Gigabyte Z390 GAMING X, bios F10
Intel 9700k with iGPU
Gigabyte radeon rx 570 4gb
Dual screens, one DP attached to the RX570, other HDMI attached to the iGPU.

The computer is currently running Catalina and Clover; I set it up 2+ years ago and didn't use it much.
Catalina is installed on a SSD, and I've got another SSD laying around to test Monterey + Opencore!
I would like to maximize video rendering performance (like Final cut pro), and have all nice features enable and hardware accelerated..

Questions:
- Do you use the iMac19,1 SMBIOS?
- do you think iMac19,1 what match my build and needs, and is better than MacPro7,1?
- Which elements of your opencore EFI do you suggest changing on my build?

Thanks a lot for your time!!

The @thepawn - thank you!

I remember there is an issue with FCP and trying to tell it to use the dGPU for rendering. I think it defaults to the iGPU, so the workaround was to use the MacPro SMBIOS. I haven't really done anything with it since I don't do much hardcore video work at the moment. It was more important for me to get Sidecar working.

I don't have access to a current version of FCP, so I'm not sure if I can help you out. I've pretty much converted over to Adobe Premiere, but that's only because I use Creative Cloud, so I figured I should get my money's worth.

Let me know how far you get with it. There was another user here who was able to get FCP to use his dGPU, but I can't remember what the settings were.
 
Joined
Jun 15, 2010
Messages
28
Motherboard
Gigabyte Z390 Gaming X
CPU
i3 9700k
Graphics
RX570
Mac
  1. Mac Pro
thanks a lot. I was able to successfully install Catalina using your EFI (open core 0.7).
I read in your first post, you later upgraded both OS (to Monterey) and Opencore.
Can you please share the updated EFI folder in your first post?
I know it takes some time to mount the drive, take the files out, and clean the "personal" information, so thanks a lot in advance!

I tried pastrychef's EFI folder (OC 0.7.9) and was able to install Monterey, but some USB ports are not working, and the build was meant to not use the iGPU, so there's no framebuffer patching.
I wish I would be able to master these things myself one day, but I was hoping to benefit from the hard work you already made in the past!
 
Last edited:
Joined
May 29, 2012
Messages
779
Motherboard
Gigabyte Z390 Gaming X
CPU
i9-9900K
Graphics
6900XT
Mac
  1. iMac
Classic Mac
  1. LC
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
thanks a lot. I was able to successfully install Catalina using your EFI (open core 0.7).
I read in your first post, you later upgraded both OS (to Monterey) and Opencore.
Can you please share the updated EFI folder in your first post?
I know it takes some time to mount the drive, take the files out, and clean the "personal" information, so thanks a lot in advance!

I tried pastrychef's EFI folder (OC 0.7.9) and was able to install Monterey, but some USB ports are not working, and the build was meant to not use the iGPU, so there's no framebuffer patching.
I wish I would be able to master these things myself one day, but I was hoping to benefit from the hard work you already made in the past!

Hi @thepawn -- Thanks for your post, and sorry for the delayed response! Make sure to tag me with an "@" before my username, and I will see your post in my Alerts.

I've been pretty lazy in updating to the latest OpenCore each month. This last month, we've been dealing with the 12.3 update derailing the Navi card support. There is some entries we needed to add, and we were hoping these were temporary if Apple could fix the Navi support. Thankfully, as of yesterday, the 12.3.1 update fixed it. So I will remove those temporary tweaks from my config.plist.

How about I wait until the next release (0.8.0) next week, and I'll upload a generic config.plist/EFI here. Honestly, my EFI is pretty similar to pastrychef's Z390M Gaming EFI. I originally just used his, then modified it for the Gaming X. You just need to put the framebuffers in there if you want to use the onboard HDMI-out, and the USBports kext for the Gaming X.

But I will update it for sure next week. Thanks for the reminder. I'll tag you when I get a chance to do it.

Ted
 
Top