Contribute
Register

<< Solved >> [Success] OpenCore 0.5.9 on Haswell Build GA-Z97-HD3

Status
Not open for further replies.
Joined
Mar 5, 2011
Messages
3
Motherboard
Gigabyte GA‑Z97‑HD3
CPU
Intel Core i5-4460 LGA 1150
Graphics
Gigabyte Radeon RX 580
Did you see my post regarding updating OC?

Anybody else have that would like to update OpenCore, please note:
You must disable Secure Boot Model on you config.plist

<dict>
<key>SecureBootModel</key>
<string>Disabled</string>
</dict>
</plist>

Thanks to @jzrodriguez I was able to start booting with OpenCore. I have now updated OpenCore to the latest release 0.6.3
@spang1974 Thank you! That worked - I was able to update OC. Really appreciate it.
 
Joined
Jan 29, 2012
Messages
165
Motherboard
GA-Z97-HD3
CPU
i5-4690K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. Mac mini
Mobile Phone
  1. Android
  2. iOS
@jzrodriguez98 - would you mind posting your latest OpenCode EFI folder? I have similar hardware, and I used your configuration (with minor changes) to get my system up and running. However, I having issues trying updating to a newer version of OC. Much appreciated.
@maddux3311 , sorry that I missed your post. I’ve bee working a lot lately and did not have the chance. I’ll upload my EFI shortly.
 
Joined
Jan 29, 2012
Messages
165
Motherboard
GA-Z97-HD3
CPU
i5-4690K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. Mac mini
Mobile Phone
  1. Android
  2. iOS
Did you see my post regarding updating OC?

Anybody else have that would like to update OpenCore, please note:
You must disable Secure Boot Model on you config.plist

<dict>
<key>SecureBootModel</key>
<string>Disabled</string>
</dict>
</plist>

Thanks to @jzrodriguez I was able to start booting with OpenCore. I have now updated OpenCore to the latest release 0.6.3
@maddux3311 , attached are my efi files. I’ve being tuning them lately. I hope they work. I also attached USBMaps.kext in case you prefer that method instead of SSDT-UIAC + USBINJECTALL.kext. I removed Resources folder due to size limits. I boot both macOS Catalina and Big Sur. The only hiccup is in Big Sur since my USB 3.1 PCIe card is not working as in Catalina. Apple changed in Big Sur the IOUSBHOSTFAMILY kext plug-in, disabling the native USB 3.1 support. I read that editing and patching ACPI (dsdt) may fix the adversely affected USB 3.1 asmedia PXSX, but it’s a time consuming process and right now I don’t have a lot of time to do it. Since Haswell ACPI works differently when compared to Skylake, it takes more time for me. In Skylake, there’s a specific SSDT OEM for xhc which can be edited to achieve a near native USB. Maybe some of you can do this and post results. Here is the link to the guide.

 

Attachments

  • USBMap.kext2.zip
    3.1 KB · Views: 122
  • OpenCore 0.6.4 z97-hd3.zip
    6.4 MB · Views: 241
  • Resources.zip
    55.5 MB · Views: 143
Joined
Nov 10, 2012
Messages
202
Motherboard
GA-Z97-HD3
CPU
i7-4790
Graphics
Intel HD Graphics 4600
Mobile Phone
  1. iOS
Anybody upgrading to OpenCore 0.6.4 getting the following error on their splash screen before the picker or booting will need to change their config.plist file as seen below.

Error - OCS: Failed to calculate size of the field containing <empty> as type integer, context <PlayChime>!

Will need to change the following line in config.plist from this:

<key>PlayChime</key>
<true/>

to this:

<key>PlayChime</key>
<string>Auto</string>


Hope that helps
 
Joined
Dec 29, 2015
Messages
29
Motherboard
GA-Z97P-D3
CPU
i7-4970K
Graphics
GT 740
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Finally I was able to move from Clover to OpenCore on my hackintosh build. It boots really fast and even with the famous boot chime. I attached the OC files for anyone who wants to give it a try. I followed the Github step-by-step guide:
My build specs are:
Gigabyte Z97-HD3 rev. 2.1 - i5-4690K - Gigabyte Aorus AMD RX 580 8gb
I used OpenCanopy to give a Clover feeling to the OpenCore boot menu.
Thank you , your files has been usefull for me to have Opencore install .. Big Sur (10.2) on a GA-Z97P-D3 with a i7-4790K and a Nvidia GT 740.
 
Status
Not open for further replies.
Top