Contribute
Register

<< Solved >> [Success] OpenCore 0.5.9 on Haswell Build GA-Z97-HD3

Status
Not open for further replies.
Joined
Oct 5, 2020
Messages
1
Motherboard
z97x
CPU
4790k
Graphics
rx580
Thanks for sharing. Does it sleep and wake up properly?
 
Joined
Jan 29, 2012
Messages
165
Motherboard
GA-Z97-HD3
CPU
i5-4690K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. Mac mini
Mobile Phone
  1. Android
  2. iOS
Thanks for sharing. Does it sleep and wake up properly?
@elontony, in my case, I disable in system preferences the wake and hard drive settings in Energy Saver to avoid sleep issues. My board is known for having issues with wake/sleep from time to time.
 
Last edited:
Joined
Nov 10, 2012
Messages
202
Motherboard
GA-Z97-HD3
CPU
i7-4790
Graphics
Intel HD Graphics 4600
Mobile Phone
  1. iOS
Anybody have any pointers on overcoming USB port limits? I tried google but can't seem to find a workaround to getting my USB ports visible? Would it matter if I am using a rev.1 motherboard?

Thank you Jzrodriguez98 for posting your OC, I was able to make the changes to serial numbers, etc and get my system to boot without clover.

TIA for any help
 
Joined
Jan 29, 2012
Messages
165
Motherboard
GA-Z97-HD3
CPU
i5-4690K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. Mac mini
Mobile Phone
  1. Android
  2. iOS
@spang1974 To enable the USB ports I use usbinjectall kext coupled with the ssdt-uiac.AML that is created following this guidance:
 
Joined
Nov 10, 2012
Messages
202
Motherboard
GA-Z97-HD3
CPU
i7-4790
Graphics
Intel HD Graphics 4600
Mobile Phone
  1. iOS
Anybody else have that would like to update OpenCore, please note:
You must disable Secure Boot Model on you config.plist

<dict>
<key>SecureBootModel</key>
<string>Disabled</string>
</dict>
</plist>

Thanks to @jzrodriguez I was able to start booting with OpenCore. I have now updated OpenCore to the latest release 0.6.2
 
Last edited:
Joined
Jan 29, 2012
Messages
165
Motherboard
GA-Z97-HD3
CPU
i5-4690K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. Mac mini
Mobile Phone
  1. Android
  2. iOS
thanks for sharing your backup, i have the same motherboard Z97-HD3 rev 2.1 with a i7-4790K and AMD RX 580 8gb (the same video card than yours). i was trying to do a fresh install of Catalina on a separate disk, the main disk i have is using High Sierra, so i'm trying to test Catalina first on new disk before doing it on my main one.

so far i did not have success with the official guide (which uses clover), and i just heard about OpenCore and wanted to try it. do you think i can use the same EFI files than your backup? we have almost the same hardware except for the cpu and the rev of the motherboard (1.0 vs 2.1) so i'm not sure if that makes some difference. also it will really help me if you can share some guide that uses OpenCore or if i just need to follow the OpenCore guide. if you have other tips that can help me i will be really grateful
@bjrmatos did you have success setting up OpenCore? I just followed the dortania official guide. I got help from a developer to generate a DSDT and properly build the EFI folder to make my wifi card work while booting Big Sur betas too. And Don’t use bootstrap if you want to access your UEFI BIOS. If I use bootstrap, I don’t have access to the BIOS. For dual booting Windows and macOS, you can follow dortania guide recommendations. There are also a couple of guides out there https://github.com/dortania/Hackintosh-Mini-Guides/blob/master/refind.md

to chain load OpenCore with reFindplus that you can explore if you want to multiboot precluding OpenCore from injecting data in Windows intended for macOS. There is also an OpenCore NDK fork that disables ACPI injection and Boot Quirks for Windows (never tried it). This is also accomplished by inserting in the SSDTs that are loaded in OpenCore a line that precludes OpenCore from injecting data in Windows.
 
Joined
Mar 5, 2011
Messages
3
Motherboard
Gigabyte GA‑Z97‑HD3
CPU
Intel Core i5-4460 LGA 1150
Graphics
Gigabyte Radeon RX 580
@bjrmatos did you have success setting up OpenCore? I just followed the dortania official guide. I got help from a developer to generate a DSDT and properly build the EFI folder to make my wifi card work while booting Big Sur betas too. And Don’t use bootstrap if you want to access your UEFI BIOS. If I use bootstrap, I don’t have access to the BIOS. For dual booting Windows and macOS, you can follow dortania guide recommendations. There are also a couple of guides out there https://github.com/dortania/Hackintosh-Mini-Guides/blob/master/refind.md

to chain load OpenCore with reFindplus that you can explore if you want to multiboot precluding OpenCore from injecting data in Windows intended for macOS. There is also an OpenCore NDK fork that disables ACPI injection and Boot Quirks for Windows (never tried it). This is also accomplished by inserting in the SSDTs that are loaded in OpenCore a line that precludes OpenCore from injecting data in Windows.
@jzrodriguez98 - would you mind posting your latest OpenCode EFI folder? I have similar hardware, and I used your configuration (with minor changes) to get my system up and running. However, I having issues trying updating to a newer version of OC. Much appreciated.
 
Joined
Nov 10, 2012
Messages
202
Motherboard
GA-Z97-HD3
CPU
i7-4790
Graphics
Intel HD Graphics 4600
Mobile Phone
  1. iOS
@jzrodriguez98 - would you mind posting your latest OpenCode EFI folder? I have similar hardware, and I used your configuration (with minor changes) to get my system up and running. However, I having issues trying updating to a newer version of OC. Much appreciated.
Did you see my post regarding updating OC?

Anybody else have that would like to update OpenCore, please note:
You must disable Secure Boot Model on you config.plist

<dict>
<key>SecureBootModel</key>
<string>Disabled</string>
</dict>
</plist>

Thanks to @jzrodriguez I was able to start booting with OpenCore. I have now updated OpenCore to the latest release 0.6.3
 
Status
Not open for further replies.
Top