Contribute
Register

[SUCCESS] Old Hack, New Tricks II - Upgrading My GA-Z77X-UP5 TH System to Catalina

Joined
Jul 13, 2013
Messages
99
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
AMD RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Centris
  2. Power Mac
  3. Quadra
Mobile Phone
  1. iOS
I'm thinking about updating my system defintion from 13,2 to 14,2. Do any of you guys have experience doing this? I don't want it to lock me out of iCloud or anything.

I would be very careful here. Changing your system definition means changing other things like serial number and SmUUID. Those are key numbers for iCloud...

First, I suggest cloning your working clover.config file and doingyour work in the clone so you can always go back to a known working state. I would also completely disable both WiFi (remove card) and Ethernet (disconnect cable) so you don’t try to talk to iCloud until you are positive you’re ready to.

Some other suggestions...
  1. If you have a small spare SSD to use as a scratch install, I would suggest using it to do a vanilla install. Then you can move that working clover.config file to your original SSD and upgrade the config.
  2. Take a look at my original post about upgrading to Mojave. That has info on how I did my system definition change.
  3. Remember that doing this will also cause some software registration issues for titles that tie registration to serial number or whatever. You’ll need to work those case by case.
I hope this helps!
 
Joined
Dec 7, 2012
Messages
6
Motherboard
Gigabyte UP5-TH
CPU
i7-3770K
Graphics
GTX 670 / RX 580
I'm thinking about updating my system defintion from 13,2 to 14,2. Do any of you guys have experience doing this? I don't want it to lock me out of iCloud or anything.
Stay on 13,2. I recently updated my machine (I'll make a longer post later about that) and I found that 13,2 enabled: (1.) natively Hardware Acceleration (intel gpu) -- great for video editing and encoding h264, AND (2) also natively allowed use of quick look/jpeg preview in Finder.

Using 14,2 previously I got #1 hardware encoding, but couldn't easily get #2.
You do need to in BIOS, make sure the IGPU is set to enabled and your Init Display First is set to PEG before all if this.

All the above is for a fresh install of Mojave 10.14.6.

Warning: When I changed from 14,2 back to 13,2 I lost my bluetooth connection off my internal wifi card (FENVI T919). I just used the USBinject all kexts and everything is working again. (and yes, I am working on USB port mapping).

If you really want to switch to 14,2 (I wouldn't)... First sign out of messages, sign out icloud in system preferences, sign out of the app store, sign out of itunes, and then finally open a browser and go to icloud.com. Look up your device and remove it there. Then sign out. Now change your system definition and reboot. Don't sign back in until you've confirmed everything works.
 
Joined
Jul 13, 2013
Messages
99
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
AMD RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Centris
  2. Power Mac
  3. Quadra
Mobile Phone
  1. iOS
Stay on 13,2. I recently updated my machine (I'll make a longer post later about that) and I found that 13,2 enabled: (1.) natively Hardware Acceleration (intel gpu) -- great for video editing and encoding h264, AND (2) also natively allowed use of quick look/jpeg preview in Finder.

Using 14,2 previously I got #1 hardware encoding, but couldn't easily get #2.
You do need to in BIOS, make sure the IGPU is set to enabled and your Init Display First is set to PEG before all if this.

All the above is for a fresh install of Mojave 10.14.6.

Warning: When I changed from 14,2 back to 13,2 I lost my bluetooth connection off my internal wifi card (FENVI T919). I just used the USBinject all kexts and everything is working again. (and yes, I am working on USB port mapping).

If you really want to switch to 14,2 (I wouldn't)... First sign out of messages, sign out icloud in system preferences, sign out of the app store, sign out of itunes, and then finally open a browser and go to icloud.com. Look up your device and remove it there. Then sign out. Now change your system definition and reboot. Don't sign back in until you've confirmed everything works.

For what it's worth, I had never-before-seen Bluetooth problems when I went to Mojave with iMac 13,2...that's why I went to iMac 14,2 as MultiBeast wanted to do with my hardware. From everything I can see, I have Intel GPU acceleration just fine (including AirPlay desktop sharing, which never worked before). I fixed the QuickLook/JPEG preview bug with two boot arguments that control WhateverGreen's implementation of the fix.

Gotta love Hackintoshing...it's not exactly a deterministic process, is it? :)
 
Joined
Sep 16, 2012
Messages
54
Motherboard
GA-Z77X-UP5-TH
CPU
i7 3770K
Graphics
GTX 760
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
  2. Quadra
Mobile Phone
  1. iOS
Stay on 13,2. I recently updated my machine (I'll make a longer post later about that) and I found that 13,2 enabled: (1.) natively Hardware Acceleration (intel gpu) -- great for video editing and encoding h264, AND (2) also natively allowed use of quick look/jpeg preview in Finder.

Using 14,2 previously I got #1 hardware encoding, but couldn't easily get #2.
You do need to in BIOS, make sure the IGPU is set to enabled and your Init Display First is set to PEG before all if this.

All the above is for a fresh install of Mojave 10.14.6.

Warning: When I changed from 14,2 back to 13,2 I lost my bluetooth connection off my internal wifi card (FENVI T919). I just used the USBinject all kexts and everything is working again. (and yes, I am working on USB port mapping).

If you really want to switch to 14,2 (I wouldn't)... First sign out of messages, sign out icloud in system preferences, sign out of the app store, sign out of itunes, and then finally open a browser and go to icloud.com. Look up your device and remove it there. Then sign out. Now change your system definition and reboot. Don't sign back in until you've confirmed everything works.

well you're certainly making me reconsider it. I don't think I will change it now. Thank you for your input.
 
Joined
Sep 16, 2012
Messages
54
Motherboard
GA-Z77X-UP5-TH
CPU
i7 3770K
Graphics
GTX 760
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
  2. Quadra
Mobile Phone
  1. iOS
Would you guys have any idea why Hackintool says that my kexts aren’t the latest version? I downloaded them from their respective githubs and used hackintool to install them but no matter how many times I restart my machine hackintool still says otherwise. Also, the file a themselves say they were modified today. I’d like to make the jump to Catalina soon but I don’t want to botch it somehow.
 
Joined
Jul 23, 2012
Messages
808
Motherboard
GA-Z77N-WIFI-F3-Clover
CPU
E3-1225 v2
Graphics
GT 640 | P4000
Mac
  1. Mac mini
Would you guys have any idea why Hackintool says that my kexts aren’t the latest version? I downloaded them from their respective githubs and used hackintool to install them but no matter how many times I restart my machine hackintool still says otherwise. Also, the file a themselves say they were modified today. I’d like to make the jump to Catalina soon but I don’t want to botch it somehow.

lastest version =/= it is stable version, (if it ain't broke don't fix it)

your hardware configuration is quite old, you don't have to update the kexts so often, the updates usually do not affect your configuration.

hacktool listed three types of kexts
Installed kext : the kexts currently installed on your system (e.g. AppleALC 1.4.5)
kext binary file on github : official released version (e.g. AppleALC 1.4.5)
lastest kext on github : most up to date in source codes but binary files are not available for download (e.g. the source codes are updated to AppleALC 1.4.6)

e.g. AppleALC 1.4.6 changelog (your system do not have these devices)
Code:
- Add missing pinconfig ALC235 layout-id 16
- Fixed speaker/headphone priority ALC700 layout-id 11
- 300 Series PCH HD Audio is native in 10.14+
- Added ALC215 layout-id 18 for HP 830 G6 by 965987400abc
 
Joined
Sep 16, 2012
Messages
54
Motherboard
GA-Z77X-UP5-TH
CPU
i7 3770K
Graphics
GTX 760
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
  2. Quadra
Mobile Phone
  1. iOS
Thanks @itwas for your information!

I was able to get my system up to Catalina this week. Everything continues to work great-- mainly just bumping this thread again to ask if anyone had any success getting their machine to sleep or if anyone has any experience getting clover to a higher resolution for a 4K monitor. The sleep thing seems like a crap shoot for many systems, but I haven't been able to have any luck, so I find myself leaving it logged into my windows disk more often just because I know it'll sleep properly.

As for the 4K clover boot screen, the most information I've found elsewhere is that you have to disable CSM and switch your OS to "other OS" but I haven't seen any way to do that in our BIOS and disabling CSM seems to outright kill the system until you refresh the CMOS. I found a 4K catalina theme and tried using that but that made things worse somehow-- the screen ended up even lower resolution than it does with my mojave theme! Obviously I've tried setting the resolution with Clover Configurator but that doesn't seem to do much to help. It's the only drawback of having a fancy new monitor currently.
 
Joined
Jul 23, 2012
Messages
808
Motherboard
GA-Z77N-WIFI-F3-Clover
CPU
E3-1225 v2
Graphics
GT 640 | P4000
Mac
  1. Mac mini
Thanks @itwas for your information!

I was able to get my system up to Catalina this week. Everything continues to work great-- mainly just bumping this thread again to ask if anyone had any success getting their machine to sleep or if anyone has any experience getting clover to a higher resolution for a 4K monitor. The sleep thing seems like a crap shoot for many systems, but I haven't been able to have any luck, so I find myself leaving it logged into my windows disk more often just because I know it'll sleep properly.

As for the 4K clover boot screen, the most information I've found elsewhere is that you have to disable CSM and switch your OS to "other OS" but I haven't seen any way to do that in our BIOS and disabling CSM seems to outright kill the system until you refresh the CMOS. I found a 4K catalina theme and tried using that but that made things worse somehow-- the screen ended up even lower resolution than it does with my mojave theme! Obviously I've tried setting the resolution with Clover Configurator but that doesn't seem to do much to help. It's the only drawback of having a fancy new monitor currently.

make sure your GTX760 VBIOS is UEFI compatible

if your graphics card do not have GOP ROM, you can update the VBIOS using this tool

in the BIOS setup
CSM Support
:: Never - Disables UEFI CSM and supports UEFI BIOS boot process only.
OS
:: change to "Windows 8" or "Windows 8 WHQL" (do not have the same effect, you can try)

about sleep/wake issue, maybe you can provide more information for troubleshooting
 
Joined
Apr 10, 2013
Messages
30
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
GTX 780
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Thanks for this guide OP.
I had not played around with my hackintosh for a long time, but last night I decided to upgrade to Catalina without reading any guides, or installing any kexts. It upgraded and booted up without audio, or wifi.
I will definitely follow your guide to fix it later tonight. Thanks!
 
Top