Contribute
Register

[SUCCESS] Old Hack, New Tricks II - Upgrading My GA-Z77X-UP5 TH System to Catalina

Status
Not open for further replies.
Joined
Jul 12, 2013
Messages
104
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
AMD RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Centris
  2. Power Mac
  3. Quadra
Mobile Phone
  1. iOS
When my iMac14,2 was working a day ago, sleep would work but the USB slots would loose connectivity. Bluetooth would also shut off and not come back on until a full restart. Now I have other problems -- Kernel 0x9e issue....

Never seen this amount of problems with other MacOS versions.

I know it’s a pain, but in the past when I had huge problems with a build, I found that wiping back to a bare drive and doing a fresh install was best. In this case, you might want to do a fresh Mojave install and then immediately update to Catalina since MultiBeast and UniBeast aren’t ready for Catalina yet. Once you’re confident the new build is stable and everything you need is working, then you can restore apps and files from a Time Machine backup.

Good luck!
 
Joined
Oct 2, 2012
Messages
2
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac Pro
Mobile Phone
  1. iOS
Hello! Anybody updating this board to Catalina using the Sapphire Pulse RX 580 8GB? Got it running with onboard video but getting black screen after installing this card.

NVM solved it with a totally fresh install. Needed to use onboard intel video until up and running, then installed lilu 1.4.0 and Whatever Green 1.3.5 via hackintool.
 
Last edited:
Joined
Dec 6, 2012
Messages
6
Motherboard
Gigabyte UP5-TH
CPU
i7-3770K
Graphics
GTX 670 / RX 580
Thank you mickelsn, for your info on this. I have this same board, and wanted to upgrade some components on it.

My question is-- Do you think it would be easier to do Mojave and then Catalina or should I try to do a fresh "vanilla" install of Catalina?
I've been on a sierra build for awhile-- it was stable, so I kept it... :)

I'm also going to put in an RX 580 instead of my GTX 670, and an Fenvi TV-919 in hopes of handoff...

Again, thank you for keeping us updated on this...
 
Joined
Jul 12, 2013
Messages
104
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
AMD RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Centris
  2. Power Mac
  3. Quadra
Mobile Phone
  1. iOS
Thank you mickelsn, for your info on this. I have this same board, and wanted to upgrade some components on it.

My question is-- Do you think it would be easier to do Mojave and then Catalina or should I try to do a fresh "vanilla" install of Catalina?
I've been on a sierra build for awhile-- it was stable, so I kept it... :)

I'm also going to put in an RX 580 instead of my GTX 670, and an Fenvi TV-919 in hopes of handoff...

Again, thank you for keeping us updated on this...

I haven't tried a clean install of Catalina myself yet because UniBeast/MultiBeast haven't yet been updated. As a result, if I had to wipe this machine clean and start over I'd probably start with a clean Mojave install, get all of that working, then upgrade Clover and kexts and then install Catalina.

I'd also do just one thing at a time -- get the OS installed and stable, THEN do the graphics card, THEN do the wireless card...less changes to try and troubleshoot if things go wrong!
 
Joined
Aug 26, 2018
Messages
2
Motherboard
GIGABYTE GA-Z77X-UP5 TH
CPU
i5-3570K
Graphics
GTX 660
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Anybody having trouble with imessage. I am able to send two messages and then all other will stated "Not Delivered". you can reboot then it works again for two messages. Everything else with Catalina works fine.
 
Joined
Jul 12, 2013
Messages
104
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
AMD RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Centris
  2. Power Mac
  3. Quadra
Mobile Phone
  1. iOS
Anybody having trouble with imessage. I am able to send two messages and then all other will stated "Not Delivered". you can reboot then it works again for two messages. Everything else with Catalina works fine.

Sounds like your Hack might have some challenges with iCloud authorization. I recommend following this guide to try and get things fixed: https://www.tonymacx86.com/threads/an-idiots-guide-to-imessage.196827/

If you look at my original post, you'll see how I'm super careful with certain IDs in my clover.config file -- that's nearly 100% so that I don't screwup my iCloud connection. Merry Christmas and good luck!
 
Joined
Nov 2, 2013
Messages
34
Motherboard
ASUS TUF Z390-PRO GAMING
CPU
i9-9900K
Graphics
RX 570 + UHD 630
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Is your startup slower than it used to be? Mine hangs on the bios splash screen a little longer than it used to.
My boot got slower when some clover update turned debug flag on in config.plist, just figured this out today and now it's back to super-fast boot.
 
Joined
Sep 15, 2012
Messages
54
Motherboard
GA-Z77X-UP5-TH
CPU
i7 3770K
Graphics
GTX 760
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
  2. Quadra
Mobile Phone
  1. iOS
My boot got slower when some clover update turned debug flag on in config.plist, just figured this out today and now it's back to super-fast boot.

Sadly I think my machine is just getting old. On every boot it tells me a disc inserted is the wrong format but I can't figure out what it thinks it the wrong format-- maybe my windows partition? My system won't sleep, frequently it seems to just junk up from leaving it on too long even if nothing is open and will struggle with internet until I restart it (it's hard wired). But I will look into the debug flag and maybe that will help some things. Still afraid to update to catalina right now, it's functioning better than it did 6 months ago where I couldn't have any USB drives plugged in.
 
Status
Not open for further replies.
Top