Contribute
Register

[Success] Music Production w/ Sierra + GA-Z170X-GAMING 7 + GTX 1050 Ti + Thunderbolt Guide

Joined
Apr 15, 2019
Messages
4
Motherboard
z170x
CPU
i5 6600k
Graphics
On Board
Just checking in that I was able to upgrade an older Hackintosh build I had with a GA-Z170X-Gaming 7 board and a i7-7700K and successfully have connected and used an Apogee Element 88 Thunderbolt on High Sierra 10.13.6. The Element software and the Logic integration worked perfectly after flashing the USB Type-C on Windows as instructed (don't know if it would work without flash, I didn't try it first). @insalada 's guide was extremely helpful and still very accurate!

I've seen several posts about UA Apollo Thunderbolt interfaces working but nothing on Apogee, and just wanted to post about my success.

Note: I stayed on High Sierra due to the Nvidia Web Drivers still not supporting Mojave. I might switch to AMD eventually but with current GPU costs I decided to make the GTX 970 work, it's still very capable.

Build:

(New to this build)
MB: GA-Z170X-Gaming 7
CPU: i7-7700K
RAM: Ballistix Sport 16GB 2666mhz
TB: Apple Thunderbolt to USB Type-C Adapter

(Donated from my old build)
GPU: MSI GTX 970
WiFi: TP-Link WDN4800 PCIe - works OOTB
FW: StarTech 1394b PCIe - works OOTB
PSU: Corsair CX750M
Case: NZXT Phantom (USB 2.0, 3.0 and eSATA on front panel header)
SSD: Samsung Pro 850 x2 (Dual boot Windows for gaming)

Build installation notes summary:

Following insalada's guide, everything worked great pretty much on the first try. Had to use -disablegfxfirmware when using the iGPU since my CPU is 7th gen. I did not have the common issue with the Nvidia driver remaining selected so I was able to skip that step. Only issue that I had to address was the USB 3.0 port on the case header wasn't working, I added a kext patch and it works great now (full notes below). I was able to successfully restore my apps and plugins using Time Machine by leaving the "Other Files and Folders" option unchecked in Migration Assistant.

Full build and installation notes:

Before starting, I did a clean install of Windows 10, I was never able to update the boot to UEFI using MBR2GPT so I took the opportunity to build a new install USB, wipe the SSD clean, and re-install with UEFI. I keep all of my game files on a separate drive so nothing except a few drivers and programs were lost. It was worth it as Clover stopped recognizing the drive after a recent update (even with legacy turned on) and I had to change boot order in the BIOS anytime I wanted to get to Windows. After this I unplugged all Windows drives to make life easier.

My old build was running High Sierra 10.13.6. The old build had an i7 3770K and an old Gigabyte Z77 series board, so I elected to do a completely clean install of High Sierra.

I created two backups of my Hackintosh drive - one using CCC and one using Time Machine. My hope was that I could use Time Machine to re-install all of my music production apps (Logic, Pro Tools, Final Cut, plugins etc.) without having to find and re-download them all. More on that later. CCC backup was plan B, and also a bootable backup in case something went wrong.

Disassembled and rebuilt the system without issue. Spent about an hour cleaning out dust and the fans...it had been a while!

I used Windows to test the system. It worked pretty well OOTB, I had some issues with the USB keyboard and mouse not working unless I replugged them. I downloaded the Gigabyte App Center and made sure the drivers were up to date etc, something it updated fixed the USB issue. I also checked that the BIOS was the latest version, it has to be the most updated for full 7th gen CPU support. I then flashed the USB Type-C connector for Thunderbolt, I used the link insalada provided after Gigabyte App Center ran some sort of Thunderbolt update, but only insalada's link appeared to flash the MOBO. FWIW.

After that I did something I always do, which is remove non-natively supported Nvidia GPUs until I've got a stable install booting and running. Using the iGPU on Gigabyte boards always seems to work and I don't waste any time fighting the USB installer or getting that first boot. I removed the GPU and changed all of insalada's recommended BIOS settings EXCEPT for the iGPU, which I left enabled. Connected my ASUS monitor via HDMI to the board and we were off and running.

USB High Sierra installer worked without issue. When I went to boot for the first time, it got stuck with an iGPU error near the end. I did some research and added -disablegfxfirmware via Clover and it booted up just fine (seems to be the i7 7th gen CPU). I went through the setup and ran Multibeast with the insalada's suggested options. FYI that when I was doing some unrelated troubleshooting I found that selecting iMac 17,1 is really important for 6th gen CPUs and above, do not skip that step.

After MultiBeast, I restarted the computer and removed the High Sierra installer USB to see if I'd pulled it off. Success! Clover popped up and I got to the desktop in no time. Time to get the GTX 970 working. I updated to High Sierra 10.13.6 using the Combo update and installed the appropriate Nvidia Web Drivers. Shut down the computer, reinstalled the GPU, disabled iGPU in the BIOS, and successfully booted up again!

I don't how I got lucky, but when I selected the Nvidia driver and restarted, it was the selected driver upon reboot so I didn't have to mess with EmuVariableUefi-64. I had done some research to prepare for the worst so let me recommend that if you are starting from scratch...just get a natively supported AMD card! I also always have issues with background rendering in Final Cut with non-supported Nvidia GPU's, I'm sure an AMD card would make the experience much smoother. I didn't mess with the SSDT for the CPU, might later if I have time.

So...holy ****...did I just have a basically no-issue Hackintosh install with all new hardware on a non-recommended MOBO? I thought for sure that all my Hackintosh karma had been used up for the year and that the Element 88 wouldn't work.

The Element curiously does not have a power button, it receives a signal via Thunderbolt to turn on. I thought this might be a deal killer with the hot-swap TB issues, but it works! I shut the computer down, plugged in the TB cable using the USB Type-C adapter, the Element powered on, and the Element software immediately recognized it. YES! I as able to select it as the Output device in Settings and I had Spotify blaring over my monitors in short order. Audio sounded great, no issues there. The volume buttons on the keyboard even worked to control the headphone output levels. I did test and the Element has to be plugged in before powering on the computer for it to work, you can't hot-swap it in while the computer is on. The USB hardware remote worked great as well.

After that, I tested all of the USB ports and everything on the back worked, but the USB 3.0 port on the case header didn't (USB 2.0 did). AHA! Finally an issue. For some reason that made me feel better, hahaha. I did some research and found out it's a silly issue where the iMac 7,1 doesn't have that many USB ports so it just doesn't recognize them. Increase Max Port Limit and Generic USB 3.0 Support options in MultiBeast didn't do the trick like they do for others. I found this excellent guide and used Clover Configurator to add the appropriate kext patch and the port began working. Total success!

The last and only issue is for some reason the Power LED doesn't come on, but it had stopped working a while ago (I thought it might be the board) so it must be the case instead. Maybe I can fix it, probably won't mess with it since all the fans have LEDs.

I plugged in all of my drives, including Windows drives, and booted 'er up again. Everything worked, and I could get to Windows from Clover. Awesome!

I made a backup of the new Hackintosh drive using CCC and was ready to try and restore apps and my library from Time Machine. I did some research, and it seemed like this can work well if you leave the "Other Files and Folders" unchecked in Migration Assistant. That worked great for me and everything seems to have been moved over, of course some of the plugins licenses and iLok were a pain to get working but that's to be expected on any new machine.

HUGE THANK YOU to @insalada for the guide!!! I hope my post gives others confidence to do similar builds.

Cheers!

Hey man, have been trying to get my first build up and I'm having trouble getting past the installer. About 70-80% into the High Sierra installation the system reboots first into the apple logo with text under the bar that reads "About 18 Minutes" a few minutes later I'll get another reboot into a black screen. Any idea what it could be? I'm following the same steps you and the OP posted..

Z170X Gaming 7
i5 6600k
On-board graphics
Samsung Evo 860 SSD
16gb
Antelope Audio Discrete 8
RME Babyface Pro
 
Top