Contribute
Register

[Success] MSI Z77A-G45 Clover Install

Status
Not open for further replies.
Joined
Dec 1, 2012
Messages
71
Motherboard
ASUS ROG Strix F Z390
CPU
i7-9700K
Graphics
6800XT (Powercolor Red Dragon)
Mac
  1. MacBook Pro
Hi,

Have you managed to get El Capitan installed on your Z77MA-G45? I have the same mobo and want to give it a try - but also keen to not waste loads of time if its a non-starter

Cheers

I'd like to know, too. I spent quite a while trying on patched 1.40 BIOS, but couldn't get Clover to work. I'm going to attempt to try with the newest BIOS and patch it if possible, but I'm in an important work phase so it'll be a few months before I want to risk breaking my stable Yosemite machine.
 
Joined
Oct 4, 2012
Messages
34
Motherboard
MSI Z77MA-G45
CPU
i7-3770
Graphics
HD4000
Mac
Classic Mac
Mobile Phone
I'd like to know, too. I spent quite a while trying on patched 1.40 BIOS, but couldn't get Clover to work. I'm going to attempt to try with the newest BIOS and patch it if possible, but I'm in an important work phase so it'll be a few months before I want to risk breaking my stable Yosemite machine.

How hard was yosemite to get on it? I might give that a try if it wasn't too bad. What settings/bios etc did you use?
 
Joined
Oct 4, 2012
Messages
34
Motherboard
MSI Z77MA-G45
CPU
i7-3770
Graphics
HD4000
Mac
Classic Mac
Mobile Phone
How hard was yosemite to get on it? I might give that a try if it wasn't too bad. What settings/bios etc did you use?

I managed to get Yosemite installed and working using Clover legacy mode. Sleep worked perfectly and one of the USB3.0 ports seemed to be working - but couldn't test the actual speed.

I'm going to try El Capitan in legacy mode and see if that works. Will post back.
 
Joined
Dec 1, 2012
Messages
71
Motherboard
ASUS ROG Strix F Z390
CPU
i7-9700K
Graphics
6800XT (Powercolor Red Dragon)
Mac
  1. MacBook Pro
How hard was yosemite to get on it? I might give that a try if it wasn't too bad. What settings/bios etc did you use?

No problem at all, but I'm still using Chimera which I know I'm going to have to change in future if I want to move on from Yosemite. I used the patched 1.40 BIOS and installed the ALC 892 kext for audio from Multibeast. Everything works fine apart from USB 3.
 

wildwillow

Moderator
Joined
Jun 26, 2012
Messages
4,560
Motherboard
Z170 Deluxe
CPU
i5-6600K
Graphics
GTX 970
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  2. Other
Joined
Dec 1, 2012
Messages
71
Motherboard
ASUS ROG Strix F Z390
CPU
i7-9700K
Graphics
6800XT (Powercolor Red Dragon)
Mac
  1. MacBook Pro
I'm still booting Yosemite with Chimera on my H77N-WIFI. I've also got another drive with El Capitan using Clover. There is a guide here if it helps you in the future GUIDE : CustoMac Mini 2012 | H77N-WIFI | i3-3225 | HD4000 | OS X 10.11 similar system. Do you know the controller of your USB's?

Thanks, although the problem is I can't get Clover to boot into the installer in the first place. I asked questions about it a few months ago but nothing seemed to work, and I've given up for the interim because I'm busy finishing my thesis and I don't want to screw up my install. The USB 3 is the default Intel Z77 spec (no 3rd party ports according to the MSI website).
 

wildwillow

Moderator
Joined
Jun 26, 2012
Messages
4,560
Motherboard
Z170 Deluxe
CPU
i5-6600K
Graphics
GTX 970
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  2. Other
Thanks, although the problem is I can't get Clover to boot into the installer in the first place. I asked questions about it a few months ago but nothing seemed to work, and I've given up for the interim because I'm busy finishing my thesis and I don't want to screw up my install. The USB 3 is the default Intel Z77 spec (no 3rd party ports according to the MSI website).

Good luck with the thesis. If and when you install El Capitan you could try adding FakePCIID.kext and FakePCIID_XHCIMux.kext to your UniBeast installer. Install to EFI/Clover/Kexts/10.11.
Reference to latest kexts here under 7/8/9 series: CustoMac Desktop USB Fixes - OS X 10.11 El Capitan - Reference ...
 
Joined
Oct 4, 2012
Messages
34
Motherboard
MSI Z77MA-G45
CPU
i7-3770
Graphics
HD4000
Mac
Classic Mac
Mobile Phone
Joined
Oct 4, 2012
Messages
34
Motherboard
MSI Z77MA-G45
CPU
i7-3770
Graphics
HD4000
Mac
Classic Mac
Mobile Phone
No problem at all, but I'm still using Chimera which I know I'm going to have to change in future if I want to move on from Yosemite. I used the patched 1.40 BIOS and installed the ALC 892 kext for audio from Multibeast. Everything works fine apart from USB 3.

I got Yosemite working on it ok. USB3 ports seemed to be working - dont' know at what speed though. Am I right in assuming that El Capitan is never going to be possible on this mobo?
 

wildwillow

Moderator
Joined
Jun 26, 2012
Messages
4,560
Motherboard
Z170 Deluxe
CPU
i5-6600K
Graphics
GTX 970
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  2. Other
I'm going to bite the bullet and get a new MoBo and CPU. Just need to decide which now
Just be aware if you are considering using parts from your existing build, hardware such as PSU would need to "Haswell Ready" or "Haswell Certified" this is also true with Skylake builds due to the lower CPU idle speeds. Memory on newer boards have become finicky and you should refer to the manufacturers Qualified Vendors List (QVL) and many 100 series use DDR4. Just a heads up.
Have you tried installing El Capitan with RehabMans's kexts from Post#17?
 
Status
Not open for further replies.
Top