Contribute
Register

[Success] MSI Z390-A PRO | i5 8400 | AMD R9 380

Joined
Jun 25, 2014
Messages
83
Motherboard
MSI Z390-A PRO
CPU
i5 8400
Graphics
R9 380
Mobile Phone
  1. iOS
dr.kkarun’s Build:
MSI Z390-A Pro - Core i5-8400 - AMD Radeon R9 380

Components

MSI Z390-A PRO ATX Motherboard | Amazon

Intel Core i5-8400 - Processor | Amazon

G.SKILL Ripjaws V Series 16GB (2 x 8GB) DDR4 3200MHz Desktop Memory (CL16-18-18-38 1.35V) | Amazon


Already Owned

AMD Radeon R9 380 GPU - Gigabyte Windforce GV-R938G1 GAMING-4GD
Samsung 840 EVO series 250GB SSD
Seasonic X series 750W 80 PLUS GOLD Certified Modular Power Supply
Asus VS247H-P 23.6-Inch Full-HD LED-Lit LCD Monitor
WTXUP BCM94360 867Mbps PCIe WIFI+Bluetooth
Cooler Master Hyper 212x CPU cooler



Comments

As my Asus Maximus VI Hero motherboard (my first hackintosh build) had gone into some boot issues, I decided to give my build an upgrade. I bought a new MOBO + CPU + RAM. All other components are from my previous build. I chose the MSI Z390-A PRO because it's one of cheapest Z390 boards. I don't need overclocking, so I chose non-K processor.

Installation (macOS Catalina 10.15.3) is through usual procedure as per guide (with Clover) with the below mentioned drivers and kexts.
SMBIOS - iMac 19,2. But this motherboard needs certain additional tweaks - ACPI patch, MSR unlock patch, Framebuffer injection for UHD 630 graphics.

Everything works fine for my needs.

Drivers
  • ApfsDriverLoader.efi
  • AptioMemoryFix.efi
  • HFSPlus.efi (needed for fresh installation from USB)
Kexts

Additional requirements for MSI Z390-A PRO
  • DSDT patch for ACPI, if the BIOS version is latest/recent. My BIOS version is V18.
Name : DSDT patch
Find : A00A9353 54415301
Replace : A00A910A FF0BFFFF
  • MSR Unlock patch: Unlike Asus, this Mobo is MSR locked. Needs either KernelPm (in clover) or BIOS patch through EFI Shell. See post#15
With these patches, I was able to install macOS Catalina 10.15.3 (using AMD graphics R9 380) with USB2 port. Post install, I have added the following patches into my DSDT (Clover can do most of these)
  • ACPI patch (described above)
  • RadeonDeInit patch & Lagotto framebuffer injection for R9 380 along with HDMI audio
  • Audio id:2 & pin configurations into HDEF (HDAS) - needed for HDMI audio to work
  • AddDTGP (needed for DSM patches to work)

USB#3 port patch
USBInjectAll.kext with two port-limit patches for Catalina works fine [link]. Since SSDT method is recommended, I tried to inject SSDT-UIAC for my motherboard [link]. But it didn’t work for me. Then I reverted back to the method which I had used in my previous build. I have deleted 4 unused internal USB2 ports from DSDT and SSDT (xh_cfsd4), which increased the number of working USB3 ports from 1 to 5. Working fine now.

USB port limit.png

Catalina.png
Geekbench.png

Unigine Benchmark.png

R9 380 graphics (Lagotto framebuffer), wifi & bluetooth work OOB.
Have been using UHD 630 graphics in headless mode, with AMD graphics as primary.
Audio - HDMI audio through R9 380.


Whats not working
  • HWPEnable - HWPEnable with Piker’s MSR 0xE2 lock patch results in Kernel panic. No need to worry as XCPM (plugin-type) is working fine.

Update 1 (2020-02-26)
  • The attached config plist (without SMBIOS) includes patches for Intel UHD 630 graphics (VGA + DVI + DP) and layout-id for audio through Devices --> Properties injection
Update 2 (2020-06-21)
  • Shifted to OpenCore bootloader (0.5.9). Everything work fine till now. Guide here.
  • USB port injection is through USBMap kext (built according to my needs using USBMap command), along with SSDT-EC-USBX.
  • Note: SMBIOS & Graphics patches (IGPU / AMD R9 380) will be missing in the EFI folder attached below.
 

Attachments

  • config.plist
    5.7 KB · Views: 96
  • OpenCore EFI.zip
    3.2 MB · Views: 145
Last edited:
Joined
Jul 2, 2012
Messages
7
Motherboard
MSI Z370-A-Pro
CPU
i5-9600K
Graphics
RX 570
After many hours of trying these files and instruction, I too have things working. Took me a while but found that the MSI Z390-a Pro would not work with my Radeon RX 570 in the 16X PCI slot, Integrated UHD 630 didn't work, but found that a card worked in the 4x slot. Older Nvidia card worked in the 4x slot, but limited graphics. Never got the UHD 630 integrated to work. Without any video card in the 4x slot, system would load the best I saw from Clover configurations but would reset when Id expect the OS to load. Added older Nvidia into 4x slot and got to installation. Copied EFI to my previous system's SSD and booted fine....

MSI Z390-a pro motherboard
Intel i5-9600k
32 GB 3200 Corsair Vengence GB (wish I could shut off the LEDs)
C-Media USB for audio (although Realtek audio ALC892 installed)
Some sort of Wifi but cant remember, disabled integrated Network, serial port, and parallel port in Bios

Used the config.plist from above and added the aml files to Clover patched directory. Added the drivers for EFI, Kexts, and KernelPM downloaded from this thread. Added the DSDT patch but in serial (not sure if this was the right way, maybe some clarification?) I'm no Clover genius.

Find : A00A9353 Replace : A00A910A
Find :54415301 Replace : FF0BFFFF

Turned XMP on to get 3200MHz for the ram.

All seems well so far. Only thing not working is 3.1 USB on front of case - doesn't seem to work at all.

Using the 16x slot seemed to be the only bottleneck I experienced.


Thanks, dr.kkarun!
 
Last edited:
Joined
Jul 2, 2012
Messages
7
Motherboard
MSI Z370-A-Pro
CPU
i5-9600K
Graphics
RX 570
Oh, and key point is to use 2.0 USB port if installing fresh or validating the settings (which you mentioned). Good luck , others!
 
Joined
Jun 25, 2014
Messages
83
Motherboard
MSI Z390-A PRO
CPU
i5 8400
Graphics
R9 380
Mobile Phone
  1. iOS
@ hipcatinca,
Glad to hear that it worked for u. I don't think u have used my DSDT and SSDT, as ur motherboard is different from mine, although similar in most aspects.

Did u create and patch ur own DSDT? In case if u have used my DSDT, there is no wonder for RX 570 not working in x16 slot, as my DSDT has patch for R9 380 in that slot. I think RX 570 will work OOB. Just try this config attached below (without any DSDT or SSDT under patched in EFI) after adding ur Smbios to see if ur graphics work in x16 slot (after proper BIOS settings).

Regarding iGPU, it will work after proper patching. I have added patches for DVI port in the config plist (no harm in having it). It may not work as ur Mobo is different. For VGA & Displayport, I will figure out after I get those cables and will update the first post. Experiment urself with Hackintool following this wonderful guide by CaseySJ.

Good luck...
 

Attachments

  • config.plist
    8.1 KB · Views: 93
Joined
Jul 2, 2012
Messages
7
Motherboard
MSI Z370-A-Pro
CPU
i5-9600K
Graphics
RX 570
Hi dr.kkarun,

I edited my post as I made a mistake. It is in fact the same MB as yours (MSI Z390-a pro). Would you mind to update the Config for the MSI Z390-a pro with a Radeon RX 570 in the 16x slot (or lack of R9 380 anyhow). I think you are correct that it should work natively. Might as well clean up my config and move the card. I'd be happy to try. I believe I left the SMBIOS as you had in your original config.
Or is it perhaps all I need to do is remove the patched DSDT file and then leave the two SSDT files in the directory?
Also, I assume to leave the DSDT patch in the configuration as I have the V18 bios?

Thank you much for your response,
Jeremy
 
Joined
Jun 25, 2014
Messages
83
Motherboard
MSI Z390-A PRO
CPU
i5 8400
Graphics
R9 380
Mobile Phone
  1. iOS
@ hipcatinca

All my graphics patches are in my DSDT, not in config. I have those graphics patches just for cosmetic reasons (not mandatory) and HDMI audio. Clover will inject the name 'ATI Radeon R9 285', as both have same device ids. In addition, my DSDT will have 4 USB2 ports (internal headers) removed. Final words, u can't use my DSDT unedited.
U have to compile ur own DSDT according to ur needs, LATER.

All u need to do is to try only the config file attached in post#4 (without any DSDT or SSDT), after adding ur desired SMBIOS settings, as both of the attached config files will not have System Serial Number, Board Serial Number & SmUUID. Also add USBInjectAll kext in addition to the kexts mentioned in post#1. In case if u want to use UHD 630, then DVI-D will work (patch included), other ports not verified.
 
Joined
Jul 2, 2012
Messages
7
Motherboard
MSI Z370-A-Pro
CPU
i5-9600K
Graphics
RX 570
I did as you said and the GFX card is working in the 16x slot. Sound doesn't seem to be working but I use a cheap USB device anyhow. I don't have an easy way to verify LAN since I use WiFi, but maybe someone else will confirm also. Many thanks for your help!
 
Joined
Jun 25, 2014
Messages
83
Motherboard
MSI Z390-A PRO
CPU
i5 8400
Graphics
R9 380
Mobile Phone
  1. iOS
@ hipcatinca

Realtek ALC892 codec needs AppleALC kext along with layout id (boot-arg or through DSDT).
If u upload ur IORegistry Explorer or IOJones output, then I will patch for u and upload DSDT with config, with which HDMI/DP Audio of amd graphics will work. Motherboard audio will need AppleALC kext along with the patch.
Since I use only R9 380 HMDI audio, I didn't install AppleALC kext.
 
Joined
May 4, 2020
Messages
6
Motherboard
MSI Z390-A PRO
CPU
i5-9500
Graphics
RX 570
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hey @dr.kkarun,
I just bought the exact same MOB, with an i5 9500 and an RX570. I believe I can follow the same step by step that you left. Would it be possible to send your EFI?

Two additional questions:
1. You said: ethernet work OOB?
2. Are the USB 3.0 and 3.1 ports working?

thanks a lot dude.
 
Last edited:
Top