Contribute
Register

[SUCCESS] MSI B360 Gaming Plus - i7 8700 - GTX 1070 - High Sierra 10.13.4

Joined
May 4, 2018
Messages
123
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i9-9900K
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
iOS
No dice on the clean reinstall. Do you mind sharing your EFI folder so I can compare mine? I'm interested to see how you have yours set up.

Thanks!
Sure thing! Just bear in mind my old EFI folder has an SSDT meant for my B360 Gaming Plus USB configuration, so plug and play may be sub-optimal. There is, however, a power management SSDT that you may benefit from.
 

Attachments

Joined
Jan 11, 2018
Messages
41
Motherboard
MSI B360M Mortar Titanium
CPU
i7-8700
Graphics
UHD 630 + Vega 64
Mac
iMac, Mac mini
Mobile Phone
iOS
Sure thing! Just bear in mind my old EFI folder has an SSDT meant for my B360 Gaming Plus USB configuration, so plug and play may be sub-optimal. There is, however, a power management SSDT that you may benefit from.
Thanks! I compared our EFIs and just noticed I was carrying additional kexts that I should not have been supporting anymore so I got rid of those. I copied how you have set up ACPI in Clover Configurator sans the custom SSDT.

The above got me using the iMac18,3 SMBIOS, which I couldn't get working with DP, I'm thinking its one of your kexts. The only kext you have that I didn't was Shiki though which I thought was already integrated with WhatEverGreen kext.

Despite all of the above, shut down still didn't work. As an additional issue ,when I put the computer to sleep, it looks like only the display turns off as the keyboard, case lights and GPU fans still spin.

Was gonna call it a night until I found a thread here: https://www.tonymacx86.com/threads/solved-mojave-reboot-when-waking-from-sleep.261061/

Basically, it has you delete com.apple.powermanagement files from /Library/Preferences. Everything works great after!

So I don't know what wasn't working but its fixed for now. Have you updated to 104.2 BTW and is a direct update okay?

Thanks for all your help man you have been a selfless and awesome resource!
 
Joined
May 4, 2018
Messages
123
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i9-9900K
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
iOS
Thanks! I compared our EFIs and just noticed I was carrying additional kexts that I should not have been supporting anymore so I got rid of those. I copied how you have set up ACPI in Clover Configurator sans the custom SSDT.

The above got me using the iMac18,3 SMBIOS, which I couldn't get working with DP, I'm thinking its one of your kexts. The only kext you have that I didn't was Shiki though which I thought was already integrated with WhatEverGreen kext.

Despite all of the above, shut down still didn't work. As an additional issue ,when I put the computer to sleep, it looks like only the display turns off as the keyboard, case lights and GPU fans still spin.

Was gonna call it a night until I found a thread here: https://www.tonymacx86.com/threads/solved-mojave-reboot-when-waking-from-sleep.261061/

Basically, it has you delete com.apple.powermanagement files from /Library/Preferences. Everything works great after!

So I don't know what wasn't working but its fixed for now. Have you updated to 104.2 BTW and is a direct update okay?

Thanks for all your help man you have been a selfless and awesome resource!
Heyo! That's amazing news. Congrats!

I updated my NVMe to 10.14.2 (been on the beta for a month) after installing my new processor and mobo, and it was indeed just fine. Always be sure to have a CCC backup on hand just in case, but so far Mojave has been totally a painless experience.

I'm always happy to help where I can, man. :)
 
Joined
Jan 11, 2018
Messages
41
Motherboard
MSI B360M Mortar Titanium
CPU
i7-8700
Graphics
UHD 630 + Vega 64
Mac
iMac, Mac mini
Mobile Phone
iOS
Heyo! That's amazing news. Congrats!

I updated my NVMe to 10.14.2 (been on the beta for a month) after installing my new processor and mobo, and it was indeed just fine. Always be sure to have a CCC backup on hand just in case, but so far Mojave has been totally a painless experience.

I'm always happy to help where I can, man. :)

Love the attitude! Really helpful!

Im 90% done with mine. If I find a way to get the DisplayPort audio on my RX 580 working, I'll be at 100% :)
 
Joined
May 4, 2018
Messages
123
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i9-9900K
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
iOS
That's something I haven't really tried or tested. I use a SoundBlaster 5.1 USB soundcard, so audio has never really been an issue for me. Try the different injectors using AppleALC.kext
 
Joined
Jan 12, 2018
Messages
5
Motherboard
MSI B360 PRO-VD
CPU
i5 8600
Graphics
UHD 630
I tried using your EFI but there was a block sign, What setting should I change for my specs?
Mobo: MSI B360 PRO-VD
Intel i5 8600
8GB DDR4 RAM
Intel UHD 630(Intel graphics only)
 
Last edited:
Joined
May 4, 2018
Messages
123
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i9-9900K
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
iOS
My guess is you will need to make changes that allow for your IGPU to be used, my EFi folder was set up for use with a discrete GPU. Boot with the -v flag and post your output.
 
Joined
Jan 12, 2018
Messages
5
Motherboard
MSI B360 PRO-VD
CPU
i5 8600
Graphics
UHD 630
My guess is you will need to make changes that allow for your IGPU to be used, my EFi folder was set up for use with a discrete GPU. Boot with the -v flag and post your output.
but it looks like macos 10.13 is working but not 10.13.6
 
Joined
Jan 11, 2018
Messages
41
Motherboard
MSI B360M Mortar Titanium
CPU
i7-8700
Graphics
UHD 630 + Vega 64
Mac
iMac, Mac mini
Mobile Phone
iOS
@MESwan Hi again! I saw a pretty sweet deal on a Gigabyte RX Vega 64 OC do you think that would work plug and play?
 
Joined
Jan 11, 2018
Messages
41
Motherboard
MSI B360M Mortar Titanium
CPU
i7-8700
Graphics
UHD 630 + Vega 64
Mac
iMac, Mac mini
Mobile Phone
iOS
@MESwan Hi again! I saw a pretty sweet deal on a Gigabyte RX Vega 64 OC do you think that would work plug and play?
Actually ignore this. If anyone wants to know Gigabyte RX Vega 64 Gaming OC works automagically with @MESwan’s config! :)
 
Top